Solved

Marshmallow broke text messaging?


  • First activity
  • 2 replies

I have an S6 and after the recent 6.0.1 update group texts no longer work.  I can create a group and send a text to said group and it'll show up on each participants end as a direct text.  They won't see any of the other people in the group, it'll look just the same as if I texted them directly.  And when they reply it'll be a direct text as well.  It doesn't show their texts in the group at all.

 

I had a different model phone in the past and had this issue, but the S6 worked as expected on the previous version of the OS.  Now after the update it's broken and doesn't work.  I have a friend on AT&T that has the same phone and same OS version and his works fine.  So what gives?  Is there a fix for this?

icon

Best answer by tmo_mike_c 18 April 2016, 01:18

Sorry for the confusion. This was a network fix that was corrected on T-Mobile's end. This wouldn't have shown up as an update on the device. There was backlog issue but it should be working after you restart your phone.

View original

42 replies

I've had the same problem. I installed the Marshmallow update on my S6 yesterday. I received a group text yesterday after the update, but I never responded so I did not notice a problem. Today I sent out a text, like i normally did before the update, to 4 people. Everyone got a direct message from me, could not see the other people on the text and when they replied to me, it came in as a direct message, not in the group text I had sent out. We need a fix!!!

Same as above!

Userlevel 6
Badge +14

Greetings to you all, and thanks for posting. Is everyone here using the standard messaging application? If not, can you uninstall any 3rd party messaging apps and retest?

Hi,

I was using the native app with no other apps. I switched to Hangouts and it seemed to resolve the problem and then I downloaded Google's new Messenger App from the store and it is working as well.

Thanks!

Userlevel 6
Badge +14

Thanks for that info. Have you tried clearing the cache and data for the native app? It would clear out any messages in there, but I'd like to see if that helps out at all.

Hello,

I gave that try but it still sent group messages out as texts to individuals.

Thanks, Mike!

Userlevel 6
Badge +14

Hmm, that's strange it still does that. What about a complete reset? Most of the time, this can clear up things like this up after a software update.

I factory reset.   Still broken.   Sending group conversations as sms instead of mms.  3rd party apps work fine.

I'm having this same issue. I've wiped my cache partition and performed a factory reset but the issue is still there. I also spoke with T-Mobile tech support over the phone about this issue yesterday but they were also unable to fix it, a ticket was submitted to "engineering".

Userlevel 6
Badge +14

Okay, thanks for letting me know @maloofah‌. Have you noticed a difference if your VoLTE setting is turned on? If you haven't already, can you turn it off for a moment and try the group messaging.

If anyone else has tested this already, send me a private message with the following information:

  • Master reset (yes/no)
  • Troubleshooting you've done
  • IMEI:
  • Android version:
  • Build version:

To send me a private message, hover your mouse over my name and click the Message button with the grey envelope. I'll forward your information internally to have this looked at further. Thanks everybody.

I don't see an message icon, but ever since the marshmallow update I can send and receive group mms, however once I get a reply, I end up receiving a single sms from the individual and not within the group mms.

Userlevel 6
Badge +14

Hey there @ucubed

Can you check for that message icon again for me? I'd also ask that you complete the troubleshooting that's been mentioned in previous threads. Thanks!

I'd like to clarify what is going on now that I think I have a grasp of the situation. 

I can receive and initiate group mms.  I can send them out via a group mms, and I can receive messages in a group mms.  The problem is once I send out the messages, it goes out individual and the receiving person ends up getting a single sms isntead of a group mms and when they reply back they don't realize that it converted into a sms instead of the group mms if that makes sense.  I only use the native app and I've "turned" off any other messaging app that I have that may cause an issue.  I've cleared the cache, data and did a reset.  I have the Galaxy S6 and just updated to the Marshmallow OTS update

I could not find the message icon either, but it was because i was not logged in. Try logging in and then hover over his name and the message icon should be at the bottom of the box with a grey envelope.

Did your group text recipients receive the text as a group text or as an individual text from you? My recipients could not see others in the group text, they received my text as a direct text and not as part of the group text i sent out. They simply thought i had text them directly.

Same issue as @ucubed here.  Clearly this is an issue that needs to be addressed on the dev / tech side.  If anyone finds that wiping all your stuff and doing factory resets actually works, will you please let me know?  I don't want to clear or lose all of my message threads just to hope it will work...  In the meantime, anyone know of a good app to use that's working for group messaging?

I am having the same issues as above. I send a group message and each person receives an individual text just from me, and does not see anyone else in the group.

Then when I receive a message from a group text, I get single text messages just from each individual person, rather than it being in the group text.

This is extremely annoying and needs fixing ASAP!

I would like to another another report of this issue.

To be honestly, I am entirely not impressed with this "upgrade".  Had a number of issues:

update caused Outlook app to go nuts, couldn't even keep myself logged into my company's email - then app force closing.

double or ghost notification sounds - would receive double sound notification for a text, once during the initial receipt, then upon unlock.

And this dreaded group messaging being broken.

I factory reset last night, and group messaging was working since last night, until about an hour ago.  VoLTE has been enabled all this time....

@ misseluna - Textra app works for group texts, give it a shot.  I prefer the default app over Textra, but at least with Textra I can group text again. 

It broke it for me too.  I installed the Google Group Messenger and it works.  So something is wrong with the stock app.

Jim

misseluna - Textra works for group text.  For some odd reason the moderators deleted my other post that said the same thing.  Are we not allowed to suggest alternatives?  No explanation was given as to why it was removed and since there doesn't seem to be a way to PM you I'll just post it again.  Fact is the default app doesn't work.  We should be allowed to discuss alternatives/work-arounds while T-Mobile hopefully fixes the problem.

Thanks for the suggestion.  I'll give it shot until the default app works.

Thanks!

My messaging issue is slightly different, but I do have to say that I have not had a group text since the update, so I may also have this issue when I finally do have one.

But my issue is that I am seeing duplicates of incoming texts. Not always and not always from the same person. They are direct texts (read: I am not on the receiving end of a group text) and I am using the stock messaging app and I did a master reset after I finished the Marshmallow install.

Userlevel 6
Badge +14

Hey folks just wanted to keep everyone updated on this. There was a fix sent out to resolve this problem with the stock messaging app. For those still having this issue, can you restart your phones and try the group messaging again? Please let me know the results. Thanks.

Reply