Solved

Phone won't download MMS

  • 17 February 2016
  • 5 replies
  • 5075 views

My Galaxy S5 won't download MMS ever since the most recent flurry of updates. To be clear, it used to be able to. This is regardless of if I'm on wifi, or the mobile network. It also cannot send any mms messages, and they immediately become grayed out with "Not Sent, tap to try again" displaying. (I'm using google messenger as my default texting client)

 

Any ideas on how to fix this?

icon

Best answer by 1-800-gio 13 April 2016, 16:45

OK so i have found a SOLUTION to this problem that worked for me. I hope this works for others. I have a Verizon Galaxy S5 with a t-mobile sim in there.  When i first put in the settings that everyone was giving me, Calls, Text and Internet worked but i could not send/receive MMS/Picture messages.  Here are some settings i found that  worked: (I am talking about adding a new Access point name)

Name:  T-Mobile US LTE

APN: fast.t-mobile.com

Proxy: Not Set (leave blank)

Port: Not set (leave blank)

Username: Not Set (leave blank)

Password: Not set (leave blank)

Server: Not set (leave blank)

MMSC :  http://mms.msg.eng.t-mobile.com/mms/wapenc

Multimedia message Proxy: Not set (leave blank)

Multimedia message Port : Not set (leave blank)

MCC: 310

MNC: 260

Authentication type : None

***NOW THIS HERE IS THE IMPORTANT PART I HAVE  FOUND THAT WORKS. ADD IT EXACTLY LIKE BELOW, NO SPACES****

APN type:  default,mms,supl,hipri,admin,mobile

APN Protocol : ipv4/IPv6

APN roaming protocol : IPv4

Bearer: Unspecified

Mobile virtual network operator type: None

press the menu button and click save.  Try to send/receive an MMS/Picture Message.

View original

5 replies

Userlevel 6
Badge +14

Hey @shino336‌ have you tried clearing the cache and force stopping the pre-installed application? I would power the phone off then back on and retest it to see if that helps.

OK so i have found a SOLUTION to this problem that worked for me. I hope this works for others. I have a Verizon Galaxy S5 with a t-mobile sim in there.  When i first put in the settings that everyone was giving me, Calls, Text and Internet worked but i could not send/receive MMS/Picture messages.  Here are some settings i found that  worked: (I am talking about adding a new Access point name)

Name:  T-Mobile US LTE

APN: fast.t-mobile.com

Proxy: Not Set (leave blank)

Port: Not set (leave blank)

Username: Not Set (leave blank)

Password: Not set (leave blank)

Server: Not set (leave blank)

MMSC :  http://mms.msg.eng.t-mobile.com/mms/wapenc

Multimedia message Proxy: Not set (leave blank)

Multimedia message Port : Not set (leave blank)

MCC: 310

MNC: 260

Authentication type : None

***NOW THIS HERE IS THE IMPORTANT PART I HAVE  FOUND THAT WORKS. ADD IT EXACTLY LIKE BELOW, NO SPACES****

APN type:  default,mms,supl,hipri,admin,mobile

APN Protocol : ipv4/IPv6

APN roaming protocol : IPv4

Bearer: Unspecified

Mobile virtual network operator type: None

press the menu button and click save.  Try to send/receive an MMS/Picture Message.

Thank you, 1-800-gio, that worked. I've followed purported solutions from various websites, including the usually-reliable developers, but none solved my problem. One thing to note for others who may find this: I also deleted the other APNs that were already there by default.

I have a similar situation, cannot download MMS pictures, but with an AT&T Galaxy S5 Active, and in Alaska on GCI network. Those APN settings do not fix the problem, and only allow for emergency calls...

Thank you! This worked immediately on my S6.

Reply