Solved

Samsung S7 Edge At&t To T-Mobile. Can't get 4G or any internet. Text & calls work


I recently switched over from At&T to T-Mobile. Today I didn't receive any texts or phone calls and missed some important calls at work. When I was walking to my car, I started getting all these text messages and voicemails. I got home and restarted the phone to see if that would fix it, and then I got a text message saying service is unavailable. I went to a T-Mobile store and they tried messing with the settings. I did a factory restart and still nothing. The only thing I can think of is I got a faulty refurbished phone from At&T or I got blacklisted for some reason

 

-AT&T Unlocked Refurbished Samsung S7 Edge

icon

Best answer by littleb411 1 May 2017, 21:54

Hi All,

Thank you for all the advice and comments. Sorry for the delay, but i don't know what i did besides putting in the APN settings manually. It took a couple days of just messing with the settings but it just worked. Now everything has been working fine since I posted my original question. I haven't restarted my phone to see if it still works since everything starting working. (knock on wood) but i hope everyone can get theirs to work 😊

View original

27 replies

Even i'm having the same problem. I have unlocked my S7 EDGE phone from ATT but thru TMobile mobile data is not working and even WIFI Calling feature itself Grayed Out.

Tmobile asking me to contact ATT and ATT guys asked me to contact Tmobile. I'm not sure what to do now.

Its brand new phone, but carrier switching screwed my phone like this.

Userlevel 6
Badge +13

WiFi calling will only work on a T-Mobile branded phone.  That's not an app you can download.  It's built into the OS version on T-Mobile phones.

You're gonna have some issues at times with phones brought from other carriers.  Compatible doesn't mean completely.

CARRIERNETWORK3G BANDS3G FREQUENCIES4G LTE BANDS4G LTE FREQUENCIES
AT&TGSM/UMTS/HSPA+2, 51900, 8502, 4, 12, 171900, 1700 abcde, 700 bc
VERIZONCDMA0, 1850, 19002, 4, 131900, 1700 f, 700 c
T-MOBILEGSM/UMTS/HSPA+2, 41900, 1700/21002, 4, 121900, 1700 def, 700 a
SPRINTCDMA10, 1800, 190025, 26, 411900 g, 850, 2500

Then what about Mobile Data issue. Why its not working on my ATT Unlocked

phone. What i need to do now.

I have done Factory reset too. but still the same issue. (APN Setting done)

Userlevel 7
Badge +12

It should work if you input the APN correctly. Make sure you have global roaming turned on too.

My internal Roaming option is ON but on top it says 4G LTE but not

internet. I don't know what to do now.

Userlevel 6
Badge +13

Hmm, that's really weird. As long as the APN settings are correct, it should work. It's not something we can guarantee, but more often than not, it works on unlocked. Do you have a T-Mobile phone you could test your SIM in for a moment just to make sure this issue isn't following to another phone?

Userlevel 6

Hey there!  I just wanted to check in here and see if you'd had a chance to test that SIM in another phone.  How is everything going?

- Marissa

I have the same exact problem. Tech support tried all kind of things.

I tried the sim card to another phone, tmobile phone, it works just fine.

What is it with ATT unlocked phone that creates this. 2 days ago just fine, but suddenly the 3rd day after porting it stopped working. What did ATT do? do you know if you could help us who already paid our phone in full, ported over and but STUCK? @tmo_marissa @tmo_mike_c

Userlevel 6
Badge +13

Aw man, sorry this happened to you too @combiblock. I'm sure AT&T hasn't done anything. The tricky thing about unlocked devices is that it can be hit or miss when it comes to working on our network. As long as the device is unlocked and our settings are entered correctly, in theory, it should work. Experience has taught me that's not always the case. Which is why we have our disclaimer for folks wanting to bring their own devices.

I remember back in the days when this happened on iPhones from AT&T. It was a mystery because they would stop connecting to data all of a sudden and there was no change in the software or the settings. It was weird because the service just seemed to stop with no real reason why. It didn't happen on every single phone, but I came across folks that experienced this. I had to let them know the same thing about the service being hit or miss.

Non-T-Mobile phone & software disclaimer

Userlevel 7
Badge +12

Can you guys try and turning off VoLTE?  I believe AT&T uses their own standard and authentication process.  If that's the case it may be causing your devices problems.

Hi all,

I have changed the network type, and now I can access mobile data without

any issue. But if I restart my mobile I need to change network type again.

But work around if fine for now

Userlevel 6

I know that altering that setting every time you restart isn't the most convenient thing, but I'm glad that you have a workaround you can use @sandokpn‌!  Thank you for the update - maybe it will prove useful to another user on this thread!

- Marissa

I had similar issues on an AT&T unlocked S7 Active.

I reset and rebuilt the APN (many times) and did everything short of rooting (much of this with support of T-Mobile telephone and message resources, and also reliable forums I have come to reliy on over the years), but in the end it still had these major problems:

- No phone call ability much of the time in AT&T roaming.

- Mostly AT&T roaming, and never connecting to Band 12 towers

- Call/text ability frequently dying, and only coming back from also frequent Airplane Mode On/Off

This is discussed in this post of mine in T-Mobile Community:

Unlocked AT&T S7 Active - moved to T-Mobile: Not working well.

and I consider that question answered. I eventually gave up on the idea of the former AT&T unlocked S7 Active being an effective T-Mobile phone to reliably function and fully make use of the available T-Mobile network and features. I hope you find this discussion relevant to your experiences.

Hi All,

Thank you for all the advice and comments. Sorry for the delay, but i don't know what i did besides putting in the APN settings manually. It took a couple days of just messing with the settings but it just worked. Now everything has been working fine since I posted my original question. I haven't restarted my phone to see if it still works since everything starting working. (knock on wood) but i hope everyone can get theirs to work 😊

Like the others, I brought my S7 Edge to t_mobile from AT&T.  After porting, all was great for about 2 days.  Now, no internet, no email.

Support states 3 days to "research" the problem.   I visited 2 stores, but no answers after resets, changing APN, calling support themselves. 

What is the fix for the problem?  Looking on line, I see several threads about the issue, but no resolution.  One would think someone with T-Mobile knows the answer.  One person in the store suggested I purchase a T-Mobile ready phone.  Is there a fix for this?

Still working well @littleb411​ ? I need to try this then because I am in the exact same situation with my AT&T S7!

@sandokpn​, you mention you "changed the network type". What did you change it too, and where do I find this setting?!!

nope!!! i want to reroot like the one person suggested and putting the

Tmobile software to override ATT. it was working fine, then i ran out of

battery and it reset everything. Now im back to square one with just text

and phone call, and can't group text now, was able to before. Frustrating.

Saving for S8+ and a better t-mobile deal to come out soon.

Hi Gunn317,

There is a code to edit the network setting, but i prefer to use "4G

switcher" app.

Once you open the APP, please change the network type to "LTE/UMTS auto

(PRL)" or "LTE/CDMA/UMTS auto (PRL)" then Click three DOT on right hand

corner and select "Enable Data Connection".

Now Status of Data service should show as CONNECTED. If it is not working

TURN OFF the "Cellular Power" on the same screen wait for 2min then TURN IT

BACK ON.

This should work. 😊

Please comment if it works for you. So others can get benefitted.

This actually worked for us.  As soon as I turned the Cellular Tower Power off and turned it back on it actually started working right away

@littleb411​ After changing APN settings, etc. it worked great until the phone was rebooted. But then to test another users forum thread on this site, we simply enabled Airplane Mode, waited a few seconds, then disabled Airplane Mode. Walla, data started working again!

We've had to use this little trick several times after rebooting the phone or when data stops working, and it someone gets it working again. I can't find the thread at the moment, but if I do I will update this comment.

@gunn317 this did the trick!!!! im so happy! been saving up for the S8 but

I could use that towards other bills. thanks for this tip with the airplane

mode. After i did that trick it was golden! I also have the settings in the

APN Type settings I have it as Default, supl, internet, mms

Hi,

I've just moved last night from AT&T with my AT&T branded unlocked S7 (that i bought from Target) and I have run into the same problem as the OP this afternoon. Using the airplane mode tip from @gunn317​, I now have 4G LTE back!!! It's not a permanent solution I don't think but it'll do for now.

I'm going to continue looking to see if something permanent crops up.

FYI: I also got the info from a T-Mobile tech that they feel it may be an issue with the phone coming over from AT&T.

I have the exact same problem.  Tech support told me it was "betterment" work in the area I was in, but as soon as I turned on airplane mode and back off it started working immediately.  Maybe the engineers can come up with a permanent solution since it seems like this is happening alot.

OMG...after banging my head against the wall and talking to countless tech support at tmobile getting nowhere, then i see this simple post.....you are a Godsend. Thank you much.

Reply