Solved

Stock Clock app crashing after updating to Lollipop


Hi everyone,

 

So I just updated my Note 3 to Lollipop, and it's working great so far. However, I am constantly experiencing problems with the stock Samsung Clock app. It crashes every single time I try to launch it; it'll open for a split second, display my alarms, then crash with the error message "Unfortunately, Clock has stopped." The only way I can set alarms is by commanding S Voice to do it, which I suppose is an okay workaround, but I would prefer to be able to use the app as normal.

 

I have tried wiping the cache partition multiple times, did a factory reset twice through the phone and Samsung Kies, booted in safe mode, the whole nine yards...and the problem still persists. Is anyone else experiencing this or is it just something weird going on with my individual phone? Hopefully if this is a problem that a lot of people are experiencing, Samsung/T-Mobile can work on resolving this is a known bug in any future Android updates.

 

Thanks!

icon

Best answer by jcnote 8 March 2015, 08:23

Well, just one more thought. Did you use Google or Samsung or any backup app to restore settings after your factory resets? If so, try turning off restore so you have clean settings after your reset.

View original

10 replies

Did you reinitialize the update when you used kies?

Yeah, I believe I did, in Kies I went to Tools -> Firmware Upgrade and Initialisation and performed the update again after I already did the OTA update the other day

Well I don't know what to tell you to help since you already did all the usual things, but just posting to say that I have no problem with the clock app or setting alarms, so it's not a universal problem. I did do a factory reset after updating but you said you did too. How about a battery pull?

Well, just one more thought. Did you use Google or Samsung or any backup app to restore settings after your factory resets? If so, try turning off restore so you have clean settings after your reset.

Yep, this actually worked for me. I reset my phone one more time without restoring my settings, and it worked. I wonder what caused it...oh well, at least my problem is solved,  thanks for the feedback everyone!

Sometimes when you backup your phone especially the settings part it saves files related to the operating system your phone is running so when you restore it on a newer version a conflict might happen

***********Update*************POSSIBLE SOLUTION

5/15/2015

I too experienced the issue "unfortunately, clock has stopped" after updating my phone to Lollipop.  I called Verizon and they told me to do a factory restore, which I did.  The issue still persisted.


I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

I tried clearing cache and doing a factory reset, and it didn't work. You don't have to do this if this if selecting a date format works.  Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!

Wow, I have been having this problem on my Galaxy Note 3 since the Lollipop update and going in and selecting regional worked for me! I had not tried factory reset but I do pull my battery all the time since I have two, so that wasn't working clearly. Thank you very much for this and I hope many people that are having this same issue see your solution!

Again this worked after trying no other methods on a Samsung Galaxy Note 3 that would not open "Clock" without crashing immediately.

Glad I was able to help. When the "Unfortunately, Clock has stopped"

message kept occurring I was freaking out because I use my clock all the

time for timers and alarms. I tried downloading a couple different clocks

from the play store, but they just weren't as good as the clock that comes

with the phone. I called Verizon tech support the first time and they

didn't have a solution for me except to do a factory reset. I reluctantly

did that, and it didn't solve the problem. What a hassle trying to set up

my phone again.

Then I got lucky when I called Verizon the second time. The guy had seen

the problem before and found a fix for it. Once setting the date format

worked for me, I immediately went online and posted the solution on about 9

different websites. The feedback so far has been great. It seems to solve

a lot of people's problems on a lot of different devices.

Hopefully people "google" the issue before doing a factory reset or even

clearing the cache. My hope is that this solution will save people hours

of frustration.

On Mon, May 18, 2015 at 10:03 AM, infinitycubed <no-reply@t-mobile.com>

Same problem,  same solution,  Note 3 on Sprint. When I went into  Settings--Date and Time--Select Date Format, nothing was checked,  so I clicked on regional date, and Automatic date and time. Thanks for the fix.

Reply