Solved

Subject headers for MMS messages

  • 15 February 2018
  • 45 replies
  • 7283 views

Currently on my Galaxy s7, all MMS messages by default display <Subject: NoSubject>. Is there a way to disable the display so that MMS messages look like regular text messages?Community-2008

icon

Best answer by tidbits 20 February 2018, 05:01

View original

45 replies

Happening to me. I believe this is primarily a Tmobile sim care issue, but unsure. My experience may help someone figure out what is happening.

I had a note 9 with a tmobile sim card in it. Moved to an iphone 13. Put the sim card into the Iphone 13 and it completely wouldn't work. Removed card and used the iphone for a couple of days before realizing i dont like iOS at all. 

 

Moved back to my old Note9. Put sim card in and activated. Now my group messages get this stupid "subject:no subject" thing. 

 

Ive tried every listed fix on the internet, nothing has worked. 

 

Userlevel 6
Badge +10

I have the same problem. I have a (very old) Samsung Galaxy Note 8 from when they first came out. I have been using it on AT&T the past 4 years. I recently switched to T-Mobile. Every time I receive a group MMS with T-Mobile as my carrier, it starts with <Subject: NoSubject>. This is super annoying!

 

 

It's a Samsung problem. It's a known issue for a long time. Your S10 is Verizon branded and their MMS setup is different. If you had an unlocked S10 you would have the problem with all carriers.

 

I have an unlocked version with AT&T, Verizon, and T-Mobile Sims and I have this very problem. I also have a International Sony XZ2 which has this problem only on AT&T. Ironically if I use MVNOs it happens with T-Mobile NVMOs and not AT&T MVNOs.

 

I used to work for the DoD doing interference work, but I retired from it.

I have the same problem. I have a (very old) Samsung Galaxy Note 8 from when they first came out. I have been using it on AT&T the past 4 years. I recently switched to T-Mobile. Every time I receive a group MMS with T-Mobile as my carrier, it starts with <Subject: NoSubject>. This is super annoying!

Update: Seems the problem was that MMS was not Configured on our phones.  Reason being is that I bought these phones Online!!  The T-Mobile SIM

cards were sent to me in the mail and all I was to do was install them and have them activated. That was all done correctly and the phones were working.

The step that was 'missed' was that I was suppose to go to the T-Mobile store for them to configure MMS on the phones, didn't know that.  Just spent an

hour on the phone with their subject matter expert and got the issue resolved.  We configured the phones for MMS manually and ALL is well.  Here's

the instructions that I followed that worked FOR ME; no more <Subject: NoSubject> header:

 

  • To set the Access Point Name (APN) and turn on data settings, follow these steps:
  • Go to the Home screen.
  • To open the menu, swipe up or down on the screen.
  • Choose Settings.
  • Choose Connections.
  • Choose Mobile networks.
  • Choose Access Point Names.
  • Choose ADD.
  • Under Name, enter T-Mobile MMS
  • Under APN, enter epc.tmobile.com
  • Scroll down.
  • Under Multimedia message proxy, do not enter anything
  • Under Multimedia message port, do not enter anything
  • Under MCC, enter 310
  • Under MNC, enter 260
  • Under Authentication type, check Not set.
  • Choose APN type.
  • If this screen appears, enter mms (note: in lower case) and choose OK.
  • If this screen does not appear, check MMS and choose OK.
  • Choose the options symbol.
  • Choose Save.
  • Return to the Home screen.
  • To finish the process and activate the settings, you need to restart the device. Your Samsung Galaxy S8 will then be configured to use of MMS.
  • For instructions on how to restart your device follow the next steps.
  • To reboot the Samsung Galaxy S8, press and hold the power button on the side of the Samsung Galaxy S8.
  • Choose Restart.
  • Choose Restart.
  • The Samsung Galaxy S8 will automatically reboot.
  • If this screen appears, enter the PIN code and choose OK.
  • If this screen does not appear, go to the next step.
  • If this screen appears, swipe your finger over the screen to unlock it.
  • If this screen does not appear, go to the next step.
  • The Samsung Galaxy S8 is now ready for use.
  • The device is set up for MMS. If you have data coverage, you can send a message to test the connection.

This did nothing on my phone T_T

***FIXED***

 

I FIXED this issue on my unlocked (non-branded) Samsung s10+, its something to do with the MMS part in a group text or picture text MMS (Multimedia Messaging Service)… These are the steps I took to stop the "no subject" cuz it was annoying me like crazy...

 

1. Open "messages" app

2. Click on 3 dots in upper right corner

3. Click on "more settings"

4. Click on "Multimedia messages"

5. Press on "group conversation" so it shows off

 

Now this will convert all messages as text instead of Multimedia messages...

 doesn’t this also turn off all group messaging abilities?

I have this same problem with my new Z Flip 5G. After browsing thru the forum. I download Tmobile message app. Made it default Text message. 

Problem solve. The interface look a little different from Samsung message app. But the problem was solve. No more Subject header

I also have an unlocked s10+ and switched over to t-mobile last week.  I am also tired of the subject no subject header in texts. It seems to only come from iphones as my mms mags from galaxy phones work fine. I've asked the iPhone carriers to have subject header off (as those users can type a subject or not) but no luck there.  No solutions here still. 

This did not work for me. Anyone else with any advice?

For whatever reason this has stopped being an issue; now it's working as normal and I didn't change anything, just started working.

***FIXED***

I FIXED this issue on my unlocked (non-branded) Samsung s10+, its something to do with the MMS part in a group text or picture text MMS (Multimedia Messaging Service)… These are the steps I took to stop the "no subject" cuz it was annoying me like crazy...

1. Open "messages" app

2. Click on 3 dots in upper right corner

3. Click on "more settings"

4. Click on "Multimedia messages"

5. Press on "group conversation" so it shows off

Now this will convert all messages as text instead of Multimedia messages...

Any news on this?  Using Verizon branded phone; flashed to T-Mobile using T-Mobile SIM and having the same issues with subject line. 

Userlevel 5
Badge +12

It's a Samsung problem. It's a known issue for a long time. Your S10 is Verizon branded and their MMS setup is different. If you had an unlocked S10 you would have the problem with all carriers.

I have an unlocked version with AT&T, Verizon, and T-Mobile Sims and I have this very problem. I also have a International Sony XZ2 which has this problem only on AT&T. Ironically if I use MVNOs it happens with T-Mobile NVMOs and not AT&T MVNOs.

I used to work for the DoD doing interference work, but I retired from it.

I disagree about it being a Samsung problem.  I seem to think this is a T-Mobile issue.  With that being said, it COULD be a Samsung problem but one which only applies to T-MOBILE phones.

I have a Verizon branded S10 which I purchased from the Verizon store the day of it's release approximately 2 months ago.  Last week, I switched my service to T-Mobile and put in my T-Mobile SIM card.  When receiving picture messages or any messages in a group text, I get these annoying subject headers.  This never happened with my Verizon SIM card in.  I know some people blamed the Hangouts app but I do not have that app and I have never used that app on this phone.  I tried clearing the cache of my Messages app and that did not work.

Any help on this issue would be of much assistance.

Thanks,

Bob

Only occurs with my T-Mobile SIM card in and not my Verizon SIM card.  I have a Verizon branded S10.  It's hard to believe it's the Samsung Messages app to blame...

I disagree about it being a Samsung problem.  I seem to think this is a T-Mobile issue.  With that being said, it COULD be a Samsung problem but one which only applies to T-MOBILE phones.

I have a Verizon branded S10 which I purchased from the Verizon store the day of it's release approximately 2 months ago.  Last week, I switched my service to T-Mobile and put in my T-Mobile SIM card.  When receiving picture messages or any messages in a group text, I get these annoying subject headers.  This never happened with my Verizon SIM card in.  I know some people blamed the Hangouts app but I do not have that app and I have never used that app on this phone.  I tried clearing the cache of my Messages app and that did not work.

Any help on this issue would be of much assistance.

Thanks,

Bob

I just spent an hour with Samsung Tech and after not able to help me with the issue they said it's the problem is with T-Mobile and they sent me the link to this forum.

I start having this annoying subject header when I switched to using unlocked AT&T Samsung Galaxy S10+ phone with T-Mobile SIM.  Never had this problem with T-Mobile brand phones.  So it's not just international phones, but it appears the problem is with any phones that are not T-Mobile phones.  So far there's no fix to this, just have to live with it for now.

Has anyone been able to successfully solve this issue

M

I've been using this messaging app since it launched without ever having an issue.  I think it's acuaactu better than the samsams one but wanted to give the Samsung one a shot

Read some of the reviews for the Google Messages app losing entire text messages, alerts with no message body, etc.

I think a blank/missing subject line by the default messaging app is minor in comparison.

But it would be good to see a fix.

I'm having the same issue.  This is obviously an issue with the Samsung Message app.  O know that there is a place to configure messages there but it didn't help me.  Please reply if you get a fix or any help!

I just purchased my first unlocked device. Galaxy S10+ directly from Samsung because the T-Mobile carrier versions were sold oit at the time. I have been with T-Mobile for 18 years. This was the first time I have ever seeln this issue with subject: no subject for group texts only. 

I tried other suggestions and none of them worked for me.

For the time being, I installed google messages app and I don't have the issue I did with default message app installed.

I did not test any other third party messaging apps but Google messages will work for me just fine.

Wierd how annoying that extra subject line can be

Userlevel 4
Badge +12

Straight Talk uses all four carriers networks for their service. Depending on what SIM you had you could have been using say Verizon's network. I would suggest using the default messenger app that comes with the device. Also making sure to check your APN settings on the affected devices. The reason for testing other devices is useful is because it helps to see if it is a device issue. Which it very well could be in regards to settings on the device. Also, T-mobile has a BYOD policy like every other carrier. They can not guarantee your phone will work with their network. No carrier can and it's unrealistic.

Like I said though I would check APN settings and maybe even do a network settings reset on the device. As well as trying the default messenger that came on the phone.

We sure hope that T-Mobile is reading this thread!  My husband and I have Moto Z Play phones (one is two+ years old, one less than a year old) and we had NO problems with that "No Subject" line using the same phone and the same Chomps MMS app while using Straight Talk service.  (We used Straight Talk for over 11 years with several unlocked, non-Straight Talk,  phones.)  We feel your pain.

Now, T-Mobile "Expert" Teams are telling us to try our SIM cards in other phones and/or try a new SIM card and that if those things are ok, it's our "handset."  They've said NOTHING acknowledging that this has been a problem for many phones over many years.  (We've WASTED hours in two T-Mobile stores + on the phone with Customer Care and with the Tech Team.)

I don't know if our phones are "international" but they are unlocked.  That should not cause a problem.  Wasn't for Straight Talk.

T-Mobile -- Please have some of your "Experts" a) fix this problem, b) acknowledge that this problem exists with some phone types and/or c) suggest a text app that will work appropriately on T-Mobile's network with ANY phone that is brought to your network.

Had same problem, could not get any direction form T-Mobile support.  Updated APN settings and still no luck.  Changed default SMS/MMS messaging app to Google Messages and everything worked - no more subject header on MMS messages.  

Update #2: Worked for a day only!!! Have to call support back to give it another try, when I have time. 😥

Reply