Solved

Verizon s6 won't MMS on T-mobile


Brought over my unlocked s6 that was on Verizon and everything works fine on the t-mobile network except for MMS. Can't participate in group messages or send pictures over text. Have tried 3rd party texting apps like textra and Messenger but did not do anything to resolve

icon

Best answer by tmo_mike_c 16 November 2016, 18:05

Ah, okay well thanks for testing that out anyway. I really think you've done all you can. Sometimes it can be hit or miss with Non-T-Mobile phones. If by chance you are able to test it in a T-Mobile branded phone, and it works it's definitely something going on with the other device.

View original

35 replies

Userlevel 7
Badge +12

Do you have roaming turned on?

Userlevel 7

There's a MMS setting that you need to look at on BYODs.

The MMS Server address is  http://mms.msg.eng.t-mobile.com/mms/wapenc

See this document https://support.t-mobile.com/docs/DOC-2090#subhead1

Yes, data roaming on

Yes, I am using proper APN settings:

  • Name: T-Mobile US LTE
  • APN: fast.t-mobile.com
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • Multimedia message proxy: <Not set>
  • Multimedia message port: <Not set>
  • MCC: 310
  • MNC: 260
  • Authentication type: None
  • APN type: default,mms,supl
  • APN protocol: IPv4/IPv6
  • APN roaming protocol: IPv4
  • Turn APN on/off: APN turned on
  • Bearer: Unspecified
  • Mobile virtual network operator type: None
  • Mobile virtual network operator value: <Not set>
Userlevel 7

I'm out of ideas.

Userlevel 7
Badge +12

Verizon makes Samsung do something with their phones. It's always hit or miss when taking them to other carriers.

Out of curiosity, are you able to browse the web  on your phone without issue?

I can do everything on the phone without issue except text images to people or send group texts. I can receive pics and group texts from others - just can't send.

Thanks for clarifying. Can you try taking a picture and try sending it to your own 10 digit mobile number?

Doesn't work

Thanks for trying that. Do you know anyone with a T-Mobile phone that you can try your SIM card in to see if the problem persists?

We have 3 phones (myself and kids). Same problem on all 3 phones

Oh my! These other phones are T-Mobile branded phones yes?

Per my original post, these are all unlocked Verizon Galaxy S6's that I brought over to T-mobile

Userlevel 7
Badge +12

Verizon

Thanks for clarifying. Under APN type, do you see an Internet+MMS radio button to select instead of default,mms,supl?

The reason I ask is because default Android provides a text field to enter: default,supl,mms where

Samsung provides an Internet+MMS radio button to select.

No radio button select. It's a text field

Ahh okay, that is a bit odd. I too am out of ideas here @brdemorin‌. The only think I can think to test here would be putting your SIM in a T-Mobile branded device to see if the problem follows the SIM (which would indicate a network issue) or remains with the device (a setting issue).

Just a WAG but are you just editing the default APN or did you create a new one?  If the former maybe try just creating one from scratch then make that one active.

Ya, created it from scratch, but thx for the idea

Userlevel 6
Badge +13

Hi @brdemorin.

I checked around and I'm curious if you've tried changing the APN protocol and APN roaming protocol to IPv4/IPv6? If it's still not working, we'll need to make sure the services are working in T-Mobile branded phones as Chris suggested. Either way, please keep us posted.

  1. Thanks.

Ya, I had read the same thing somewhere and tried it to no avail. Thx though

Userlevel 6
Badge +13

Ah, okay well thanks for testing that out anyway. I really think you've done all you can. Sometimes it can be hit or miss with Non-T-Mobile phones. If by chance you are able to test it in a T-Mobile branded phone, and it works it's definitely something going on with the other device.

This is the issue that fixed my same problem:

APN Type: default,supl,mms OR Internet+MMS

  • Default Android provides a text field to enter: default,supl,mms.
  • Samsung provides an Internet+MMS radio button to select.

It is not a button; but tech support and reps at the store somehow leave out this part : supl,mms

I am going to ask T-mobile for a 1 month credit for the 2 phones that I worked on for 3 days.

i found this on Youtube

actually the APN type is -  default,mms,fota,hipri, supl

on this link :

Samsung Galaxy S6 Change APN Settings T-mobile MMS, 4G LTE Data, and Picture Messages - YouTube

when I just did  default,supl,mms I could receive MMS messages, but I still cant send them:: I am currently troubleshooting this.

Reply