why is my phone stuck on airplane mode

  • 20 May 2013
  • 9 replies
  • 1801 views

my phone wont stay off airplane mode. it doesn't allow me to receive calls or text messages


9 replies

Have you tried a master reset?

Can you provide us a little more info.

Have you gone into settings to turn OFF airplane mode?

When you say Stuck is it constantly reverting back to airplane mode even after you turn it off?

have you done a reboot / removed the battery?

Your WI-FI calling is set to "Never use cellular network". Goto "more settings->WI-FI calling-> connection preferences" and change the setting to either of the other settings.

Just shut off wifi calling restsdt phne

There is know bug with the Samsung S4.   A work-around solution is posted here :

xda-developers - View Single Post - Those getting the new M919 Batches (5/16 & 5/20)

what it says is :

Bug occurs if you have WiFi Calling on when you turn off WiFi.

To fix :

1) Enable WiFi

2) Enable WiFi Calling

3) Let WiFi Calling re-establish itself.

4) Turn WiFi Calling off

5) Wait 10 seconds

6) Turn WiFi off.

Your 4g should be back.

Hi Hillanthony!

That one worked! Thanks a lot!! 😊

Oh man @hillanthony you are a GENIUS. Thanks so much, I was dreading having to do a factory restore. Cheers! 😊

  Thank you! I was an idiot! After I read your post I remembered that WiFi calling settings was accident up. Oddly enough it happened to be up right before I started having the issues.

On a Z1s : "Radio Off" or "Turn Airplane mode off" message even when airplane mode switch IS off will be caused by the wifi calling setting being set to ONLY Wifi Calling.

"Only use Wifi" turns the Radio Off.

Choose "Wifi Preferred" or "Cellular Preferred" and the phone will start using the radio again but choose Wifi for calling if available.

This is a badly hidden setting but has a simple solution.

Thanks!

Reply