FTP and other port blocking??

  • 17 December 2016
  • 16 replies

Sorry - really weird issue - apologies in advance.

iOS latest 10.2

Digits installed

Latest T-Mo carrier update installed (today).

Can't reach FTP and other sync-related sites via cellular data.  Works fine over wifi and has worked fine over LTE in the past.

Could be a Digits issue (some sort of virtual network problem??) or a Carrier update issue (they've been disasters in the past) or T-Mo now blocking ports?

How best to resolve?

anybody else seeing this (or not, but using FTP, etc)?


16 replies

Looks like this might be related to a DNS problem - does Digits use a different DNS or set up a different APN on the phone?

I don't have Digits but have the same issue. I can connect to my FTP servers fine on wifi, or when on a VPN, but as soon as I try from the T-Mobile cell network it fails immediately.

Same phone connect fine with AT&T sim put in it as well, so it's not a device issue. Would be nice to resolve this.

ah, so sounds like switching carriers would solve the issue. Sounds like Un-Carrier means un-service maybe.

What os/version/carrier update version are you on?

I found problem on iOS 10.2 (and 10.2.1 beta) but not 10.1. Carrier update 27.0 onward.  Unfortunately iOS updates carrier automatically, so can't figure out if it is thet, iOS version, or T-Mo network change combined.

Right now I'm on 10.2.1 beta 2 and carrier update 27.1, but this happened for me on 10.2 and with the 27.0 carrier update. Unfortunately I can't roll back to 10.1.x anymore since Apple closed the signing window. To be fair I don't think I've had any of the carrier updates lower than 27.0 because I only recently unlocked the phone and used it on T-Mobile. Has to be something on their end though since it works fine on other networks, on WiFi, and when connected to a VPN...

I feel like they're blocking the FTP protocol, because I can connect to the same servers over SSH using Prompt, but can't connect using SFTP through Transmit (I've tried other FTP apps as well, all fail to connect) even though they're using the same ports. I've even changed the server's ports to see if that works, but I still get blocked when trying to connect via SFTP.

I'm also getting lookup fails on dyndns servers, which is just weird. IP gets to server fine, lookup via name fails. Works fine on VPN over cellular tho.

So something beyond just protocol block it seems like. 

As I said, weird. And frustrating.

Just for fun I put the same SIM in an Android phone (Nexus 5 running 6.0.1) and it connects just fine over SSH and SFTP, so this looks like it's specifically an iOS thing 😥

Yes, very frustrating. I've tried connecting directly to the IP addresses instead of the domains and that fails as well.

Honestly I'm kind of relieved to see I'm not the only one with this issue. Up until I saw this post I haven't seen much proof of this being an issue. It sucks, but at least it's not just me? ¯\_(ツ)_/¯

Yeah, for SFTP, direct IP doesn't work for me either. WebDAV does however work so you could switch (insert all the hassle/issues here).

Nice to know it isn't just me!

I re-pinged the TMo Twitter support folks and pointed them to this discussion.

TMo had a huge fail on iPhone 7 launch where the carrier update was completely borked, so I'm hoping it is some sort of glitch like that vs network change that will never get figured out.

Will update here if something changes.

Userlevel 5

Hey folks,

I saw another post on this issue recently. Deductive reasoning would point to a T-Mobile/iOS issue but other than that other post I saw, this is the only other report I have heard. The best course of action here would be to contact our tech support and have some engineering tickets opened so we can investigate where the failure is happening but it would also help to check things out on the FTP server side to see if it/they are reporting any failures when getting requests from iOS on cellular networks.

Any updates on this issue? Today I'm not able to FTP to any of my servers over TMobile but WiFi works fine. I thought this was working in the past but now I’m not sure it ever worked over TMobile. Is anyone able to FTP on iOS 11 over TM?


I believe I’m on the latest, iOS 11.2.1 and TMobile 31.1 (iPhone 8+) and 31.0 (iPad Pro 10.5). I’ll open a support issue today and relay and progress I make.

TMobile is definitely blocking FTP. I tried another FTP site (speedtest.tele2.net) and got the same Network is Unreachable error. What did work was using a TMobile hotspot on my tablet from my phone. This doesn’t surprise me since tethering is wide open because it is reduced speed or limited data. Anything on an unlimited One plan is throttled by speed or simply blocking the ports.

i can understand the goal but I think it is unreasonable to disallow FTP transfer. In my case I use far more data loading up web sites than the amount used to transfer files from my home server.

Does TMobile have an official statement regarding FTP?

It's 2018 and I can't even run my app that I developed for iPhone because they are specifically blocking ports.  I guess I'll have to find a work around... I'm sure you probably already came across this but this is the only site that really goes over into any detail on how to get past their firewall.


I hope this helps....

Userlevel 5

Hey folks! If you are having troubles connecting to your FTP site, please ensure the site uses iPv6 as we have moved to iPv6 only support. We switched to iPv6 only support to fall in line with Apples iPv6 only initiative Supporting IPv6-only Networks - Support - Apple Developer

IF this iis an IPv6 issue it can be circumvented by using a VPN like ExpressVPN.  Unfortunately that costs money.   Looking for Ann effective IPv6 solution.