Question

iPhone 12 won't do wi-fi calling

  • 19 April 2021
  • 6 replies
  • 233 views

Badge

We have two iPhone 12 Pro Max phones that have been unable to make calls. Our area has poor coverage, and we use wi-fi calling to bridge the gap. Lately, the call just says “calling . . .” but nothing happens.

The 12 has 5G capability, and our earlier phones didn’t, so I wondered. There is a setting under Cellular/Cellular Data Options/Voice & Data. It was set to 5G Auto. I changed it to LTE, and my wi-fi problem disappeared.

Not sure whose issue this is, Apple or T-Mobile, but if you have the issue, this is a workaround.


6 replies

Userlevel 6
Badge +14

I don’t see any known issues with the device, but there are a couple steps you can take on these phones to get them working. Can't call, dropped calls, & other calling issues is a great place to start for fixing this issue. 

Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on. Restart your iPhone. ... Turn Wi-Fi Calling off and then on again. Go to Settings > General > Reset, and tap Reset Network Settings.

 

I have almost the same problem. I have an Iphone 5s blocked on the T-Mobile network. I do not have the original sim card anymore and I want to unlock it via internet.

Ideas? Because there I do not know what to do: I went to smartphone shops but sellers do not deal with foreign networks (or so I did not find the right store)

I do not want to go to another country just for an iPhone ...

I am desperate any help will be welcome.

 

thanks my issue has been fixed.

same problem; in terrible cell area; only wifi calling ...i have done all steps for iPhone 12 (turn off/on wifi calling; reset network setting;but still no wifi calling

Userlevel 7
Badge +14

WiFi Calling is very depending on the speeds of the internet it is connected to.  If it can’t allocate enough bandwidth for its connection, it will not enable.  

Nothing but headaches. The device refuses to shift to WiFi calling. I’m constantly international and I want my iPhone 8 back!

Reply