Question

iPhone 13 PRO and iPhone 12. Frequently lose data connection on 5G.

  • 28 September 2021
  • 51 replies
  • 6633 views

Userlevel 1
Badge

 I’ve been with T-Mobile for 6 years and always had decent service (except in very rural areas, where I very infrequently visit). I just got an iPhone 13 PRO.  My wife has had an iPhone 12 for about 6 months.  She was frequently having issues with the service on her phone - especially with iMessages not going through. I tried to help her and figured it was just a weak signal issue.  She texts more than anything on her phone when she out and about.

Got my iPhone 13 PRO last week. I have good 5G signal in many locations if the number of bars is a reliable indication.  However, more often than not when I am in a new location and try to use my phone I have no data access at all.  Webpages won’t load, iMessages won't send.  Voice phone calls work OK.  If I reboot the phone or turn off 5G everything seems to work again (unless I leave 5G on and move to a different cell service area).  I’ve seen on Reddit that this is a common issue on T-Mobile 5G.  I called customer support and they just suggested to restart the device -- it’s impractical to do that 10 or more times per day - defeats the purpose of having a $1,000 5G smartphone.

Is there a better solution that anyone has found?  I’m seriously thinking about returning my phone while I can and switching to VZ.


51 replies

Userlevel 6
Badge +11

might depend on which bands etc they are running for 5G on that specific tower.. your phone was purchased through TMO or directly from Apple?

Yes I am having the exact same problems. Has anyone heard how to fix it yet or if apple or T. Mobile are in the middle of trying to correct those problems at least? This iPhone 13 has become more of a nightmare. Extremely slow text messaging, can’t get on the internet and it wont load webpages. Tells me to turn my cellular data on and it already is on . And same thing turn my phone off and on and it will work only for a few minutes then go back to doin the same thing . Oh 

Userlevel 6
Badge +11

which update is your phone currently on?

Yes, same with me. 5GUC shows connected with good signal. It rarely ever connects. And when it does speeds are 4.50 Mbps up and .02 Mbps down. Sometimes it will connect and get 660 Mbps down but that’s ever so rare. 5G will connect and get 70 Mbps down. LTE will get 230 Mbps down. 5GUC is basically useless. all on band 41. 
 

To check which bans on iPhone use the phone app and dial *3001#12345#* to open field test and see. 

which update is your phone currently on?

The newest one 15

which update is your phone currently on?

The newest one 15

Yes. Always am up to date. 

And of course I sent a message they the App and now when connecting after the reply it’s says fails to connect to server. Of course it would. Even on Wi-Fi 

I upgraded to iPhone 13 pro and I have the exact same issues. 5G never works, can’t get or send messages  and even phone calls can’t be made. Get a strange message’Last Line No Longer Available Do you want to call using remaining line? After several tries the phone call goes through.Even the web pages won’t load.  T-Mobile support and their technical support is unable to help unfortunately. I am out of options but to change carrier to Verizon as T-Mobile is unable to provide a reliable 5G service. 

I don’t think this is an isolated problem because my family switched to t mobile recently and we all got iPhone 12s and all of the phones have the same problems you all are talking about and t mobile has no answer.  I am about to switch carriers if this doesn’t change.  If it’s an IPhone issue either iPhone or T-Mobile needs to come up with a fix fast.

Userlevel 6
Badge +11

I don’t think this is an isolated problem because my family switched to t mobile recently and we all got iPhone 12s and all of the phones have the same problems you all are talking about and t mobile has no answer.  I am about to switch carriers if this doesn’t change.  If it’s an IPhone issue either iPhone or T-Mobile needs to come up with a fix fast.


TMO doesnt have any answers in here because the site is primarily peer to peer with a handful of agents that keep the site in order...they do not have account access.

I was very excited about this new IPhone 13pro max but I have the same problem and every time I call customer service they say  they’re working on towers and recommend me to change the settings to LTE. Very disappointed! 

Userlevel 6
Badge +11

i have a feeling its going to be like most device releases as of late..there will be an update pushed out within the next couple weeks to tweak a few things network connection wise and possibly some other bug fixes.

I am having the same issue. I had an iPhone XR before getting my 13 pro and had very minimal issues with service. Now that I have my 13 pro I barely get data service anywhere, even though I have bars and a big 5G in the corner. I was at a restaurant that had QR codes to scan for a menu, and I could not load it at all, and my mom, who also has T-Mobile, was able to load it fine with her XR.

This is a serious technical issue if I’m not alone. My new iPhone 13 pro cannot get 5G data at all, even there’re four 5G bars. I called 611 three times and went to the local store. No one could solve it or tell me why. I can make calls and text but no web browsing without WiFi. Customer service sold me the new Magenta plan but still no data. The store installed a new SIM card. Now I can have data with LTE. But no data if I switch to 5G, and no data even if I switch back to LTE. I have to restart the phone again to make LTE data work. I hope the issue can be resolved soon. 

Same exact problem here too. 
 

if you got into settings, cellular, data options, then change voice and data to LTE. Then the phone will never connect to 5G and there is never an issue.

 

I can not believe its almost been a month since release and this is still an issue. Very disappointing there is such a huge bug in a flagship phone for nearly a month. 
 

i am going to contact T-mobile and refer them to this forum if they try to say its just my phone and that I need to reset or change my sim. Cause its clearly their network or a software bug with iOS

Purchased an iPhone 13 at Best Buy on Monday and could not get it to do data at all on 4g or 5g 

took phone to blue shirts for diagnosis with tmobile
they determined defective and replaced phone but still having issues with no 5g and lte only 
 

My iPhone13 purchased from Apple store has no issues and connects to 5g and 5gUC with no issues 
 

seems like a modem software update problem 

but no one seems to know how to fix 

Having the same issue. Upgraded to an iPhone 13 Pro a couple days ago, and I’m having all sorts of cellular data problems that I’ve never had on my iPhone 11 Pro. For the past two days, I’ll randomly have data completely cut off for most of the day which has been extremely frustrating. I never thought to turn off 5G though, so here I was thinking I had a defective phone, but switching from 5G to LTE seems to solve the issue.. so it’s a T-mobile problem after all?

This is worth a shot, as my daughter’s new iphone13 was not getting 5G data at all:

I went into settings and switched it from “5G Auto” to “5G on”.  That stops it from hunting around and just instructs the phone to use 5G at all times.

It worked right away and seems to be fine today, although with one or two hiccups that were hopefully signal related.

This is worth a shot, as my daughter’s new iphone13 was not getting 5G data at all:

I went into settings and switched it from “5G Auto” to “5G on”.  That stops it from hunting around and just instructs the phone to use 5G at all times.

It worked right away and seems to be fine today, although with one or two hiccups that were hopefully signal related.

Thank you! I’ll give this a shot tomorrow and report back with results :)

Just an update to let y’all know that the “5G On” option didn’t work for me. I’m using prepaid though, so there’s that. 4G LTE works fine so I guess I’ll stick with that for now until they iron these kinks out. 5G just isn’t working for me at all.

Wow, and I thought I was alone on this issue.

I received 3 iPhones 13 (No Pro) and one of them lose data when it is in a poor coverage area. But the worst thing is that the iPhone does not recover or throttle back, it stays stuck with no data until you tinker with the Network Selection and reboot the phone.  Roaming is Off, Voice and Call on 5G Auto.

I literally spend almost 5 hours today with customer support on the App and still don't know if the issue is resolved.  Going to a T-Mobile store is useless, they send you to Best Buy or an Apple Store.

An Apple engineer told me that the phone is not the issue but the configuration on T-Mobile side for the line. So it looks like T-Mobile has something that screw up during line activation of the new phone.

Funny thing is that the other 2 iPhones are working like a charm and if I switch SIM cards with the number that is bad, I get the same issue.

I’m having similar issues. I upgraded from the XR to 13 Pro right when it came out. What happens to me is I am using 5G with no problems when suddenly something like Google Maps can’t connect even though I have 3-4 bars. 
 

My quick fix is to turn cellular off and back on again. A lot faster than restarting the phone but still not acceptable. I sometimes have to do this multiple times in a day. 
 

It literally just happened to me now while I’m reading an online book in a strong 5G area; which is what brought me to this forum! T-Mobile (or Apple?) appears to have a significant problem.

 

Same issue here.  4 new iPhone 13’s.  2 work “ok” and 2 can’t use cell data……

 

And TMO cant do anything to fix it…  Waited an hour in the store and nothing was fixed.

My kids and I live in a rural part of the southwest. It is a two-hour (+) drive to the T-mobile store. So we have always done business with T-Mobile via FedEx or UPS. Recently we had been experiencing issues with our iPhone XS and decided to upgrade. BIG MISTAKE! I have literally spent hours on the phone with customer service, the tech department and Apple. T-Mobile blames Apple, Apple blame T-Mobile and meanwhile I am paying several hundred monthly and we have no data on the new phone. Glad I decided to upgrade only one instead of all of them at once. Now I am debating going to Verizon because this thing is absolute junk. So frustrated with T-Mobile right now.

 I’ve been with T-Mobile for 6 years and always had decent service (except in very rural areas, where I very infrequently visit). I just got an iPhone 13 PRO.  My wife has had an iPhone 12 for about 6 months.  She was frequently having issues with the service on her phone - especially with iMessages not going through. I tried to help her and figured it was just a weak signal issue.  She texts more than anything on her phone when she out and about.

Got my iPhone 13 PRO last week. I have good 5G signal in many locations if the number of bars is a reliable indication.  However, more often than not when I am in a new location and try to use my phone I have no data access at all.  Webpages won’t load, iMessages won't send.  Voice phone calls work OK.  If I reboot the phone or turn off 5G everything seems to work again (unless I leave 5G on and move to a different cell service area).  I’ve seen on Reddit that this is a common issue on T-Mobile 5G.  I called customer support and they just suggested to restart the device -- it’s impractical to do that 10 or more times per day - defeats the purpose of having a $1,000 5G smartphone.

Is there a better solution that anyone has found?  I’m seriously thinking about returning my phone while I can and switching to VZ.

I have tried calling and messaging through the app with ZERO success. I get under 3mbps in 5G constantly. Very annoying and not happy about upgrading and now I am stuck with T-Mobile because of this new worthless iPhone 13. T-Mobile needs to figure this out asap.
 

Also looking to start a class action lawsuit, so in anyone else is interested send me a message. 

Reply