Solved

iPhone 6 Plus calls echo when receiving calls.

  • 30 October 2014
  • 4 replies
  • 80 views

I have no problem making calls, but whenever I receive calls I hear an echo. The person on the other end doesn't hear an echo. What should I do to fix this problem?

icon

Best answer by paul.johnston.9887 20 December 2014, 05:50

‌I had a similar problem when receiving calls from landlines After resetting my iPhone and replacing the SIM card T-Mobile replaced my iPhone 6 Plus. The new phone had the same problem when receiving landline calls from those who have AT&T. I called and spoke to an Apple specialist at T-Mobile who said he would open a new ticket with T-Mobile Engineering. He said my problem was a known issue when the iPhone 6 came out. He had me change one setting that so far has worked great. Go to Settings and then to Cellular. Look for Enable LTE. Change the setting to Data Only instead of Voice & Data. Hope this fix works for others.

View original

4 replies

‌I had a similar problem when receiving calls from landlines After resetting my iPhone and replacing the SIM card T-Mobile replaced my iPhone 6 Plus. The new phone had the same problem when receiving landline calls from those who have AT&T. I called and spoke to an Apple specialist at T-Mobile who said he would open a new ticket with T-Mobile Engineering. He said my problem was a known issue when the iPhone 6 came out. He had me change one setting that so far has worked great. Go to Settings and then to Cellular. Look for Enable LTE. Change the setting to Data Only instead of Voice & Data. Hope this fix works for others.

Thanks for the quick reply, guess i'll wait it out

The problem sorted itself out. I called tech support and the guy said hat

he would look into it and get back to me, but he never did. But since then

I haven't had any echos. So I guess they fixed it

Having the same problem except I get the echo from incoming landline calls only. Did you happen to figure it out?

Reply