Solved

messages via SMS gateway are not threading on iPhone.

  • 20 December 2019
  • 6 replies
  • 161 views

This bug was closed on the suggestion that senders manipulate a message to force MMS delivery:

Text Message via Email

That won't work in my situation. The unthreaded SMS messages, in my case, have been received and grouped properly on at least fifteen other Android phones and are know to work properly for iPhones on ATT and Verizon which leads me to believe the problem is with TMo's gateway and that Android has some built in workaround.

This command:

echo boo | mail -r "me@example.com (Me)" -s important XXXXXXXXXX@tmomail.net

results in a text that reads:

400-5

me@example.com (me) / important / boo

Because the 400-5 part is variable, my iPhone 11 pro will not thread. And yet, no other carrier is similarly affected.

Please provide a better fix than "force MMS"

icon

Best answer by tmo_amanda 31 December 2019, 16:19

Good morning!

I'd recommend PMing @srickar . You'll need to "follow" him first, he'll follow you, and then you'll be able to send private messages between the two of you. srickar is a T-Mobile Engineer that knows all the ins and outs of this kind of stuff. We're currently working to make it simpler to get answers to questions about the SMS gateway.

View original

6 replies

I see that ATT has an @mms.att.com option, does tmo offer that?

Userlevel 6
Badge +14

Just so I'm clear, is the issue with gateway messages not appearing in the same thread?

Yes, that is the issue. I can't really modify the messages that I would like to receive and even if I could, when I test larger (but not MIME encoded) messages using the gateway, I do not receive anything at all.

I suspect that Android messaging apps use the subject of SMS and that Apple simply refuses, but if you had a number@mms.tmobile.com gateway that was as reliable as your tmomail.net gatway, it would probably solve my issue.

Userlevel 6
Badge +14

I think you might be on to something. The only other thing I can think of is to temporarily turn iMessage off to see if it changes the behavior. Have you tried that out? Also, do the gateway message come from the same subject line?

Userlevel 5

Good morning!

I'd recommend PMing @srickar . You'll need to "follow" him first, he'll follow you, and then you'll be able to send private messages between the two of you. srickar is a T-Mobile Engineer that knows all the ins and outs of this kind of stuff. We're currently working to make it simpler to get answers to questions about the SMS gateway.

The message needs to be at least 160 characters or it will be delivered via ashort code i.e. 400-1 instead of the actual email address you send from.

Reply