PDP authentication failure

  • 16 November 2015
  • 21 replies

HI y'all

For the past few days I can't connect to data at all and get pop-up saying "PDP authentication failure" On my iPhone4.

I can still call and do sms.

I have North America plan and in Canada for couple of days. I come here quite often and there was no issue before until few days ago.

Ive done couple of thing trying to fix this including

-Switch on/off

-Sim in/out

-Update to latest OS

-Restore iPhone

-Hard reboot

-Switch roaming carrier

-Check APN

I put my SIM card to other iphone and still getting PDP error so it's not a devise problem.

Called customer support but no solutions what's so ever. My account is in good shape.

One thing that comes to back of my mind is, I receive SMS from T-mobile saying they have implemented some extra fee

for Prepaid customer.... blah blah,,, and since I'm on monthly plan (I was with prepaid plan before) I thought it's weird and eraced the text.

So it could be technical glitch on account problem?

please help.


Best answer by tmo_mike_c 23 November 2015, 20:14

View original

21 replies

Userlevel 6
Badge +15

Thanks for posting @piperoni‌!

Gotta hand it to you, you've covered a lot of the bases needed to fix this yourself. Sorry calling hasn't fixed this but have you given our T-Force team a try? You can reach them on our Community-2153 page using social media. A trouble ticket may be needed now if this issue still continues and they can help file that for you.

Thanks Mike!

I contacted through Facebook, but all I got is contact 1-877-778-2107number

which I have done like 10 times. Every time I call, I have to start from the beginning, and they offer same troubleshoot, give me ticket and never call me back again. I call them, and they tell me ticket is closed telling me nothing is wrong. I need somebody to look into deeper root for this problem.

Userlevel 6
Badge +15

I agree that this needs to be looked into deeper. I'm curious, did T-Force give you any additional instructions after they told you to call in? Tech Support does have a way to reopen the most recent ticket depending on how long it's been closed.

Normally if it a ticket comes back with no trouble found, it usually means it's something with the phone. I know you tried using another phone, but in order for that to show on the network side, you'll need to make a call on the second phone first. What you have to do is put the sim in another phone, make a call first so it shows on our end, then try using the data service. If it still doesn't work, we can reopen the ticket and engineers will be able to see that the data isn't working when you tried using another phone.

We can also have Tech Support reference the previous tickets after a new one is filed so engineers know you've been dealing with this for a while. We don't have the tools on the forum to escalate a ticket but Tech Support and T-Force do. If you'd like to give T-Force another shot, you should link them to this thread so they're aware that you've tried contacting them before and the data still isn't working.

Hi Mike, thanks for the advise and sorry that reply was kinda late,, I didn't get notification here..

I swapped the sim with other phone, called once, and tried to use data as you mentioned.

See if engineer can figure out something new knowing it's not the phone issue.

I wish this was just a phone issue then I can buy new phone, but seems it's not the case.

I have no data since November whenever I'm in Canada. Whenever I'm in US nothing wrong with it.

I'm guessing there's a glitch in my account that it is still associated with previous pay as you go account.

Userlevel 6
Badge +15

Hello, and thanks for the update. I appreciate you testing your sim in another phone. If the data's not working in Canada only, then this would be something network engineers would look into. Are you still working with T-Force to file a trouble ticket? If so, did you mention that the data troubles are while you're in Canada and it's happening on another phone too?

Thanks Mike,

In Canada now and data is not working again. I have no problem with 3G in US, only in Canada it's not working.

I haven't had a chance to go Mexico this year yet so I don't know if it works there. Anyways I call tech and it's always a same thing, I have to explain everything all over, have to do reboot and on and off  stuff that I've already done million times. I told them I switched phone, it's only happening in Canada and always end up they gonna check and call back, which they never did and I call them back just to know they closed the case without solving anything.

I used to have pay as you go account, and I'm suspecting somehow my subscription is still bugged by that old configuration. Because I get text message like "Welcome to Canada Text $0.50 each and Talk $1.79...." which is kinda weird since I have don't need to pay extra with my North America Plan.

Is it possible for you to look in to my account? Because you seem to know more and you already know the situation.

I'm bit tired of calling call center and do same stuff over and over again without ever been fixed...


Userlevel 6
Badge +15

Wow, is it still giving you the same error message? I'm not able to get to your account but I did check and we haven't been getting any official news about data not working there. I know we last left off with a Trouble Ticket that was filed for you. Instead of calling, are you able to run this by T-Force to track down that ticket?

Last time I asked T-Force about this matter over the Facebook, T-Force told me to talk to the tech on the phone giving me a 1-800 number that I called before,,,, should I try again?

Userlevel 6
Badge +15

I think you should. I feel like you need a trouble ticket so our engineering team can look over what's happening with your connection. We just have to get it filed for you either through Tech Support or T-Force.

Similar situation for me. I just landed in Italy and my Iphone 6 does not work.

What I have:

- iphone 6

- Tmobile ONE Prepaid

Here's what i've done with my phone and none of them solve the problem:

- Enable Data Roaming in settings

- turned roaming on #RON#

- tried enabling AND disabling LTE

- tried Resetting network settings

- tried powering off and restarting phone

Despite all these attempted fixes: I still receive a 'Could not activate Cellular Network: PDP Authentication Failure'

I can't believe I'm the only one experiencing this. In the US I have no problems and have never seen this error.

Any recommendations?

I am having the exact same issue here in Canada, since last Friday about noon eastern. I wonder if something changed. Resetting the network worked once, for a few days, but I am back in PDP Authentication failure land now, looking for a solution. Is it because Ive been in Canada too long? I am also looking for a solution to this issue...

Had this issue today, tried a lot, including 2 tech support folks and 4 calls... the final fix was to remove the SIM card, reset the phone, reinsert sim, and Dial #766#.

Pretty sure it was the last part that did it.

good luck everyone!

Thank You yogi_Iv. I had same issue and did #766# then #763# (disable roaming) and restarted phone and now it works!

I had follow the steps starting from the SIM card too—like metooblam. After a day of frustration, this did the trick! It worked. Thank you for sharing!

Thank you. Was having the same issues and have done all the above but #766# was the answer.

You rock! You just saved my trip.

Since I arrived in canada I had no data, I called t mobile and I did everything. #766# is the answer, I don’t know what it does but it works    

I had the same issue and literally tried everything. Nothing worked except the #266# and hard restart.

Hello. I’m having the same issue and nothing I’ve done so far seems to be working. I have tried resetting the phone, removing the SIM card, turning it on airplane mode and then restarting the phone and have dialed #766# and nothing has happened. What do i do?

Having the same issue in Mexico. Tried #766# but didn’t work. 

Wow ...this problem has been going on for a while. I use an iPhone 11 Pro . installed T-Mobile esim for whenever I’m in the US. Note that my phone works everywhere and I’ve never had an issue with data. My data works in the US with T-Mobile. I’ve been to Canada twice with it and I turned on the service ($5)to get data and calls in Canada. Unfortunately all I got was PDP failure.

And yes I too went through the hoops with customer service and then the tech team. Nothing worked!

As I have mentioned, my phone works fine whenever I travel. Never had data issues. Not even in Canada with the exception of this particular situation: esim, prepaid plan with add-on for Canada/Mexico. 

On both trips I used an Airalo esim for data only when I could not get my T-Mobile data to work. No issues with that esim data.

I’m thinking there is an issue with something that is embedded in the network code. It is not the phone and it really is an insult when we have to keep pointing out that the phone data works just fine including in the US but just not in Canada or Mexico as the case may be.

Surely by now someone should have spent the time to dig deep and find a solution. I’m also guessing that many more people have this issue but they just give up trying to solve it. Instead, they probably find an alternative.

Is there a way to change the APN on the T-Mobile esim?