HTTPS Verification only failing on mobile data

  • 28 January 2022
  • 4 replies


So basically, about a week ago I stopped being able to use a lot of social media sites, as well as a lot of just general websites. I thought it was the phone, until I got home and it worked just fine. I was looking into every single one of these sites and apps, and they all required https verification

So basically my mobile data wont allow me to verify on these. There are no account blocks, I’ve cleared that up already, and fiddling around with settings, both by me and one of the store clerks achieved nothing. 

I’ve already reset the phone and no results. Please help

4 replies

Perhaps the most widely recognized issue on the Android gadget comes as a programmed message that says, "your association isn't private." This might befuddle you since it happens even on the freshest gadgets with the most recent updates and the ongoing OS. It's anything but a joke matter. However, this is the way to fix SSL association mistakes on Android telephones.

We should start with SSL/TLS certificates.

start with a small foundation. You might be aware, an SSL certificate is intended to both verify the character of the site you're visiting—something done by the certificate authority that gives the endorsement and guarantees that you know who's on the opposite end of your association—and encode all correspondence between your program me and the web server.

This is critical on the grounds that, without SSL encryption, all of the correspondence you're shipping off the website page you're visiting is out in the open and can be captured or controlled by an outsider. In any case, with an SSL certificate, that correspondence is encoded and must be unscrambled at its the actual site.

Perusing without a protected association is never really smart.

Presently, one final tad of data for lucidity. SSL is truly just a conversational term for the convention now. SSL represents Secure Socket Layer. It was the first convention for encryption. However, TLS, or Transport Layer Security, supplanted it some time back. The two of them achieve basically exactly the same thing, but now genuine SSL has been gradually gotten rid of (Android no longer backs SSL 3.0-its last emphasis) and we're truly discussing TLS Certificates.

This problem is caused by T-Mobile Web Guard.  On my T-Mobile account web site profile, under Family Controls, Web Guard was showing as “No restriction”, but it was actually behaving as if it was set to “High”.  I toggled it to “High”, waited a few minutes, and then toggled it back to “No restriction” and then I was able to reach all websites.

Userlevel 7
Badge +15

Have you tried a different browser?  Is your current browser up to date?  Are you running any anti-ttacking plug-ins that might be preventing https?

For me, the original poster’s problem occurred across multiple different browsers and also prevented apps that used their company’s backend APIs from connecting to the app company’s servers that used the same DNS address.  There were no VPNs configured on the device and no other applications that manipulate networks state. 

If I had to guess, I believe what is happening is that T-Mobile has a flaw in their system where if Web Guard is activated for a given phone number and then that phone number is recycled, they don’t reset the Web Guard status in the active routers, but the new customer’s profile is initialized with the setting at No restriction” without actually applying that to the restrictions system.  When a new user adopts the phone number it will show Web Guard inactive when it is actually still active from the settings of the prior owner of the account.  Toggling off and on again then properly resets the value in the active filtering system.