NOK5G21 and outside network access (Cameras, etc) working

  • 14 January 2021
  • 3 replies

Userlevel 2

So I got one of these last week, was disappointed by the extremely limited options. I thought it was real internet, like dsl or cable  but it has no port forwarding/mapping, no dhcp server options like reservations. It seemed more like a large hotspot for basic internet use watching netflix on your laptop or getting facebook on your tablet. 

I needed incoming connections for a security camera dvr, for remote desktop and one for a mysql connection.

The easiest thing to get working was remote desktop, using chrome remote desktop. I think it uses google servers to make the connection so it works behind firewalls and inside private networks. Typical remote desktop uses a direct connection between 2 computers and requires an open and properly routed port.

However, I was able to also get a direct remote connection using real vnc and running a vpn on that computer with a ddns updater. By going though a vpn you can directly get into your home network even if tmobile can’t (or won’t) let you forward incoming connections.  This method also worked for a mysql server, I set it to the ddns address given by the vpn and I was able to get a connection back to the computer. 

The cameras (an amcrest dvr) didn’t have a way of running a vpn and also needed a direct connection by the monitoring software. I tried using an old router to make a vpn connection, it was not a reliable connection and didn’t really work. Maybe a newer/faster router would have worked better.  But the dvr had a setting for P2P connection, I enabled that and now can connect remotely with no issue. Again I think that worked by Amcrest being the middle man (like google) making the connection between the devices. 

3 replies

Userlevel 5
Badge +5

Yeah… they are using a funky IPv4>6>4 scheme.

Basically… CGNAT scenario, which causes all kinds of issues with apps/devices that need you to be able to forward ports in a traditional fashion.

If they would let us run native IPv6, might be able to get around some of that… but don’t expect that to come down the pipe soon either.


it is working for what I primarily need it for ATM… not playing anything on the consoles lately that depends on moderate/open NAT, and while I miss remote access to my media server it isn’t a “must have” thing atm.  So will stick with it a little longer to see how things shake out.


BUT… when I do get back into playing coop and such that does need ports opened/forwarded properly, I may have to switch to something else.

Userlevel 2

If your media server is something like plex on a computer or nas box like a qnap you could add a vpn connection to make it accessible.  It will loose some speed, but I can still get 5-6Mbps upload on a vpn, or about half of the direct connection. 

Userlevel 5
Badge +5

Unfortunately, it is Play-On.  Even with a VPN it stillis misbehaves... likely because it still picks up t-mobile endpoints somehow.

The mobile access feature does some weird tracking of the IP's (local gateway, WAN gateway, public IP...).  That data gets synched to the devices so the clients know where to reach out to when abroad.  Their 464 is likely what monkeys it up--that, and/or the lack of a proper bridge mode.  Can even knacker the mobile client when at home if things aren't setup up right (basically, all the traffic is forced to my router, and the Asus runs everything--firewall, NAT, DHCP, etc.)..

Might work somewhat if I fed the public IP:portID in a browser and all... but it isn't really setup to work that way.  I've tried that in the past to share stuff with friends/family.  Streamed videos get janky, and photos all render in portrait alignment regardless.  In the end I wound up sticking things on a USB stick to host files via FTP in the router (haven't had an occasion to test that on Tmobile yet).

I even tried setting up a VPN on the router.  But something is up with the last few firmwares--says it is connected, but is not forcing all data through the tunnel so it doesn't work as intended.  An older Asus model, so their firmware updates are basically limited to security updates at this point.  Otherwise it is more than adequate for my needs, so not keen on plunking $200 down on a newer one in the hopes it may resolve what really is an ISP issue, not a client-side generated problem.


These are important issues they really need to address ASAP.  It isn't just about our media servers.  It impacts IoT stuff like security cameras/devices, things that rely on location data and stuff like streaming services (ie: the Hulu dilemma).  Their tunneling can cause bad GEO data to get thrown in the mix periodically--some sites periodically track me as not only in a different town, but sometimes a different STATE.

Just a lot of weird little snafus like this with the service that will prevent it from being a good fit for many people, which is a shame when you look at potential competition it stands to offer against the more "traditional" ISP's.