T-mobile -- White mesh -- can't get it to pair -- have tried everything!

  • 14 June 2024
  • 9 replies


No matter what I try I cannot get the white mesh disks to pair.

I have spent hours on the phone with support...I have reset factory reset my gateway, the mesh several times...and all it does is blink white.  They have sent me knew ones… same result.  I don’t know what else to do that this point.  Does anyone know how to fix?

Thank you!


Best answer by nc1037 14 June 2024, 17:06

View original

9 replies

Userlevel 5
Badge +8

Troubleshooting suggestions - start upstream and work your way down.

Does the gateway work by itself?  (Can any of your devices connect to it?)

If it doesn’t, that’s the problem. 

If it does, have you tried pairing the mesh units very close to the gateway?  After they pair, move them.  If they still won’t pair, you could try something different, such as connecting your old Wi-Fi router to the gateway with an Ethernet cable.  See how far that signal reaches, and if necessary, add extenders to make your own “mesh” network.

Finally got the mesh access point to turn solid green. Then moved doesn't show up on the app as devices or on devices when searching for wifi access. 

App says error cannot connect. App doesn't ask or let me add device set up Access point.

IDK what else to do

MESH access point doesn't show in my life app, but I can now see it on my phone after scanning for Networks. But I cannot connect to it? 

Anybody have that happen. How do I fix it?

I called the help line and got it up and running.  it took a few hours for the mesh access point to show up but it eventually showed up.  i also restarted my phone during that period

So I was having all the issues above. I was connected to the internet and all my devices were connecting to the wifi but the mesh never did. It was white blinking never green. No matrer what i did. Resetting, restarting the modem, the mesh my phone nothing the mesh NEVER worked with or without the ethernet. I also spent HRS! In store and customer service. Swapped the mesh like 3 times they were ALL the same. 

So finally someone in tmobile tech figured it out! :)

He pushed a firmware update on the modem and finally the mesh turned green and i was able to connect it to the modem via ethernet. Once that happened i unplugged it and moved the mesh upstairs.  And tried to connect again. This time it didn't connect to my app but was green? 

So I restarted the modem and app and FINALLY it connected! So hopefully this will work for everyone out there having issues. Good luck!


This is my mesh devices behavior and the issue, so how can I get support to send firmware update?  Don't have hours to spend on phone with support.  Who does?


This is accurate. Contact customer care and ask to speak to someone on the tech team. Ask them to check your gateway to see if it requires the firmware update, you will need to provide the IMEI on the back of the gateway. The update takes about 5-10 minutes. As soon as that is complete pairing is quick. My opinion T-mobile should be doing this before sending these units out. It should not fall on the customer to figure out that their tech needs updating.

What is the version of this new firmware?

This is my mesh devices behavior and the issue, so how can I get support to send firmware update?  Don't have hours to spend on phone with support.  Who does?

I just called tmobile customer support who transferred me to the home internet technician. We went over everything and then he said he was going to try to push a firmware update to the modem not the mesh.  I honestly do not know if the one helping me had more access than your average tech personal to overide something or see more info into my device. (i.e. a higher up ). But i do remembet being put on wait a couple times so he could talk to a higher up and see what to do next. And then eventually he was able to push it. So it could be that is something a higher up can do but not a regular tech? 

Unfortunately i do not know the firmware option.