Request: Please honor DND when booting and displaying splash screen

majorhavoc

    So my phone (Samsung Galaxy S8) has been receiving a lot of updates lately (and the phone seems to like to do its installs at 2 AM in the morning, EVEN THOUGH I HAVE TURNED OFF THE SCHEDULE UPDATES TIMER. So I am seeing this issue more lately, but I see it on reboots and restarts as well:

     

    I have two requests for when the phone starts up:

    1). Please either honor the Do Not Disturb (DND) setting, or give an option to mute the T-Mobile jingle at startup. It is quite annoying to have the phone restat in the middle of the night when it is set to DND, only to have it loudly play the little T-Mobile jingle. If that time during the boot is too early to access the DND setting, then please give us an option to silence the boot sound completely if you cannot honor DND.

     

    2). I really like the black T-Mobile splash screen that shows up at shutdown. But I equally hate the VERY BRIGHT T-Mobile splash screen at boot up. Especially at night. My phone reset in the car recently while I was driving at night. The BRIGHT T-Mobile screen at boot right after the Samsung logo was so bright it was blinding. I had trouble seeing the rather dark street I was on that screen is so bright. Likewise, when it rebooted for a software update recently, the BRIGHT white screen and T-Mobile jingle woke me up a little after 2 AM in the morning. Really, I have to have a bright white screen and jingle at 2 AM in the morning?

     

    So, I would like an option to choose the black splash screen with T-Mobile logo at the start rather than the full brightness white screen. Also note that a full brightness white screen uses the most power possible on an OLED screen. Why waste battery power on your logo? I know who's phone service I am using.  A little respect for our batter please.

     

    Thank you

      All replies

      • victor_j

        Please consider this request.  There is an on/off setting under Sound called "Power on ringtone", but even though I have it set to off, it still plays.  I have a medical condition called hyperacusis where everything is much, much louder to me than most people.  I recently got a new tablet from T-Mobile and, the first time I powered it up and the sound played, it was so excruciatingly loud (and unexpected) that my hands jerked to cover up my ears and the tablet went flying.  (Luckily, it landed on a carpet without breaking.)

         

        When applying updates or rebooting, I expect the sound now so can take steps to mute it by putting it under something like a pillow, but there are still times where it plays unexpectedly.  For example, last night while I was sleeping, the tablet rebooted and got stuck in a boot loop, playing the sound over and over.  I had to run out of the room, from a dead sleep, and have someone else go into the room to take care of it.  Note, the tablet was on Do Not Disturb's "Total Silence" mode, which I always have enabled except when watching the occasional video.  The description for "Total Silence" mode is, "This blocks all sounds, including from alarms, music, videos, and games."  T-Mobile's version of the tablet is not respecting this setting while booting up.

         

        Thank you.