Question

3G Iphone 12 Woes

  • 1 February 2021
  • 1 reply
  • 112 views

Badge

Hi Everyone,

I currently have an iPhone 12 Pro running on iOS 14.4.  I’m currently up in Canada and roaming, but I’m not sure where this problem is unique to roaming. When I connect at LTE everything works as expected, but if I connect to a 3G network, I get the “Could not activate cellular data network. Turn on cellular data or use Wi-Fi to access data”. Here are some of the things I’ve tried:

  1. Reset Network settings multiple times
  2. Tried multiple carriers (Telus, Rogers, Bell), if on 3G same problem arises
  3. Tried an AT&T sim which allows me to roam on 3G on Telus. So I “believe” the phone isn’t the issue
  4. T-Mobile thought the Sim card could be the issue, so I removed the SIM and activated the eSim instead. Same 3G problems.
  5. When I had my iPhone 11 Pro, I never had any of the above issues.
  6. T-Mobile has also made this very hard to diagnose as they’ve disabled the iPhone 12 from turning off LTE. So I can’t force the phone to 3G. The only data settings are: 5G On, 5G Auto or LTE.


I’ve spent over a month with T-Mobile at this stage trying to debug this but haven’t made any progress. Any thoughts or recommendations here?
 


1 reply

Hi Causaelity,

I began having these problems a few months ago and when I looked on this forum, most people had new Apple phones. I’ve been chugging along with my 8S and my data issues seem to have begun with the most recent Apple update. T-Mobile advised that when the merger took place with Sprint, I’d need a new SIM card, which I haven’t done yet. However, plenty of people on here have switched their cards out to no avail. Therefore, this appears to be an Apple issue after reading everything on here, although some have linked it to T-Mobile “no credit” pay plans. I’ll ask T-Mobile about that issue, because I’ve been with them at least 6 years with a credit check. 

Reply