3rd party apps not working on data

  • 18 May 2022
  • 4 replies



I have had this issue since Jan ‘22 and have worked with both t-mobile and apple support numerous times yet the issue persists. For some reason, my 3rd party (non-apple) apps do not work on cellular data. i have tried everything tech support has suggested: reset phone, reset network settings, turn on roaming, ensure data usage is allowed for each app. it even went as far as me being advised by apple to redownload the current ios onto my phone and set up my phone from factory settings. this has been extremely frustrating and i would like to use my phone without such hinderances. can someone please help?

4 replies

Try a VPN. It has been a temporary fix for my son's phone with the same exact problem. 

check for a web guard feature

I am having the same 3rd party Apps issues. I have a I-phone 13 mini, OS 15.6. Went to my local T store where those guys did all the usual stuff, changed SIM card, reset, enabled, disabled, checked rechecked, etc etc. to no avail. Tech fellow finally said “ oh its a bad device you have, go to Apple and let them run their diagnostics” I said “ Well all the apps were working when I had Verizon”

Anyway, asluck would have it I have Best Buy near me where I purchased the phone 6 months ago, they ran the trove of diagnostics and as expected…….all green no issues! 

So like many others here in the community, and those I found on the Web, I find there are issues with OS 15 system and T-Mobile cellular and apps connectivity 


  1. Has anyone ever gotten a solid answer from T-Mobile on them working with Apple to actually fix the issues? 
  2. Has anyone actually had solid recommendations from T-Mobile on how to proceed with a useless phone and their recommended fix?
  3. Since T-Mobile not only sells Apple products but those like me who change over to T-Mobile with an Apple phone, there has to have been enough issues that both T-mobile and Apple are addressing the issues. 

Thanks for any help or input 


To update and close the loop and this issue I had with 3d party apps and T-Mobile cellular data. I called the T-M tech support, explained the issues with apps and cellular data connectivity. They (being the person I spoke with and their tech support) had never heard of this issue!

After finally stating again that it must be Apple, I was transferred to an Apple support fellow. Giving my phone access, and being on line with them for over an hour, Apple support frankly and solidly stated it was neither the device or software and that the issue had to be on the T-M side and some restrictive code, or block or a permission that was not completed

I again contacted T-M tech support and luckily got a young lady in the Philippines, who after explaining the issues, dug into my account and found……….the codes and blocks that somehow got inserted by T-M that blocked the data!!  After clearing the block and code……….all is well and my apps work just fine. What is terribly frustrating is that the local T-M store support and the several times I called tech support did not find this!! It took one person who made the effort to dig a bit further!! 

I hope this helps someone having similar issues!!