Solved

After latest update, GS9 keeps defaulting to Cellular Preferred over Wi-Fi calling

  • 25 February 2019
  • 42 replies
  • 2146 views

I have very poor (but existent) cellular coverage in my home.  I had no problems with setting Wi-Fi preferred for all of my calls/texting prior to the latest (large) update.  Now, I can select Wi-Fi preferred under Wi-Fi calling, however it never seems to save that setting.  As I am typing this, I have two outgoing messages that aren't sending (spinning circle) because the phone can't decide whether it wants to use Cellular or Wi-Fi.  I want it to use Wi-Fi because I know my Cellular coverage is horrible at my location.  I called into customer service today (somehow without a dropped call) and they made some adjustments on their end, however it fixed nothing. 

Even after selecting Wi-Fi preferred, I will go back to check a few minutes later and the phone has already switched itself back to Cellular preferred.  This is very frustrating.  What can I do to ensure that Wi-Fi preferred will be the default setting?

Thank you

icon

Best answer by tmo_amanda 28 February 2019, 00:37

Hey, @drinktigermilk​!

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

View original

42 replies

Userlevel 6
Badge +12

I am also a Galaxy S9 user and this may just be a bug that Samsung introduced in their update to One UI. Which is the one I think you are referring to. I have been able to fix the issue by putting the phone into airplane mode and then connecting to wifi so it has no options. Sorry if that's not a permanent fix but when it does occur it what I do.

Userlevel 5

Hey, @drinktigermilk​!

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

I have the exact same issue.  Poor cellular so I use Wi-Fi calling.  But the phone keeps defaulting to cellular.  No matter how many times I update it.  I need my phone for sales so this is very frustrating.

This just started happening to me too, Samsung Galaxy S20 Plus 

This just started happening to me as well, Note 10+ 5g. All current updates, and every 20 minutes or so T-Mobile “helpfully” tells me that they’ve adjusted my wifi call preferences to prefer cellular. My issues are similar to the original posters… I barely have a cell signal, but enough that the phone keeps trying and I will miss calls or texts because it never tries WiFi until I notice and switch it back manually.

One of the main reasons I’ve been a T-Mobile customer for so long is the Calling over WiFi.

Userlevel 1
Badge +1

under advance wifi, (3 little dots to the upper right) when you are on the wifi list of available wifi’s, on your phone. make sure wifi is priority over mobile calls and data calls. (only if wifi is gone, it goes to mobile) make sure anything “aggressive” is turned off, such us if “weak signal from wifi is low” it would switch to mobile to fast. turn off wifi scanning.

 

just anything that favors wifi calling over mobile, first.

 

if you see under advance wifi, switch to mobile data and its off, turn it on, then hit the little 3 dots.keep aggressive mode off, like i said. but under excluded wifi make sure your personal wifi is selected. so that it wont connect to mobile, when you still want the wifi calling feature on.

 

 

Thanks, but this isn't helpful. Those options have been turned off since I got the phone, because I have known of my signal issues. I primarily use wifi.

This has only become an issue since the phone got the most recent update. No settings were changed, and I did review them as your post suggested to make sure. There are no "aggressive" mode options under any of the wifi menus or settings regardless of what is toggled on or off. There is no context menu under mobile data, even when turned on.

Userlevel 1
Badge +1

oh, well in that case, reset the phone to new, wont erase your external micro sd card, if you have one.

or your personal pictures.

 

I do suggest you do a master reset, erase it all. not all updates will make a phone work snappy, just by updating it. some updates might not work as good as the old settings, or fix or w/e they did.

 

gl

I'm experiencing the same issue on my new Galaxy A71 5G. My phone keeps "optimizing" my WiFi calling by changing to cellular preferred. I need to keep it set to WiFi preferred, but it won't stay set that way. Very frustrating!

I have 2 S20+ phones and only mine is doing this optimize of wifi calling. I’m also having an issue where the wifi password keeps saying incorrect. I try typing it in again and it says same thing. Only fix so far has been to restart the phone. Started after the first update in September, I hoped the new update with September security update would fix it but it hasn’t.

Same issue with Samsung S8, recent updates have made my phone change randomly from Wi-Fi preferred to Cellular preferred. My signal in my home is also non-existent and it MUST be on Wi-Fi for my phone to work, this is infuriating and I am on the brink of switching to another provider since my phone now completely stops working randomly throughout the day since it is changing to Cellular.

Userlevel 1
Badge +1

Same issue with a Galaxy S10 Plus after a recent update.  If you are going to give the option to prefer WiFi over cellular then that choice should be respected and not automatically changed or “optimized”.  There is a reason I choose to prefer WiFi over cellular in my home.  As I move around the house the signal strength fluctuates and if I am on cellular service I will drop calls and text messages will not go through. This is an issue that will ultimately lead me to switching carriers as I have no other choice if the T-Mobile phone will not respect my choice to use WiFi preferred.  This one option makes the phone not work when it worked prior to the update that changed this behavior.  It is redundant to give the users this choice if T-Mobile’s network optimization changes it automatically against your wishes.  

 

Unfortunately, I see this has been going on for over a year on other T-Mobile devices (Like the person who started the thread) so my hopes that this is not intended behavior are low which is a shame.  It is unfortunate T-Mobile and Samsung got around to ruining the GS10 Plus in the same way over a year later.  It feels a bit like planned obsolescence If I am being honest.

This is getting ridiculous.  My wife’s phone (S9+) has now started doing this since her most recent update as well.  A new update on my phone in the meantime hasn’t fixed it.

We have to keep our phones in airplane mode to keep them from switching back to “cellular preferred”, which won’t work because of the weak signal here. Since “Cellular Preferred” sees a barely-there one-bar cell signal, it will not even try the WiFi calling. We start missing calls and texts.

Since BOTH of our phones are now doing it, this is something T-Mobile’s update has doing to our phones since the recent updates.

T-Mobile, please fix this ASAP.

 

Badge

My wife and I just switch to T-Mobile and get the Samsung Galaxy note20 for each of us and both of our phones constantly notify us every minute or two that it switches back and forth on preferred network or Wi-Fi and it's super annoying we have to put our phones the silent in order to get any peace.

It shouldn't need to switch back and forth as in our bedroom where we spend most of our time is where my network setup is located including my Wi-Fi router and I get very poor cell phone service where I live so there should be no question on whether or not it needs to switch or stay on WiFi so I don't know why it's switching.

 

My wife and I just switch to T-Mobile and get the Samsung Galaxy note20 for each of us and both of our phones constantly notify us every minute or two that it switches back and forth on preferred network or Wi-Fi and it's super annoying we have to put our phones the silent in order to get any peace.

It shouldn't need to switch back and forth as in our bedroom where we spend most of our time is where my network setup is located including my Wi-Fi router and I get very poor cell phone service where I live so there should be no question on whether or not it needs to switch or stay on WiFi so I don't know why it's switching.

 

 

Unfortunately, you’re likely going to miss calls and SMS while at home.  The only solution I’ve found to this is to set your phone to Airplane mode when home, and turn on WiFi and Bluetooth manually. Of course, this is a PITA whenever I go out and forget to turn airplane mode off…

Just got another update, and still not patched. T-Mobile, fix this. DISABLE the “automatic adjustment”. Let us set what works for our situation.

Badge

My wife and I just switch to T-Mobile and get the Samsung Galaxy note20 for each of us and both of our phones constantly notify us every minute or two that it switches back and forth on preferred network or Wi-Fi and it's super annoying we have to put our phones the silent in order to get any peace.

It shouldn't need to switch back and forth as in our bedroom where we spend most of our time is where my network setup is located including my Wi-Fi router and I get very poor cell phone service where I live so there should be no question on whether or not it needs to switch or stay on WiFi so I don't know why it's switching.

 

 

Unfortunately, you’re likely going to miss calls and SMS while at home.  The only solution I’ve found to this is to set your phone to Airplane mode when home, and turn on WiFi and Bluetooth manually. Of course, this is a PITA whenever I go out and forget to turn airplane mode off…

Just got another update, and still not patched. T-Mobile, fix this. DISABLE the “automatic adjustment”. Let us set what works for our situation.

I was on the phone with them for an hour today with no resolve.

 

They are friendly as always however it's like they don't know what I'm talking about they try to give me a solution but it's the solution for a completely different problem that I'm not having lol

I also have the same problem with my S20.  Don’t know exactly when it started automatically switching back to cellular, but I think within the last couple of weeks.  Like so many other respondents, I have very poor cell service at my house and need to be on wifi.  Please fix this problem!

Yeah I have the same issue, "network optimization" keeps setting my preferred method to cellular when I want it to be wifi due to no cellular signal. This started happening this last update to both my wife's phone and my phone.

 

I know it happened with this last update because I updated my phone first and the update made everything too big on my screen so i had to perform a hard reset. From that day forward I kept getting the notification that "network optimization" has changed my settings back to cellular.

this wasn't happening on my wife's phone. She kept putting off the update until she accidentally pressed update when it popped up as a reminder one day.

literally right when it booted back up and finished updating it popped up with a  "networks optimization." 

Guess what happened.. it too is now reverting back to cellular preferred. Even after saving the change or in the middle of a phone call it will switch back to "cellular preferred."

 

Please fix, this is an annoying glitch.

Userlevel 1
Badge

This is insane as it's happening on both my and my wife's Note 10+. It started after the August security update. There is no way for me to disable the notifications that I get 50 of on the weekends. Why is T-Mobile not answering or anything?! 

Badge

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This issue is not solved please do not mark it as such I'm using a Galaxy note20 as well as my wife is using the same phone and a lot of people are having this issue right now

Userlevel 3
Badge +5

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This issue is not solved please do not mark it as such I'm using a Galaxy note20 as well as my wife is using the same phone and a lot of people are having this issue right now

 

 

seeing as how this issue was for the S9 and was posted a year ago...it was resolved.

Userlevel 1
Badge

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This issue is not solved please do not mark it as such I'm using a Galaxy note20 as well as my wife is using the same phone and a lot of people are having this issue right now

 

 

seeing as how this issue was for the S9 and was posted a year ago...it was resolved.

Yeah, direct me to where it was resolved you intelligent piece of work?! And explain to me exactly if you're not having this issue and I've seen this issue reported on just about every T-Mobile Samsung phone from the S8 to the Note 20, WHAT ARE YOU DOING HERE?! Man I would love to call you some names that this forum would block but I'll stick to troll. Have a nice day. 😁

 

God Bless,

5th

Badge

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This issue is not solved please do not mark it as such I'm using a Galaxy note20 as well as my wife is using the same phone and a lot of people are having this issue right now

 

 

seeing as how this issue was for the S9 and was posted a year ago...it was resolved.

My apologies if I came across rude that was not my intention at all however I don't see where this was resolved I may possibly be overlooking it but I've read through this thread several times thank you for your time and assistance

Userlevel 1
Badge

Magma I was talking to the piece of work above you that posted (fireguy). This was never resolved and it's NONE of his business anyway. What is he doing in a thread that he's not experiencing the issue? I've had this issue for months now and it's driving me to the point of insanity. I had lived in an area with great signal and then I moved to a new home my wife and I bought that's in a T-Mobile dead zone. It's so bad I sometimes get the non-smoking sign on my signal notifier. So I'm not sure if this actually started sooner than August as I've always had WiFi calling disabled. But now that I need it, it simply doesn't work and notifies me every few mins that its changing the setting I selected, WTH?! Why would thisbevennbe turned on EVER?! If I set wifi calling to cellular priority or wifi why does T-Mobile care? And they make sure you can't disable the WiFi notification. Now I can use package disabler to disable the WiFi calling system app but I need wifi calling sadly enough now due to t-mobiles crappy signal. And when you go to report signal issues to T-Mobile they send you to a petition to get towns to allow towers?! What?! Just redirect a current tower or refit it with another antenna array?! This has me on my last nerve as I'm losing business because of it and T-Mobile doesn't even have the decency to respond?! 

Badge

Magma I was talking to the piece of work above you that posted (fireguy). This was never resolved and it's NONE of his business anyway. What is he doing in a thread that he's not experiencing the issue? I've had this issue for months now and it's driving me to the point of insanity. I had lived in an area with great signal and then I moved to a new home my wife and I bought that's in a T-Mobile dead zone. It's so bad I sometimes get the non-smoking sign on my signal notifier. So I'm not sure if this actually started sooner than August as I've always had WiFi calling disabled. But now that I need it, it simply doesn't work and notifies me every few mins that its changing the setting I selected, WTH?! Why would thisbevennbe turned on EVER?! If I set wifi calling to cellular priority or wifi why does T-Mobile care? And they make sure you can't disable the WiFi notification. Now I can use package disabler to disable the WiFi calling system app but I need wifi calling sadly enough now due to t-mobiles crappy signal. And when you go to report signal issues to T-Mobile they send you to a petition to get towns to allow towers?! What?! Just redirect a current tower or refit it with another antenna array?! This has me on my last nerve as I'm losing business because of it and T-Mobile doesn't even have the decency to respond?! 

Sorry I meant to reply to the other guy not you LOL however you're experiencing the same thing my wife and I are experiencing and I hate the fact that when I manually select Wi-Fi to take priority within 5 minutes it changes I think it should be up to me to choose what I prefer which is the exact same point you're trying to make is ridiculous that something so simple has gone on for so long.

I'm hoping one of their text representative or just anyone that works for them sees these messages and tries to fix it I've been on the phone with him a couple times and they just don't seem to understand what I'm trying to tell them.

Also if the program worked correctly it wouldn't be an issue however I can't understand for the life of me why sitting 15 feet away from my high-end gaming router with five bars of 5G Wi-Fi service it would choose one bar of 3-g over the Wi-Fi connection anyways lol but it does

Reply