Solved

After latest update, GS9 keeps defaulting to Cellular Preferred over Wi-Fi calling

  • 25 February 2019
  • 64 replies
  • 8471 views


Show first post

64 replies

I have 2 S20+ phones and only mine is doing this optimize of wifi calling. I’m also having an issue where the wifi password keeps saying incorrect. I try typing it in again and it says same thing. Only fix so far has been to restart the phone. Started after the first update in September, I hoped the new update with September security update would fix it but it hasn’t.

Our family of 4 is having the same issue since the last update. It is very frustrating that our calls are being dropped in mid conversation. We are 8 hours from immediate family and my parents are ill. This is unacceptable. This issue needs to be fix asap.

 

Userlevel 3
Badge +12

I am also a Galaxy S9 user and this may just be a bug that Samsung introduced in their update to One UI. Which is the one I think you are referring to. I have been able to fix the issue by putting the phone into airplane mode and then connecting to wifi so it has no options. Sorry if that's not a permanent fix but when it does occur it what I do.

Userlevel 4

Hey, @drinktigermilk​!

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

Same issue with iPhone 12 and 12 mini. Something to do with 5g phones or Tmobile 5g SIM cards.  They need to fix this WiFi calling issue or I have to find a new cell company. It’s been going on way to long now . TMOBILE get with it already stop going one step ahead and then 3 steps back

Same issue with iPhone 12 and 12 mini. Something to do with 5g phones or Tmobile 5g SIM cards.  They need to fix this WiFi calling issue or I have to find a new cell company. It’s been going on way to long now . TMOBILE get with it already stop going one step ahead and then 3 steps back

 

Same issue with my T-Mobile galaxy S10 device. So frustrating that no response here from the support team!

Userlevel 3
Badge

Same issue with my T-Mobile galaxy S10 device. So frustrating that no response here from the support team!

I contacted Samsung and they said it's up to T-Mobile as the WiFi calling app is there's. So good luck, T-Mobile doesn't care. 

Just to add to this exchange, I have the same problem with the S8 and the S8 Plus.

 

T-Mobile, go fix this issue asap, please.

 

 

Userlevel 2
Badge +1

under advance wifi, (3 little dots to the upper right) when you are on the wifi list of available wifi’s, on your phone. make sure wifi is priority over mobile calls and data calls. (only if wifi is gone, it goes to mobile) make sure anything “aggressive” is turned off, such us if “weak signal from wifi is low” it would switch to mobile to fast. turn off wifi scanning.

 

just anything that favors wifi calling over mobile, first.

 

if you see under advance wifi, switch to mobile data and its off, turn it on, then hit the little 3 dots.keep aggressive mode off, like i said. but under excluded wifi make sure your personal wifi is selected. so that it wont connect to mobile, when you still want the wifi calling feature on.

 

 

This is happening with my Galaxy s21

Wifi preferred keeps switching back to cellular preferred. I’m missing important calls because I work from home where I don’t have great cell coverage. 

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This thread doesn’t exist and this link is broken. Also this isn’t a solution.

Userlevel 1
Badge

Just to let you know that with an android update many months ago this constant switching from wi-fi to cellular stopped and most of the time my android phone stays on wi-fi. Once in a great while I get a “preferences updated” notice and after that happens my phone reverts to cellular preferred. However, this is very rare. This seems to happen only with ONE of the wi-fi systems that I regularly use. I have no idea why. Just had a new android update today and my phone was still on wi-fi preferred after the update. Hope my update is helpful to the community.

Userlevel 2
Badge +1

oh, well in that case, reset the phone to new, wont erase your external micro sd card, if you have one.

or your personal pictures.

 

I do suggest you do a master reset, erase it all. not all updates will make a phone work snappy, just by updating it. some updates might not work as good as the old settings, or fix or w/e they did.

 

gl

Reply