Solved

After latest update, GS9 keeps defaulting to Cellular Preferred over Wi-Fi calling

  • 25 February 2019
  • 64 replies
  • 8471 views

I have very poor (but existent) cellular coverage in my home.  I had no problems with setting Wi-Fi preferred for all of my calls/texting prior to the latest (large) update.  Now, I can select Wi-Fi preferred under Wi-Fi calling, however it never seems to save that setting.  As I am typing this, I have two outgoing messages that aren't sending (spinning circle) because the phone can't decide whether it wants to use Cellular or Wi-Fi.  I want it to use Wi-Fi because I know my Cellular coverage is horrible at my location.  I called into customer service today (somehow without a dropped call) and they made some adjustments on their end, however it fixed nothing. 

Even after selecting Wi-Fi preferred, I will go back to check a few minutes later and the phone has already switched itself back to Cellular preferred.  This is very frustrating.  What can I do to ensure that Wi-Fi preferred will be the default setting?

Thank you

icon

Best answer by tmo_amanda 28 February 2019, 00:37

View original

64 replies

T-Mobile you are the provider. Find a fix and get  it released. Thanks.

Badge

Hello, TMO are you there?? 

 

Wait you cant hear me cuz my stupid phone keeps unilaterally switching my WiFi call preference to Cellular when I’m right next to my router.

Im having the same annoying issue with my S8.

Fix it! or Im switching carriers. BTW, been with TMO since ‘96.

I have same issue after i had to get replacement phone. My other s10+ never did this... So annoying..

Tried updating E911 address to location where I was visiting, reset network wifi settings.

Working from home during pandemic and now dealing with this nonsense.

Tmobile fix this!

I've been with tmobile after omnipoint since 2003.

If not fixed switching carriers!

I have been having the same issue on both of my Samsung Galaxy Note10+ for last few months. TMO, since my signal is terrible in my house could you make available the signal booster you once carried?

I too am seeing this on a Galaxy Note 20 Ultra. I actually had to silence the notifications for this because it popped up every few minutes telling me my wifi calling preferences have changed. I still get the notification several times a day but it doesn’t make any sounds. 

I absolutely need wifi calling. I’m lucky to get 1 bar of 4g LTE inside the house. 

im legacy and this is not solved its a burden on the prepaid thats what they want

 

This just started happening in recent months. I have a Galaxy Note 10+5G. I have been a T-Mobile customer for many years, but I will switch carriers if they don’t fix this “feature” or whatever you want to call it. Why can’t I just set my phone on wifi preferred and have it stay that way? Unreal.

I have very poor (but existent) cellular coverage in my home.  I had no problems with setting Wi-Fi preferred for all of my calls/texting prior to the latest (large) update.  Now, I can select Wi-Fi preferred under Wi-Fi calling, however it never seems to save that setting.  As I am typing this, I have two outgoing messages that aren't sending (spinning circle) because the phone can't decide whether it wants to use Cellular or Wi-Fi.  I want it to use Wi-Fi because I know my Cellular coverage is horrible at my location.  I called into customer service today (somehow without a dropped call) and they made some adjustments on their end, however it fixed nothing. 

YOU WOULD THINK SOMEBODY AT T-MOBILE WOULD READ THIS THREAD AND RESPOND!!??

Even after selecting Wi-Fi preferred, I will go back to check a few minutes later and the phone has already switched itself back to Cellular preferred.  This is very frustrating.  What can I do to ensure that Wi-Fi preferred will be the default setting?

 

 

Thank you

 

Same issue with iPhone 12 and 12 mini. Something to do with 5g phones or Tmobile 5g SIM cards.  They need to fix this WiFi calling issue or I have to find a new cell company. It’s been going on way to long now . TMOBILE get with it already stop going one step ahead and then 3 steps back

Same issue with iPhone 12 and 12 mini. Something to do with 5g phones or Tmobile 5g SIM cards.  They need to fix this WiFi calling issue or I have to find a new cell company. It’s been going on way to long now . TMOBILE get with it already stop going one step ahead and then 3 steps back

 

Userlevel 1
Badge

Since last Android update my Galaxy S9 is driving me nuts. Tells me via notification with a beep that wi-fi is optimized every 10 minutes and phone refuses to retain wi-fi preferred setting. I live in a high rise where wi-fi works but I’m up high and cell service competes so calls are dropped and have a vacation home with practically no cell coverage so wi-fi is vital. I’m about ready to give up on T-Mobile. Wi-fi service is a great feature but it stopped working and when you call technical support they have never heard of the problem. There are some screws loose in this system. All these messages about the same or similar issues and technical support knows nothing? Why have this idea exchange?? A high up technical support person told me it was other applications on my phone causing the problem. Samsung says its T-Mobile’s fault. T-Mobile says its Samsung’s fault. I am exploring other carriers as I write this. I just cannot understand why this problem cannot be fixed NOW. All the advertising to recruit new customers and T-Mobile will be losing old ones. Wi-fi use with the cell phone is very useful -- but not having it so screwed up. Should they not admit that there is a BIG problem and get it FIXED. This company seems totally and completely unresponsive and irrational.

This is happening with my Galaxy s21

Wifi preferred keeps switching back to cellular preferred. I’m missing important calls because I work from home where I don’t have great cell coverage. 

Hey, @drinktigermilk​!

 

Unfortunately, this is the first post that I've seen around the Support Community regarding WiFi calling taking a back seat to cellular after updating to Pie. We're still working to get answers on why this is happening and what we can do to fix it. In the meantime, we're using this thread: Official Android 9.0 Pie Discussion Thread to track user-reported issues related to Pie. When we have more info, we'll be sure to post it over on the linked thread.

This thread doesn’t exist and this link is broken. Also this isn’t a solution.

Userlevel 1
Badge

Just to let you know that with an android update many months ago this constant switching from wi-fi to cellular stopped and most of the time my android phone stays on wi-fi. Once in a great while I get a “preferences updated” notice and after that happens my phone reverts to cellular preferred. However, this is very rare. This seems to happen only with ONE of the wi-fi systems that I regularly use. I have no idea why. Just had a new android update today and my phone was still on wi-fi preferred after the update. Hope my update is helpful to the community.

Reply