Can't receive data when on 5G UC

  • 6 November 2021
  • 19 replies
  • 14749 views

Badge

New Pixel 6 Pro.  Worked fine for first few days.  Now when the phone shows connected to 5G UC, I can not receive any data or connect to internet.  There's an exclamation point in the notification area.  If the phone shows just 5G or LTE them I can receive data.  Tried resetting all networks and still won't work on 5G UC band.

 


19 replies

Hi Jimmy, what you are experiencing is a sim issue, it's unfortunate right now with all the modernization of the towers,  but rest assured there is a fix.  You'll need to switch from the esim to psim (physical sim). We've noticed this issue with all Apple Devices with dual sims. If you're device doesn't have a physical sim, just drop by aT-Mobile retail store and pick up one.  They will be happy to make the switch for you.  No need to use it for a paperweight.  Hope this helps.  

I wish that were the case but neither device is on e-sim or dual capable and on separate lines. TabS8+5G has new sim and had them send new one for Note 10+5G since the original was over 2 years. Not sure about tower modernization either since it's been this way over a year but even worse the last couple months. Tech says nothing going on with towers in this area and with the coverage they see it doesn't make sense. New Tablet vs older 5G phone shows minimal speed difference but going for the S22 Ultra to test because of better 5G tech inside. I can detect mmWave signals but it's not off of my tower which is a tease but do get 4+bars 5GUC on tablet all day long. I know I can get slightly stronger data signals on 5G bands out here but band selector cannot lock them in. Phone steps in and constantly forces me back to band 2 and 66 which are always the weaker signal. Going to test the Hi-boost 10k pro signal booster to see if it makes any difference in data on the LTE signals out here. If I can get - 80 to - 100dbm at least it would be better than - 100 to - 120dbm. 

Hi Jimmy, what you are experiencing is a sim issue, it's unfortunate right now with all the modernization of the towers,  but rest assured there is a fix.  You'll need to switch from the esim to psim (physical sim). We've noticed this issue with all Apple Devices with dual sims. If you're device doesn't have a physical sim, just drop by aT-Mobile retail store and pick up one.  They will be happy to make the switch for you.  No need to use it for a paperweight.  Hope this helps.  

Having the same issues with my iPhone 12 Max. Phone turns into a brick when UC triggers. First time in a long time I’m looking for new service. Reset my network settings, cycled my phone… nothing works. Worst part I can’t restrict UC from triggering and turning my phone into a brick. 

Have you tried using Samsung Band Selector? It's at Play store. You can choose the bands you prefer and just keep the UC bands out. N38 and N41 are mmWave, N260 and N261 I believe is where the UC starts. When I can lock these 4 in I can get better data speeds than on the regular 5G bands. Unfortunately when I do get the better bands the phone eventually will switch me back to the shittier band 2 and 66 for some reason except for on my Tab S8+5G which loves the UC and mmWave. 

Userlevel 5
Badge +4

I saw a post where the suggestion to resolve the data issue when seeing the 5G UC is to revert to LTE. On the 5G capable iPhone go to Settings > Cellular > Cellular Data Options > Voice & Data and then set LTE vs 5G On or 5G Auto. That should work for an iPhone. I don’t have the Android but I am pretty sure the same approach should work. Set the phone to use LTE for data when the 5G UC results in no proper data delivery. I have been there and experience the same issue with my iPhone 12 Pro. It is a bother.

The lower “5G NR” T-Mobile solution has better range and penetration so is more forgiving. The solution seems to be more towers and more uniform coverage. It is not there yet. Sorry but with technology has going pains. 

Userlevel 5
Badge +4

5G UC T-Mobile’s “Ultra Capacity” network technically includes high-band 5G. The range of the higher bands are much more limited (1 mile radius) than mid and lower bands and some phones may not handle the higher mm bands very well. The mid band delivery makes more sense but still the 2-3 mile range and penetration could be sketchy. With the T-Mobile solution it appears the UC could appear when connecting to the mid-band mm or high-band mm network but probably the mid-band mm network. Since the radius of delivery for a mid-band mm frequency is not that broad (2-3 miles) it seems the delivery for mobile customers in transit is probably be a bit problematic. The lower “5G NR” T-Mobile solution has better range and penetration so is more forgiving. The solution seems to be more towers and more uniform coverage. It is not there yet. Just my take. 

Having same issue with S21 Ultra. Anyone find a resolution? 

This is a terrible experience very frustrating and purposeless to have if it’s not going to work in emergencies

Userlevel 5
Badge +6

I see the ‘Adaptive Connectivity ‘ on that Pixel.   you may want to check on its use.

 

https://lifehacker.com/how-to-fix-your-pixel-6s-connectivity-issues-1848149259

I have an iPhone 13 and magenta max 55+ and lost data everytime UC turned on. pretty bad to lose nav data when in a different city and trying to navigate. I saw above that one person was able to turn off UC but I don’t see where that is an option. calling it ultra capacity is a joke. 

I have a T-Mobile Samsung S21 5G.  Same problem.  Normal drive back and forth to my property and even my calls drop whenever my band changes to 5G UC in two spots along the highway.  UC stands for Ultra Capacity regardless of what customer service says.  I can run a speed test when on 5G UC and download at 300Mbps.  Upload at 10.  But cannot use internet, cannot text, cannot make calls.  Makes no sense.  They want you to see how fast it is with a speedtest but then block you from using it for normal purposes.  

Been having the same issues on my iPhone 12 Pro since it rolled out back in November. Very frustrating. Would love to have a solution as well. Got any sort of response yet, T-Mobile? It’s been a long time at this point…

+1 every time I see 5G UC it means not enough internet even for checking emails, I am on T-Mobile ONE, feels like punishment for being on grandfathered plan… no offers, no promos, no internet, I wish John Legere to be back so bad 

No. The solution offered by T-Mobile was to turn off 5G completely and only use LTE… not exactly the right way to keep customers. They should have held back the rollout of UC. 

Exactly! Sounds like T-Mobile is saying, go to another carrier. I still have a couple apps that get no data when UC is connected. Royal PITA 🤬.

No. The solution offered by T-Mobile was to turn off 5G completely and only use LTE… not exactly the right way to keep customers. They should have held back the rollout of UC. 

Having the same issues with my iPhone 12 Max. Phone turns into a brick when UC triggers. First time in a long time I’m looking for new service. Reset my network settings, cycled my phone… nothing works. Worst part I can’t restrict UC from triggering and turning my phone into a brick. 

Figure it out yet? Same issue on my iPhone 13. I JUST got T-Mobile about 2 months ago, and they say UC stands for “Ultimate Coverage”, but that’s gotta be a joke 

Having the same issues with my iPhone 12 Max. Phone turns into a brick when UC triggers. First time in a long time I’m looking for new service. Reset my network settings, cycled my phone… nothing works. Worst part I can’t restrict UC from triggering and turning my phone into a brick. 

Badge

Think I'm good now.  Believe it was a combination of cell tower upgrades in my area and sim card.  Switched to esim and getting better connections and data transfers.

I had this issue on my S21U once UC started showing up. This is what worked for me.

Go to device settings. Then connections. Then sim card manager. Deactivate the SIM. Wait about 15 seconds. Reactivate sim. Enjoy faster speeds.

Hope that helps. 

Reply