Question

Cant view home cameras with T-Mobile iPhone but can with AT&T service.

  • 29 December 2016
  • 58 replies
  • 4373 views


Show first post

58 replies

Mine just stopped working today, 4/17/18 around noon EST. It has been working fine using iphone 7plus and 8plus since i switched to Tmobile last year. Since today i cannot view my cameras anymore using LTE, only works on WiFi. I wish someone can fix, i realy dont want to switch providers.

Userlevel 1
Badge +4

I installed Swann View Plus onto my iPhone 6s, and it works fine.

ok, so making progress, and hope someone can take this further:

I upgraded my router for one that supports IPV6

I enabled 4to6 in the IPV6 option.

I now have a IPV6 IP address

I enabled PING from WAN

I can ping externally either IPV4 or IPV6 addresses

I reduced MTU to 1280 (not seen any difference)

I added a free subdomain AAAA record at http://freedns.afraid.org/subdomain/  this points to my IPV6 address

I can ping with this new subdomain DNS name instead of my IPV6 address, i.e mydomain.mooo.com

all this progress, but still no image in Myeye IPCamera utility using the IPV6 or DNS name

ideas ?

Userlevel 6
Badge +12

I am sorry, there is currently no known solution. You would ether need to work with the vendor/service to have them update their system or use a phone that allows for you to force a IPv4 connection.

That doesn't help, describing the ocean to a drowning man!  We need a solution, not re-stating the known issue.

Userlevel 6
Badge +12

I am sorry that you had that experience. However, it is a know issue with Apple. If you use a Android device you would be able to force a IPv4 connection and things would work out fine. Although I understand not wanting to swap your device for such a reason.

I have iphone 6 with the latest ios update with Verizon couple weeks ago and never have problem viewing my home security camera(Samsung SNH-V6414B) with carrier data until I switched to T-Mobile. With T-Mobile, I can only view my home camera live or stored when on wifi but never on carrier data. Called T mobile several times and even went to their store but no one can help. Was issued couple of trouble tickets but never get any responses back. Only recourse is to switch back to Verizon which has a lot better coverage. T mobile can be a little cheaper but not worth the trouble and agony.

So what is the solution ?

I enabled IPV6 in my router, also the 4to6 service, and still doesn't work.

this only broke when i upgraded IOS10 to latest IOS11

i have tried a bunch of different IOS IPCAMERA utilities

we need solution community....

Understood, now I just need to try make my affected customers understand this.

Thank you,

Userlevel 6
Badge +12

Correct the problem mainly lies on Apple with this one. Other carriers may still work with the Iphone for these legacy services but as they upgrade their network as well and phase out IPv4 support unless on legacy devices this problem will merge its head.

Thank you for the reply, so it's definitely a problem that's a combination of IPhone and T-Mobile, mainly IPhone, right?

I have not been able to test it with an IPhone with a carrier other than T-Mobile network .

Userlevel 6
Badge +12

Its a apple issue that is well known. If you use any Android device or any older iPhone running its original software you won't run into the problem. T-mobile can not do anything to fix since Apple ultimately controls all aspects of the software.

Hi All,

I would like to share my experience on this issue.

I recently noticed an almost identical problem.

I have been installing CCTV cameras for several years and currently have about 25 systems online, using cell phone APPS, that use P2P.

Until recently I starting using an IPhone 7 plus on the T-Mobile Network to view my installations. Prior to that I was using a Note 5, on the Verizon network.

I was always able to access my customer's systems using the Note 5, now on the IPhone 7 I can only see about 15 out of the 25. The others  show online, but cannot access the cameras.

Please check out this scenario,

With my current IPhone 7, I can view an Annke DVR for a certain customer using the T-Mobile service (ISP is Spectrum).

With this same IPhone 7 I cannot view a recently installed Annke DVR (same model  as the above one, the ISP is Frontier), but I can view them using Wifi.

I tried two different IPhone and got the exact same result, not connection. I tried 2 Samsung Galaxy phones and they worked fine using the Verizon Network.

I also tired and HTC one M9 phone using the T-Mobile network and it work fine.

to me it looks like it's a combination of the T-Mobile, the iPhone and possibly the ISPS's modem?

any updates on the exact source/s of the problem and a solution?

Thanks,

Userlevel 6
Badge +12

Magenta so you understand this is forum is made up of fellow customers and users who do our best to help/inform people like yourself on why things are happening. I understand your frustration and if you want anything to change on the backend you will have to work with T-mobile through ether the T-force team, dialing 611 or hoping one of the mods comes by who will not have account level access but will be able to forward the thread over to someone that can help you.

To be clear though T-mobile supports IPv4 and IPv6 tech. In fact the majority of ISPs both wired and wireless do. This protocol is something that has to happen for a few reasons but the main one being that we have to many devices that need connected. Without getting to crazy into tech talk think of your IP as your personal identity for the internet. IPv4 protocol would be like if everyone only had a first name which makes the amount of names possible alot more limited then if everyone had the ability to choose a last name as well. This is one difference between the two.

Anyhow it was Apple who decided to remove the option of legacy support for the T-mobile firmware update they rolled out thus responsibility does not lie with T-mobile as they have no control over what Apple decides to do.

It is interesting to see T-Mobile pointing finger at Apple and not blaming T-Mobile for blindly following Apple move to ipv6.

Apple made a move to ipv6, fine let it be. Why the hell did T-Mobile switch to ipv6 also.

When Apple switched to ipv6, they didn’t break anything. My cameras with the same iPhone and iOS (ipv6) works on other networks like Bell and Rogers in Canada?! So how could it be Apple?!!

It is when T-Mobile switched to ipv6 when things started to break. 

To your point, if T-Mobile stayed with ipv4 like everyone else and let Apple go with ipv6 without doing anything just like other network providers, this problem wouldn’t have happened.

It is T-Mobile switch to ipv6 that caused the issue.

Userlevel 6
Badge +12

This one is on Apple. They force users to connect using IPv6 and some applications have not been updated to support this connection basically. So ether the app dev needs to make a work around or Apple(which will never happen) needs to let users force a IPv4 connection.

I also have been having the exact same issue Using the V380 camera app On ios11. I think the problem started when I updated my iPhone from iOS 10 to iOS 11 about 5 months ago.

I can see the cameras when over wifi from anyw in the world. Once I am on the T-Mobile network the cameras don’t show up. I am also able to connect with iOS 10 on an older iPhone. I spent many hours talking to Apple, and the V380 developer with no success.

I discovered the issue just yesterday when I was in Canada connected to Bell or Rogers, and was able to see my cameras!! I thought something got fixed after almost 5 months of fiddling with the problem. When I went home and connected to T-Mobile, the problem still existed, and I immediately realized it is something to do with T-Mobile and iOS 11.

I called T-Mobile yesterday and they are researching it. I will forward to them this link to show that many people are having the same issue.

For me things have been fixed

It was NOT A problem in T-Mobile part, but the level of security that T-Mobile uses when authentication to the Dlink servers via proxy.

Dlink did not , or had not, updated their end to  newer more robust SSL , so when using my T-Mobile iPhone 7+ over LTE it would fail out.

My AT&T LTE connection was using a less secure standard (as well as a Verizon and Sprint)

If you ever watched the show 60 Minutes and the SS7 (global switching) layer then you would get a idea    of as to why this didn’t work.

I am still waiting on iOS 11 (already have it) to finish to where FaceTime audio is the default versus cell tower voice.

It works for me now and I am content with it.

I am always a adopter of the latest iOS install and this corrected my problem.

I am experiencing the same issue.  I agreed this is nothing to do with the router or iPhone OS. The same iPhone works fine on Wifi network.  Also, the Video monitoring app has no issue if you try to access using the AT&T network. 

The explanation above makes some sense that it has to do with IPV4 or IPV6 but unfortunately, this forum doesn't provide step by step solution.  I have opened a ticket with T-Mobile support and escalated this to their 2nd level Technical Support.  I have also mentioned this post as a reference.

If I find any resolution of this problem, I will post the solution here.

This has nothing to do with the router so you don't have any reason to change anything in the router

This has to do with T-Mobile cellular connecting to the proxy service or do you link uses in order to view the cameras over sailor and it's a problem between T-Mobile and dlink security setting one is too low or too high

dlink  is too low in the proxy settings that's why at&t works

i had my friend download the app I use on his android using T-mobile LTE and he was able to view cameras live fine. I complained to the delelopers of my app but it sounds like it's a T-Mobile/iPhone issue. I wish they could fix something so I can use my app. I didn't spend all this money on cameras Not to view them. someone suggested changing something with router but I have no idea how to change that.

I got Dlink cameras   

and it used to work fine but now, on T-Mobile on my iPhone 7+ or wife's iPhone 6 can not see thru the myDlink app when in cellular

my kid'S iPhone 6 is in StraightTalk on AT&T network GSM and the app works just fine over cellular

I just called Dlink and they said it was because of a proxy issue from T-Mobile tithe my that is NOT the top of the line secure connection that it won't work. It works fine with AT&T because they are not as secure. Ok that's good in one aspect but sukcs in another.

if I am in wifi no problems but I need it to work on T-Mobile cellular too, like it used to

Anyway the guy said to me (like 10m ago today 5/22/2017) that if T-Mobile doesn't help out then there is nothing they can do, and this only affects iPhone users. Guy said if I had a Android it would work in T-Mobile

well I like security    and android is by no means secure, because it is open source based off of Linux

and google makes its money off selling ads and data mining

they can't do that to iPhone users

so come on T-Mobile, make it work, because Dlink isn't the sharpest crayon in the box    dealing with data and cellular

Did you see the first reply in this thread from @theartiszan​ you will need to configure your home router to accept an IPv6 connection.  You might try Google'ing "how to I configure my XXXXXXX brand router to accept IPv6 connections"  you will probably get some hits.

Just know switching back to AT&T is only delaying the inevitable. IPv6 is and has been the new standard for IP addressing and IPv4 is being phased out, T-Mobile is just ahead of the game in upgrading their servers and network. 

I have same issue. I had AT&T on my iPhone 6s and I could view my cameras live on their network fine, I switched to T-Mobile yesterday and now I can't view the live feeds on LTE only works on WIFi. Please help if anyone has Any clue what I need to do to fix this besides going back to At&t.

I have that same issue. Ive talked to my ISP, modem,router, camera manufacturers and even the app developer and none of them can determine the issue. I was willing to pay netgear's tech support to remotely configure my router's setting etc..none work...

iphone6 (tMobile), NETGEAR N600 WNDR3400v3, Akaso IP1M-902 and Yoosee app

i will appreciate any help..im very desperate and need this camera to work:( ty

Reply