Hi All,

T-Mobile Cell Spot is not working.

I have comcast internet with my own motorola modem and a linksys router. I tried connecting to both (one at a time) and the result is same.

The Power (1st) light is a blinking green and the (2nd) internet light is a blinking orange.

I called the T-mobile support and they said they can't do much as the device is supposed to be plug and play.

I called the comcast and they are not blocking any ports. I checked the modem configuration also and no ports are blocked.

Can anybody give me some pointers please? I really appreciate

14 replies

did you get this resolved? I am having the same issue and can’t find a fix. Thanks!

Userlevel 4
Badge +9

Are you having the same issues with a flashing green power light and flashing orange internet light?  This could indicate that a ticket needs to be filed, have you reached out to t-mo via 611, T-Force, or the messaging through app or the Contact Us link at the bottom right corner of your screen?

Hi. Yes I have made calls and tried chat. No luck with a fix, sadly. Seems like it happens somewhat often following searches here and on Reddit but I never see how it’s fixed. Company is sending a signal booster tomorrow but I liked this unit. Thanks for the reply!

Same issue. Called T-Mobile support, they said it could take 4 days to activate. This makes no sense at all. There is nothing wrong with my ISP (Spectrum) or router settings. Even swapped out a Linksys with a Netgear, no difference. Green power light and yellow Internet light blinking for days. Packets do not take 4 days to reach a destination (at least on this planet ).

Has anyone been told what the root cause is? Even if it gets operational in 4 days, what will happen if a power outage or internet outage occurs? I have many IOT devices operational, and they all work fine.

I am having the exact same problem with my cell spot--- Won't connect, green and amber internet light flashing. T mobile has sent me another cell spot,but it but ti won't connect either. I have been waiting for 24 hrs now, but there is no change in the progress of the lights. Some discussions point to an upgrade that Spectrum did to tier internet service. I wonder if that is true? Can someone at Tmobile give us an update on the progress in fixing this problem? I have followed all sorts of trouble shooting steps including checking for the correct ports being open with no results.i

Finally activated and working !! Just waited 5 days or so. No changes to my router or LAN setup.

Userlevel 4
Badge +9

That's wonderful! I'm sorry it took so long to activate, but I'm thrilled to hear it's working now  

Question I am having the exact experience you are describing and it took 5 days? Anyway to know that the device is doing anything with the Power light flashing green and Internet flashing orange? I have tried locating the Cellspot using the command prompt with the arp command and it is not showing the device on my network at this point. Currently I am installing Wireshark to see if the ports 4500, 123, 500 are being used to see if anything is actually happening from that end as well.  If you can think of anything else I might try let me know


any update?  i’ve had the same issue … top green light and 2nd orange light flashing … for OVER 2 WEEKS … really think this is still trying to update?

Following. My cellspot reset and has been flashing the power green light for a few days. Just today the internet orange  blinking light. Tmobile tech support has been useless and just suggests sending me a new one. Mine is less than 6 months old? 

Same issue here. T-Mo is telling me that Xfinity is blocking ports 123, 500, and 4500. I know for a fact that this is not the case. I have tested the UDP ports, and they are all open with Comcast.

T-Mo seems to have a default set of answers when it comes to troubleshooting this device. 
1. Your Internet provider is blocking the ports
2. This is a known issue and it is taking longer than usual to register on our network​​​​​​​​​​​​​​​​​​​​​
3. Defective device, we’ll send another. 

I have had so many replacement devices that I have lost count. The last time this happened, the device just started working one day.  

It sure would be nice to have a T-Mo tech who knows how to troubleshoot these things because not being able to make a call while at home is a major PITA.  WiFi calling blows. 

I am on day 3 and have restarted everything.  I just did another reset of the CellSpot.

The last support person told me she could see that the CellSpot was communicating with their network.

I did a port scan and all the ports are open. Added the MAC to DMZ on my router. 

I was in IT for 33 years and work with computers all the time.  This is ridiculous!

We have very poor reception and my wife needs her phone for business. 

I can’t imagine it taking more than a few hours.  Certainly not days!

Just blinking along…..


Userlevel 1
Badge +1

Hi there! I apologize that you’re having a hard time with your Cellspot. Here are a couple things you can do to ensure that your Cellspot is working properly.

1.) Wait a full Two Hours to let the Cellspot Activate and link to your T-Mobile account. In some situations, the Cellspot can take up to Two Hours to Activate.

2.) Be sure that you are using the Cellspot at the Address you gave to T-Force when your ordered the Cellspot. If you are using it at an alternate Address, be sure to contact the T-Force and have them Update the Address on file in order for the Cellspot to work properly.

3.) Make sure that you have at least 1 bar of 4G LTE at your location where the Cellspot is located. If not, the Cellspot may not work. 

4.) (Yes this sounds ridiculous) But make sure that all connections are secure, including the GPS Antenna included in the Packaging of your Cellspot. If you do not use the GPS Antenna, your Cellspot will not work. 


If all else fails, Contact the T-Force and ask them to replace your Cellspot. I hope I was able to help! If I have, be sure to mark my reply as your Solution! Have a great week!

Exact same issue as noted by the others. Green power solid, Flashing amber internet.

Reset router after 3.5 hours. No go.

I’m curious, why I received a 5 year old cellspot, that has a manufacturing date of the 7th week of 2016? 

I have the “Nokia” cellspot at my home. It works great. 

I just received this 5 year old “Alcatel”? Cellspot for my stepmothers home. And, it won’t install/connect.

How do I get the Nokia version that I have, to replace this headache?