Cellspot Firmware alternative download

  • 16 November 2015
  • 17 replies
  • 543 views

I have a cellspot set up as an access point in my home. In this configuration, the "update firmware" function in the router interface does not work. I contacted ASUS and was informed that they offer NO support for the T-Mobile branded router. Is there a site that has the latest firmware available? If not, why not? Thanks


17 replies

I use the cellspot router. Haven't had an issues, it only updated firmware once when I first got it. The button did work. I haven't been able to find any Firmware online, can't say as to why.

Asus does offer support for the Tmobile router. I spoke with them before, but I had called Tmobile first and they transferred me. Maybe they have a special number? Or things have changed? It's been months since I called about it.

Thanks, I contacted ASUS directly. When the cellspot router is set as an AP, the check for update connection wont work. Anyone from T-Mobile have any information?

Userlevel 5

Unfortunately after some searching, I didn't find anything that was of much help. Have you tried alternate browsers or completely resetting the router?

-Lauren

yes i have. If TMO would provide a download links through the ASUS or TMO websites it would resolve the issue.

Userlevel 5

Which model of ASUS router are you using? I can do some checking to see if it's available anywhere! 😊

-Lauren

I have the TM-AC1900. Thanks,

Kirk

Userlevel 6
Badge +14

Hey just checking in to see if you still need help upgrading the firmware. Have you tried going through the Administration page using the steps in this link to see if it works?

https://support.t-mobile.com/docs/DOC-14950#howto1

I have tried that and it wont work with my current setup. I am using the TM-AC1900 as an access point for the lower level of my home. It is behind my primary router. It would be very inconvenient to undo the access point settings, reconnect it as a router and go through the process of setting it up as an access point again. I don't understand why either T-Mobile or ASUS don't have a site to directly download the the firmware. It appears that others in the forums are asking the same thing.

Userlevel 6
Badge +14

I couldn't find another way to get the firmware update. If the current setup is not allowing you to complete it, T-Mobile wouldn't have any other steps other than completely resetting the router, and using the steps in my previous post to complete the firmware update. If your not on the firmware listed on the Cellspot router firmware update information page, and the update still doesn't complete after the reset, we may need ASUS to take another shot at helping you out on this one.

Mike, thanks for the try but ASUS will not provide support for the router. They refer back to T-Mobile who is not equipped to provide firmware assistance other than reset or reboot. Someone at T-mobile needs to take ownership on the support "vacuum" for the router.

Userlevel 6
Badge +14

Sorry for the delay, but I'm having this looked into. Seems strange ASUS would tell you they don't provide support for this because the firmware would come from their site. At any rate, I'll keep digging for answers. Thanks for keeping in the know.

Thank you, it has been very frustrating. Even on their support website the TMO router is listed but no support information or firmware is listed as all the other models. I had one tech tell me by phone and one by email that all support was done through TMO.

Userlevel 6
Badge +14

Hey just popping back in to give you an update. I checked the ASUS website myself and it doesn't allow you to select the file to download. I did get confirmation that you should be able to click "Check" in the Firmware Upgrade tab, then the file should automatically populate in the "Choose File" area. I know mentioned you currently have it set up as an access point, so I'm not sure it will behave this way if you have it set up like that.

Hi Mike, it does not work that way while in AP mode. Any update on who is actually providing support?

Userlevel 6
Badge +14

Yes, I do have an update. ASUS would still provide support for router as well as the firmware. The best we could do is reset the router, go through the steps I mentioned before, and update the firmware through the admin page.

Has anyone here who's ASUS TM-AC1900 router is running firmware 3.0.0.4.376_3169-g21ec390 have issues with their 5Ghz signal not broadcasting? I've searched online and this issue seems to plague these routers sometimes. I hard reset the unit and set it up like a new router - still no 5Ghz. And yes 5Ghz is showing as active within the administrative settings despite of not.

It seems my router is missing a HUGE security feature for guest networks!

as you can see here https://www.asus.com/support/faq/1009857

We do not have the ability to turn off guest access to our network,

access intranet is not an option on my router!

setting ap isolated will make it so other wireless devices cannot be seen but I am not certain that is working at this point but it does not stop any guest on my network from having full access to my wired network.

Please let me know when this security flaw will be fixed, I would rather not share personal documents with everyone on a guest wifi account

Edit:  Also guest accounts should not be able to connect to the routers management page as well but without any intranet security then anyone accessing the guest network could attempt to login to my router and change anything they wanted there.

Reply