Cellular Data Dropping While in Transit

  • 30 January 2019
  • 20 replies
  • 701 views

Not sure if anyone else has had this issue. I'm hoping yes and that there's an easy fix. I find that often, though not always, data connection drops while I'm traveling, possibly when switching towers? My phone will read 4-5 bars, LTE service but phone has completely lost all data connection. It's easy enough to fix by switching airplane mode on and back off again. Data comes right back, but it will remain shut off until I do this. It is incredibly annoying. Turning airplane mode on resets my tether/hotspot connection so that has to be redone as well which is extremely frustrating if trying to do something as simple as work from a train.

I rarely am on the phone (i.e. on a call) when this issue occurs but the few times I have been I will also lose the call. Or if I have switched towers and have yet to enable/disable airplane mode, when trying to call my phone acts up and will freeze once I try to place a call. I have to wait for it to unfreeze, toggle airplane mode on and back off and then I can call again like normal.


20 replies

Userlevel 4

What make and model phone are you using?

iPhone 8 Plus

Userlevel 4

Have you tried to reset your network settings in the phone's main settings menu?

This will reset any Wi-Fi Bluetooth connected devices status but might refresh the system so that this works a little bit more seamlessly.

Yes. I have tried this and the issue always returns. Might be better for a day or two.

It would be awesome if TMobile would respond and/or do something about this. I am close to throwing my phone down a hole. I am actively looking for a new provider because this problem is so frustrating.

Userlevel 1

That's odd to me it seems something might be wrong with you IPhone had you tried putting the sim card on a other device and test it to see if you have the same issue because if its even freezing for which is rare with recently released IPhones then I say it's your iPhone that might have been given you issues

That is a very good suggestion. I don't have another phone to try this with, though I recently replaced my phone through the apple store. I previously had the same issue. T-Mobile does not seem willing to look into the issue so if it continues I will just move to Verizon or ATT.

I have 2 different phones and having the same issue traveling from the northside of Atlanta to the southside.  I have an iPhone 6s and a new Motorola G7.  I took the sim out of one and put it in the other with no change in the outcome.  This happens m-f so the day of the week does not make a difference either.  Does anyone on this thread or T-Mobile have any suggestions?  This is getting very frustrating and rendering the use of the phone for any type of data communication useless.

I am having the exact same issue while roaming in Mexico, using a Galaxy S10.

I am about ready to give up on T mobile. Data drops out several times daily. Have to toggle the Airplane mode on and off to get data restored. I live and mostly travel in areas with great cogerage, but it still drops. 2020 I shouldn't have to deal with this.

Lately (seems like in the last few months) the only fix is to turn on “airplane mode” and then turn it off.  No bueno, looking for options in terms of a different phone service.

Userlevel 1
Badge

My husband and I have been having the same issue lately!  We used to have incredibly reliable service in our area.  We will range form 2-4 bars but data drops (even with cellspot at home!) until we toggle airplane mode on and off several times.

Mo_Rsa, I wonder if it is some network thing with the Sprint Merger and the move to 5G?  I went to a T-Mo store and also talked to a tech on the phone and did not get a good answer.

Userlevel 1
Badge

@kingRidiculous I am thinking the same thing because we have LTE phones and things started not long after the merger.  I was even told our local tower was recently upgraded when I first reported the issue (that’s when we got the cellspot at our house).  I have been very pleased with the service in our area until recently so it’s very disappointing.  I’m going to try touching base with someone at T-Mobile again about this specific issue to see if I can find anymore from them now that I know we aren’t alone.

@Mo_Rsa , we are twins because I have a cellspot at my house as well. I’m wondering if that is part of this. 

I’m thinking the phone gets connected to the T-Mo network on the Cellspot, but then the phone has trouble getting re-connected to a “real” T-Mo tower.  Lately, I’ve just been turning on airplane mode for a few seconds and then turning it off when I’m some distance from my house.  This seems to be “fixing” the issue.

I’ve had this exact problem. I’m from the UK and my mobile network provider is called Three Mobile. When in the USA my phone locks onto their roaming partner which is T-Mobile. Last week I went to Seattle, Chicago, Washington DC and Philadelphia and after random amounts of time my phone would drop the data signal (4G(LTE), 3G or E) but the little bars would still show sometimes and sometimes not.  I was receiving a Cellular signal (it just seemed to be the data dropping although I never made any calls to test this). This happened about 20 times per day every day in each city mentioned and was 100% annoying. From leaving my hotel to getting to a restaurant 200m up the road it would have lost all data signals! I have a new(ish) iPhone 12 Pro Max. The annoying thing is my girlfriends iphone XR (older phone) picked up the data fine and it never dropped once. I tried her sim in my phone and it did the same thing so not my home network (she’s on exactly the same network and tariff as me). I tried my sim in her iphone XR and it worked perfectly so don’t think it’s a sim issue. I tried switching off 5G in the roaming settings and it didn’t make a difference. I reset my network settings in my iphone 12 and it still didn’t work. I have now completely erased my phone using a computer so that it has to re-download the whole iOs operating system (rather than resetting it from my phone). It’s annoying for me as need my phone for travelling so can’t test it until I’m next in the USA which could be months away and my phone will then be out of warranty (if it’s the phone that’s faulty). Apple suggested I buy a sim to use just in the USA on a different network but I don’t want to have to pay extra as with Three I can use all of my included minutes, texts and data when in USA and all of my previous phones have worked fine there when data roaming. I switched off automatic network selection and tried selecting AT&T and Sprint but my phone won’t allow this as I’m roaming and Three is partnered to T-Mobile. I have noticed in my home country that the 4G (LTE) signal seems to be worse since they starting rolling out 5G. After reading about T-Mobile and Sprint merging I wonder if it has anything to do with that? I was convinced it was my phone but now not so sure. I was reading about channels and someone wrote that the 5G opens channels that some networks can’t use and tries to force your phone onto so drops the data signal but not sure. It’s just frustrating that a phone less than one year old can’t do what a phone from a few years back can! The airplane mode ‘fix’ works but it’s very annoying in this day and age having to effectively reset your network signal just to be able to receive data!

Userlevel 7
Badge +13

if you tried her sim card in your phone and it still did it..then tried your sim card in her phone and it worked fine...everything is pointing right at your phone being the culprit. if the problem followed the sim card then it would be sim card related..since it didnt follow and stayed with your phone no matter the sim card then it points right back at the problem being your phone. since its a European device it might be missing certain bands that are used here in the U.S that her phone actually has on it.

That’s what I was thinking and had a support call with a Senior Apple consultant from California. It’s just frustrating that my old iphone (that my girlfriend now has) works fine. I’ve got an appointment this weekend here in the UK at my Apple Store although even if they swap the phone I’m still not sure if I can test it as won’t be in the USA for a while. The Apple consultant said that she has heard of the problem before. It’s also weird that it’s the exact same problem that the posters above mention (and I assume they live in the USA). My phone works fine here in England.

I have a Samsung s21 . My phone has been doing the same thing. Losing network 20 some times a day. Went through a bunch of steps with tmobile tech. Nothing fixed it. Was also tokd to do a cache wipe but afraid I'll lose stuff on my phone if i don't back up memory.  Hearing all these comments and complaints tells me that probably won't work anyway. 

I did actually get mine working. I had to erase everything and set up as a new phone and instead of restoring from a backup (from my previous iPhone) I set it up as a complete new phone and downloaded all my apps again. It must have been because I went from iPhone XR to 12 and it didn’t like bits of my restore from the XR. 

Reply