Solved

Default to WiFi Instead of Cellular Connection (Not Working)

  • 24 January 2018
  • 28 replies
  • 2217 views

Hello,

I receive very poor reception in my home that ranges from one bar to (sometimes) two.  It cuts out and drops calls frequently.  It seems as though my phone (iPhone 7 running iOS 11.2.5) is defaulting to the poor cellular connection instead of my WiFi.  It's driving me nuts, especially as I use the line for work calls and they keep getting dropped.  Does anyone know how to make the WiFi the default connection?  I put the phone in airplane mode and toggled the wifi on and off and got it to work that way, but that doesn't solve the problem for incoming calls, and I don't want to have to remember to put my phone in airplane mode whenever I arrive to my house, and then turn it off again when I leave.

I've google this and seen others with the same frustration - some of which have simply had to leave the carrier, which I do not want to do.

Thank you for your help!

icon

Best answer by tmo_chris 28 January 2018, 01:14

Thanks for clarifying. I think in this situation we will more than likely need to look into a device replacement. There is no reason the device should be trying to connect to cellular with when you are connected to Wi-Fi and have Wi-Fi calling enabled. I know that you said it works fine on Wi-Fi when you have Airplane mode on and Wi-Fi on but still, the phone should not switch to cellular when you are connected to Wi-Fi calling unless your phone is losing connection to Wi-Fi for some reason.

Please contact our tech care teams as soon as you have a chance so we can get the ball rolling on this.

View original

28 replies

Userlevel 6

iPhones default to WiFi.  If it is connecting to cellular instead of wifi then the wifi might be the issue. Might be you aren't authenticating with the router properly. Could be traffic is too high from other devices in the same wifi  You might try turning off wifi assist as well, because that will try to use cellular when wifi is weak.

Sounds like this one is going to be pretty tough for me to get to the bottom of.  It was working fine until recently.  I have a great wifi setup and all of my devices work flawlessly with it except for the occasional hiccup when I have to restart the router once in a great while.  The phone also works great with the wifi connection (streaming, etc.) outside of the calling.

Userlevel 6

You can also turn off wifi calling on the iPhone.

I've tried that.  The reason that it is dropping calls is because it is prioritizing the poor cell connection over the wifi connection.  When I make calls in my house by turning on Airplane Mode and then toggling the wifi connection back on it makes crystal clear calls without interruption.  It will not connect to my wifi unless I turn cellular off on my phone completely.  It prefers to connect to the fluctuation of zero to one to two bars I get, and then drops a call, over the connection to my wifi (Airport Extreme and Airport Express).  I apologize if I was unclear in my original post, @snn555​ .  I appreciate your responses.

I've got the exact same problem with my iPhone.  WiFi is not the problem.  It has excellent signal strength for all other uses on the iphone and nothing else is using the network.  After a few seconds, the phone keeps reverting to the missing cell signal and drops the call.

Very interesting.  What iteration of iPhone are you using?  What version of iOS?  How long have you been looking for a fix?

Thank you for sharing.  I thought I was losing it.  Still frustrating as all heck!

Userlevel 6

iOS 11.2.5 is available. Idk if it fixes any issues but there might be a carrier update available that will help.

I am already running 11.2.5.  I try to stay up to date on all updates in case a problem like this arises.  I checked to make sure that I am running the most current carrier update.  https://support.t-mobile.com/docs/DOC-36411#steps1

Thanks again.  Do T-Mobile support people ever read these boards?  These situations tend to stink because they're just going to kick me over to Apple and Apple is just going to kick me over to T-Mobile forever until I've just wasted my time and not come up with a fix.  If it wasn't at my home and I wasn't fielding business calls it wouldn't be nearly as big a deal that WiFi calling wasn't prioritized over cellular, but coming from AT&T a year ago I really rely on the WiFi calling feature more now than I used to even outside of the house.

Userlevel 6

Being a customer to customer Forum there's generally not a lot of technical assistance from T-Mobile personnel. T-Mobile employees on the Forum are mainly Community moderators but sometimes have useful information. In most accounts that the customer is unable to assist you would be directed to Tmobile on Facebook or Twitter for a faster more in-depth response or B directed back to the manufacturer.

I know it stinks getting bounced back and forth but it could be a hardware or software issue with apple or it could be a network issue with TMobile or it could be a hardware issue with a third-party device manufacturer like a router.

Userlevel 6

I can say that in the past I have had some success with dealing with Apple support. They can not only open a ticket on their end but they can have a diagnostic run on the iPhone and uploaded through iTunes. That diagnostic log can be sent to apple and usually they can take a look at that pretty quickly and see where the phone is failing in its Communications connectivity.

Using iphone 6 with IOS 11.2.5.  Its been reset and restored too.

Awesome!  I'm traveling now, but will try reseting all network settings again when I get home and hope that plus the update will do the trick.  Fingers crossed.  Thank you for the update.

Resetting does not solve the issue for me, I still have the problem.  I was just responding to the person who asked what phone and IOS version I have.  My phone has been reset and restored but the problem continues.  It won't hurt to try resetting though.

Ah, I see, bummer.  Thanks for the heads up.  I guess T-Mobile can't push me back to Apple though since I can demonstrate that the iPhone works with zero problems when I am disconnected from cellular (Airplane mode), but have wifi on for calling and am using my router.

Userlevel 6

I still think it's worth a shot letting Apple run a diagnostic and uploading the log to them

Userlevel 5

So I hope I am not sounding silly here but are we 100% certain that Wi-Fi calling is enabled when this happens?

Before placing a call do you see:

Or do you see:

If you see the first one, go to settings>call>Wi-Fi calling>toggle switch to enabled and see if you see T-Mobile Wi-Fi

Thank you so much for your help Chris.  I do have Wi-Fi on and do see that displayed at the top left hand corner of my screen as you have pictured in your screenshot.  The reason I feel so certain that it is working is because when I toggle on Airplane Mode I cannot make a call on Wi-Fi or cellular (obviously).  However, when I activate Wi-Fi while in Airplane Mode every test call that I make works, and the person receiving the call says they can hear my voice even clearer than usual without experiencing me going in and out or dropping the call.

From this I deduce it must not be the iPhone itself or the Wi-Fi service in my home.  Of course I could still be wrong, but it seems to eliminate a lot of the doubt.

Here is a thread where someone seemed to have experienced the same issue as me, although I just don't have the time to jump through all the hoops this guy did to get my phone working on the network at the moment:  WIFI Calling Down

I do appreciate your suggestions.

Do you have any advice if you're out there @magenta1416786

Userlevel 5

Thanks for clarifying. I think in this situation we will more than likely need to look into a device replacement. There is no reason the device should be trying to connect to cellular with when you are connected to Wi-Fi and have Wi-Fi calling enabled. I know that you said it works fine on Wi-Fi when you have Airplane mode on and Wi-Fi on but still, the phone should not switch to cellular when you are connected to Wi-Fi calling unless your phone is losing connection to Wi-Fi for some reason.

Please contact our tech care teams as soon as you have a chance so we can get the ball rolling on this.

Thank you so much for your help @tmo_chris.  I am going to try to get in touch today and will let you know how out goes.  It will be a huge relief if I can get this portion of the service working again!

Ran through some trial and error tasks as well as diagnostics with a tech and T-Mobile is replacing the device by shipping a new one to the T-Mobile store I purchased it from.  Hopefully this work, but he sounded pretty confident.  I'll eventually report back although it may take ten or so days.  Thank you!

Exactly the same behavior with a Pixel 2. Really bad coverage area (not only T-Mobile, all networks), WiFi calls on, but it defaults to network. I have to turn on Airplane mode and then turn WiFi on to receive and make calls from home. Then Turn it off when I go out. Very inconvenient.

I have the same issue trying to stay connected to wifi while in the house.  My issue started after I switched my service from AT&T to T-Mobile.

My wife and I both have the exact same issue.  We're both using iPhone 7s, fully updated with newest IOS and T-Mobile updates.  We live in an area where we have 1, sometimes 2, bars for our T-Mobile cell coverage, so WiFi calling is imperative!

And "yes" we have all the settings on our iPhone set for WiFi calling.

When the "T-Mobile WiFi" notation at the top of the screen is there, we have good phone service for both in-bound and out-bound calls.  Then, it will disappear and all we see is the 1, or sometimes 2, bars and then the call service is terrible.

Help!!!!

Thank you.

Cheers,

Bryan

I also have this issue and had it on my previous iPhone too. Most WiFi networks I connect to, my phone does not switch to T-Mobile WiFi, and relies on whatlever cellular signal it picks up. If I switch on Airplane mode, then Tmobole Wifi immediatetly kicks on. And seemingly at random it will also turn on without needing Airplane mode. I am on an iPhone XS. It feels to me like there’s some network prioritization code in iOS that’s acting in unexpected ways. 

Reply