Solved

Email to sms gateway not working

  • 4 October 2019
  • 14 replies
  • 2581 views

I used to get alerts on my phone by using phonenumber@tmomail.net

Stopped receiving these alerts about an year ago

All other carriers are getting these alerts, also t mobile users are getting these alerts, except my phone.

Not sure, what is causing it. Any help is appreciated.

I tried to put my sim card in another phone and see it the alert gets delivered, no luck so far.

Doesn't seem like a phone issue.

Srickar, i have seen you helping other users with this issue, i have sent u a follow request hoping that you help me out.

I am wondering if my number is blacklisted for these alerts because sometimes i get a lot of these alerts.

icon

Best answer by tmo_amanda 7 October 2019, 23:45

View original

14 replies

Userlevel 4

Hey, @subodh123​!

We have a mega thread about the same issue here: E-mail to SMS being blocked due to suspected SPAM​. There's a fantastic engineer that monitors the thread and helps out our users, as you noted in your reply. I recommend replying to that thread so we can figure out why you're no longer getting the notifications.  

Hello Amanda,

Srickar was able to help me out and we were able to resolve the issue.

Thanks,

Subodh

Hey, @subodh123​!

 

We have a mega thread about the same issue here: E-mail to SMS being blocked due to suspected SPAM​. There's a fantastic engineer that monitors the thread and helps out our users, as you noted in your reply. I recommend replying to that thread so we can figure out why you're no longer getting the notifications.  

Hey Amanda,

I am having this same issue for a email alert that is not working. I tried to follow the link to the other thread but it is gone. Hoping that engineer can help me out too! :) 

Same issue here, and same problem as k.dougherty:  that link (which shows up in multiple posts on topics related to the SMS/MMS gateway) no longer works.

I’ve heard that T-Mobile discontinued the gateway service, but I can find nothing to document that.

Badge

I’m trying to send my self a sms via email and testing using my number plus @tmomail.net. I get the notification to download it, but it doesn’t download after I click on the sms.

 

What am I doing wrong?

 

My work uses this function as well, I get a sms notification to download a message and nothing will ever download

Badge

This is not working for me and that thread link is not valid any more https://community.t-mobile.com/network-coverage-5/thread/144851

 

@tmo_amanda  @t-mobile_2027  : Can you please check and update on this - Thanks

 

I am having trouble sending an email to text from my Outlook email. It will work when I send one to a recipient om another carrier. It will work if I use my Gmail to text. There is an issue with Outlook to T Mobile sms.

Badge

@magenta10324128  I just try with gmail to text and its not working for me. I use <phonenumber>@tmomail.net 

 

Is that above format correct or ?

Yes, that should work.

Userlevel 6
Badge +11

contact srickar in this thread...also read through what he posted in case that resolves your issue.

 

 

Badge

I think, I found the solution, On iPhone under Settings → Messages, we have to turn on ‘MMS Messaging’ and ‘Group Messaging’. I also turned on ‘Send as SMS’. Which was disabled for me.

 

Now, its working for me :-)  from outlook. I will now further test with our Alert system as well.

 

FYI
Shameem.

I have an Android. I just tried it using Gmail, which worked before, and it didn't work either. This is what I usually receive when receiving from Outlook.

 

Badge

@magenta10324128  Its working for me with yahoo / outlook / gmail as well.

From first hand experience:

For now SPAM blocking of INDIVIDUAL incoming email to SMS text messages is not possible.  You can try to block them individually but that does not work.

I would suggest that you TURN OFF the email to SMS gateway by placing a call to T-Mobile support (611) and asking them to “block the TMOMail.net SMS messaging gateway”.  A switch will appear in your T-Mobile app that turns off ALL incoming email to texts.  This will stop the bogus emails to your SMS/text messaging app on your phone.  It’s great if you don’t need to use email to text messages.  It DOES turn them ALL off, not just the bogus email to texts.

 

BTW,  Do not expect that if you turn off that feature from your app/phone/account that you will be able to turn it back on by yourself.  It will need to be turned back on by T-Mobile support.  I am not sure why the feature disappears when you switch it off.

 

Reply