Solved

Fairphone 4

  • 3 April 2022
  • 9 replies
  • 911 views

Badge +1

Hi I bought a Fairphone 4 which seems to be mostly compatible with my phone in the USA. I can get 5G mobile speeds on this phone. (Yes!) But then when I try to use the built-in Google Messages app using the default settings from my T-Mobile SIM it gives me a “Can’t send messages with T-Mobile, Error 50” notification. Everytime I try or resend it seems to give me that message. I have tried changing APN’s and copying it from my old phone that worked to the new one and seems to do the same thing. But when I pop it into the old phone it says it works. When I switch from the Fairphone 4 to my old phone it says from 2903 “We see your phone does not have correct settings to access the internet or send MMS. Settings will be sent to your handset.” And I click the messages and it downloads the settings again to my old phone and still works. But I can’t get my new phone to recognize. Fairphone is a European phone but the bandwith is essentially the same. The fact that it can access internet and pull 5G internet means it can go online. I would think this would enable it to also send SMS/ MMS. In fact when I try to send text SMS it gives me that Error 50 message. But when I do a picture MMS. It looks like it goes through, but never appears on the receiving phone. And also the antenna symbol has an “X” on the bottom. That’s the triangle wedge on the top of your phone screen that shows how many bars and how strong your connection is. But I don’t think that’s the problem because when I turn on data it shows 5G Basic.

So on my older phone it shows 5 APN’s:

T-Mobile

fast.t-mobile.com

 

T-Mobile LTE

fast.t-mobile.com

 

LTE Attach Profile

 

T-Mobile IMS

ims

 

T-Mobile Emergency

sos

 

But the Fairphone 4 when I load the SIM in there shows only the T-Mobile USA APN and no others. I have tried manually adding and also T-Mobile settings shown here:

https://www.t-mobile.com/support/devices/not-sold-by-t-mobile/byod-t-mobile-data-and-apn-settings

 

I checked the settings and the Authentication type for T-Mobile says PAP while my Fairphone 4 uses the None listing.

There are also additonal settings in the Fairphone 4

APN type: default,supl,hipri,xcap,mms

APN protocol: IPv6

APN roaming protocol: IPv4

Bearer: HSPA,VDO_B,eHRPD,LTE,HSPAP,GPRS,EDGE,UMTS,IS95A,IS95B,1xRTT,EVDO_0,EVDO_A,HSDPA,HSUPA

MVNO type:
GID

MVNOvalue:544D

And on the data screen I have MMS messages: Send and receive when mobile data is off

Preferred network type: 5G/4G/3G/2G

and Automatically select network defaults to T-Mobile

icon

Best answer by magenta2053076 26 May 2022, 21:54

View original

9 replies

Badge +1

I just wanted to confirm that the phone is now working. It was giving me an error 50 because TMO was BLOCKING my account since it was a new phone and I think it was international and had never been used. They had to get do *#06# to get my IMEI and then register me on the network. I was on the phone for about 30 minutes. They had to escalate it to someone with authorization to unblock me since it was about Sunday when I called. Then they said would call me back in an hour since the person wasn’t immediately available or it took time to get registered. After about 1 hour the person called me back and we tested the SIM on the old and new. It wasn’t initially able to receive messages but could send. After they unblocked a few more things it worked on the Fairphone 4. I also took out the SIM and tried it on the old phone again and it took about 5 minutes and it registered the old phone handset again which is what I wanted so I could swap back and forth. The rep said it takes a while but it does take time to swap between handsets but they had unblocked me entirely. After the call I put it back in the new handset again. So it works in the USA this phone. It does sometimes go to H++ or 4G depending on area, but usually is 5G. I have no major problems with this phone and seems like an upgrade and faster and more stable. The battery is slightly less capacity than my old handset that had an after market battery for a non-Fairphone handset. Also the Android 11 operating system on this handset is nice, but I don’t like that Google makes sdcards restricted in the name of security. I like being able to access my disks. All in all this seems to be working now.

The VoLTE suggestion above seemed irrelevant, but thanks for the help, I just broke down and called their help support (wasn’t sure they supported the new phone but they did!)

I think you might have VoLTE off. I really want to get a Fairphone myself but was worried about lack of B66 on it.

This, and the problem of not having T-Mobile Wi-Fi calling, would be fixed if T-Mobile would just start offering the Fairphone 4 here in the US, the way they do in Europe.

Badge +1

Sorry, but still doesn’t seem to work. Can’t see VoLTE settings on this phone. Maybe I need to check SMSC settings with the secret Android dial code *#*#4636#*#* . But it seems to match the settings here for SMS center here:

https://www.t-mobile.com/support/devices/not-sold-by-t-mobile/byod-t-mobile-data-and-apn-settings

I may have to reach out to help line soon if no more ideas...

Hmm, I'd check out the forums on Fairphone’s site themselves. From what I can see people are having trouble getting VoLTE working. There's a thread called “Fairphone owners in the USA”. I'm very curious as I want to get one myself, but cannot if VoLTE isn't working :(

Badge +1

Also I really didn’t need to do anything with my APN settings as they were already on the SIM card. The problem was on TMO’s end with the SIM IMEI blocking and registration...

Yay! I really am tempted to get one when it's time for my next phone.

Badge +1

Yay! I really am tempted to get one when it's time for my next phone.

I had to buy it from a third party like Ebay as you can’t get it directly from the official site. They don’t sell to the USA for now. None of the accessories either. But it seems to be a decent phone minus the SDcard restrictions from Android 11. May one day have to use Magisk or some program to elevate to root permissions or use more recent apps to get full access to SDcard like my older phone… but I digress.

I have family in Europe so I can order it to them, though the timing of receiving it is highly dependent on their travel schedule :D Agreed about the SD card.

Reply