Question

Good signal/bars but no network connection many times daily

  • 13 July 2021
  • 45 replies
  • 26741 views

Userlevel 1
Badge

Ok here's what is going on... I have pretty good signal almost full 5g bars most of the time down to where it drops to 4g lte at full bars. From time to time every couple hours I lose connection to the network where I can't text no apps work etc but usually I can still make calls just fine while this is happening. It only lasts 1-2 minutes sometimes or it may be out 15-20 then all of the sudden it's back to normal like nothing ever happened. It may go right back out again in 2 minutes or it may not happen for hours. Also it only happens on my new galaxy a32 not on our old galaxy j7 or prime whatever it was or on the older LG phone both of which are still being used on this account and same house at same time but they have no issues with connection ever. They aren't 5g either so I figure 5g has something to do with it. It just really gets old when you can't finish a conversation or get directions because internet/network connection just stopped. What can I do? All my connection settings are set how tmobile and other people have said they should be. I don't have Wi-Fi so I'm set to always use mobile data. What now? Or will I just have to suffer through. It's prob just some tmobile network problem that's with the new 5g. I guess that's what I get buying a new phone. Any ideas?


45 replies

Userlevel 6
Badge +15

I have a couple ideas about this. If you’re in a lower level room or basement, you can have some issues with the connection cutting in and out due to line of site. I’d head to a higher level of the house/building if possible. Restarting the phone on a daily basis can help make sure you maintain a solid connection. If this is happening in the same area and even around the same time of day, this could be something our engineering team can look into after our Tech Care team files a Service Complaint for you.

Userlevel 6
Badge +13

you might be on the edge of 5G coverage as well.. so you might also try going into your mobile settings and changing it from 5G to 4G..restart the phone and make sure its not pulling in 5G still..if it isnt then go ahead and run it like that for the day and see if the problem persists or if it goes away.

Badge

I’m having the same issue with my S21 Ultra. I can be sitting in my living room and have 5G w/full bars and it will not allow me to use any apps or internet through chrome. States, Offline. Place it in Airplane mode and back off and it works again. What gives? OP were you able to figure out the issue?

Userlevel 6
Badge +13

did you attempt to change it to 4G instead of 5G in case its an issue on the 5G side of things?

Userlevel 1

Did anyone ever get this figured out?  Has been happening to me for a long time on multiple iPhones, including my brand new iPhone 13 Pro (and my iPhone 12 Pro before that). It doesn’t happen to other family members, and it’s bad enough that I’m starting to look at what options I have with other mobile providers (not a threat, I’m just at my wits end…)

Userlevel 5
Badge +6

I can say for the iPhones, but in my experience with Android, and Samsung/Oneplus and LG, 5G “extended range" can sometimes make service worse.  I've actually gone and disabled n71 on 5g as it becomes the weakest link in a chain, especially when 5g is coming from one tower, and LTE is from another.  Depending on your area, you might not have 5g “ultra capacity” for use, which would give you LTE only.

I also experience this issue randomly throughout the day. Hopefully there is an explanation and solution to this.

I am also experiencing this issue; it started around September 20. I even did a Factory Reset on my Z Fold3, but it didn’t make a difference. 

My co-worker also has T-Mobile, we sit in the same area, but he doesn’t have this issue.

Has T-Mobile find a solution yet?

Userlevel 6
Badge +13

I am also experiencing this issue; it started around September 20. I even did a Factory Reset on my Z Fold3, but it didn’t make a difference. 

My co-worker also has T-Mobile, we sit in the same area, but he doesn’t have this issue.

Has T-Mobile find a solution yet?

if someone else with TMO is right in front of you and they are not in any way or form connected to your account and their service is fine then its an issue with either your phone or something with your account.

I am also experiencing this issue; it started around September 20. I even did a Factory Reset on my Z Fold3, but it didn’t make a difference. 

My co-worker also has T-Mobile, we sit in the same area, but he doesn’t have this issue.

Has T-Mobile find a solution yet?

if someone else with TMO is right in front of you and they are not in any way or form connected to your account and their service is fine then its an issue with either your phone or something with your account.

Perhaps you are correct; I have already replaced my phone. Another line in my account is also experiencing similar issues. 

Thanks for your comment.

Badge

I find it happens in the vicinity of Ave U in Gravesend, Brooklyn. No one can hear me. It goes out. Unfortunately, it happens in my house and I can’t live this way since it is my only telephone. Anyone in that vicinity?

I had this issue for a year with my iPhone 12 Pro (I simply dealt with it, switching airplane mode on and off to reset the connection) and now with my iPhone 13 Pro. This morning I took my dog out and found I had no connection the moment I left my house’s wifi. And I can tell you for a fact that there is literally a T-Mobile 5G microcell within 300 feet of where I was standing, basking in solid full signal, and no data connection whatsoever. This happens nearly daily to me, or at least seems to when I manage to catch it. 

Userlevel 1

This is happening to me constantly on an iPhone 12 Pro running iOS 15.1. It happens when I leave my home wifi. It happens when I’m driving and need to access Google Maps, among many other situations where I need data. Google Maps will say “poor connection” or not even appear to have a connection at all, yet my phone has full blown 5G service. Toggling airplane mode usually fixes it, albeit temporarily. Sometimes it only fixes it for a couple minutes. When it manages to fix itself I get a slew of notifications that are finally able to be pushed through. 
 

It’s extremely frustrating. I have 5G in most areas, most recently 5G UC. I live and work in a major city and I almost never get a signal below 5G. I switched to T Mobile and initially loved their service, but this is frustrating to no end. Resetting my Network Settings is becoming annoying at this point and is not an acceptable solution anymore. 

I just got the new Moto G100 and I am having this exact issue. Maxed out 5G signal, but it's running like it's dial up. Slow if it works, with repeated dropped signal. Irritating is an underwhelming statement.

Userlevel 1

I landed here while googling for help on the same issue. Nothing to add other than happens to my wife and I daily on our new iPhone 13’s with T-Mobile. Stinks, because otherwise, our decision switch to this carrier has been been okay and the network is definitely fast when it works.  The issue seems worse when leaving wifi going to cellular data but it also happens randomly when out and about. In all situations, full signal, no data.

 

Happens to me all the time … shows it have bars and LTE but no data connection… dealt with this for a while now … switching to Verizon seems it might fix the problem 

Userlevel 1

This is quite frankly the only issue keeping our switch from Verizon to T-Mobile from being great. I’ve been impressed otherwise by not seeing any drastic reduction in coverage vs Verizon. T-Mo also has. better UWV presence in our area than the competitors and it’s pretty fast - when it works.  However, all that said, I am about to lose my sanity and jump to another carrier.

 

I spoke with support last week only to be told that I should consider turning off the 5g on my iPhone to fix the issue. I didn’t switch carriers to the “nations best 5g coverage” to turn off my 5g. 

 

Exact same issue as all others have described. S21 Ultra. 

TMobile wtf? 

How bout an explanation by now?

Userlevel 5
Badge +6

I can't speak for the ultra, but on a S21 in many areas, I've either disabled 5g , or disabled  n71 SA/ n71 NSA due to it being either saturated on SA or ‘the weakest link in a chain’ on NSA.  eg.  1Mbps on ‘auto 5g/4g/3g/2g’, and 60 on 4g/3g/2g.   if I went the route of  disabling n71, but leaving n41 enabled, I get 400Mbps.

Userlevel 5
Badge +6

If you're willing to test the waters…to disable n71.  menus are slightly different on each Samsung model...this is from S21

*#2263#

 

Userlevel 5
Badge +6

Lastly…

Then just hit your home button.

Userlevel 5
Badge +6

If you're worried,  *#2263#

#8 select all bands

Then

#9 Apply band configuration

 

Userlevel 1

FWIW - Here is the response I received from T-Force when asking about the issue. The funny thing is, 5G coverage in my town is honestly pretty good with UC covering a good chunk of town. I don’t think lack of coverage is to blame and I am interested to know about this special iphone 12/13 network she referenced :) Realistically, it’s probably a N71/LTE blending issue.

 

“It's important to have all the details you need to know about our 5G service. I'm here to help! We have a new 5G service that we're prepping called stand alone 5G for the iphone 12-13 series. This will allow your phone to operate even if there is only 5G signal in the area. We currently don't have this service available in your area quite yet. We do have a 5g tower in your area and at the moment you should definitely be able to see 5g outdoors and in most homes (depending on your location) but the LTE signal in this area is quite a bit stronger at this time so it's likely your phone will opt for LTE for the best experience till we add additional 5G spectrum. To why I suggest on you turning off the 5g from your device till we launch this software. Our 5g network is still maturing and we look forward to providing more 5G coverage as our journey continues. You can always keep an eye on our network newsroom here: https://www.t-mobile.com/our-story/network-and-innovation to stay up to date with our integration plans. Meaning you will experience some issues with lagging, call drops, messages not sending nor receiving, data issues till we launch this new software to our iphone 12-13 series. I would suggest to turn off the auto 5g connect and connect to LTE/4g as the signal is much stronger. If you want to go ahead and give this a try after restart your device please”

 

 

 

Userlevel 5
Badge +6

That's pretty much a nice way of stating iPhone 12/13 doesn't always work well with 5g NSA

I wish I had something different to add but, I’m just confirming that I have the same issue and am thinking about switching back to Verizon. I wanted to love t-mobile but just isn’t usable. Like all of you, great signal but no ability to use data.

Reply