Question

Good signal/bars but no network connection many times daily


Userlevel 1
Badge

Ok here's what is going on... I have pretty good signal almost full 5g bars most of the time down to where it drops to 4g lte at full bars. From time to time every couple hours I lose connection to the network where I can't text no apps work etc but usually I can still make calls just fine while this is happening. It only lasts 1-2 minutes sometimes or it may be out 15-20 then all of the sudden it's back to normal like nothing ever happened. It may go right back out again in 2 minutes or it may not happen for hours. Also it only happens on my new galaxy a32 not on our old galaxy j7 or prime whatever it was or on the older LG phone both of which are still being used on this account and same house at same time but they have no issues with connection ever. They aren't 5g either so I figure 5g has something to do with it. It just really gets old when you can't finish a conversation or get directions because internet/network connection just stopped. What can I do? All my connection settings are set how tmobile and other people have said they should be. I don't have Wi-Fi so I'm set to always use mobile data. What now? Or will I just have to suffer through. It's prob just some tmobile network problem that's with the new 5g. I guess that's what I get buying a new phone. Any ideas?


45 replies

Honestly it does sound like a device glitch on the iPhone side. I have an iPhone 13 Pro Max and running on the 5G in my area,  ever fall from 4 bars and still I get CB glitches. I have the T-Mobile 5G home internet and when I  run the wifi through my iPhone, Voila, internet is Super fast. 

I have been having the same problem on and off for a few months and it is about to make me switch carriers. I finally found someone who understands what I'm going through and describes it well! I have an LG velvet that I've had for 1.5 years and I had no problems until the last few months. But my problem happens whenever I leave Wi-Fi and go to mobile data, or when I'm on 5G and then I go out of 5G and try to go to 4G. Everything shuts down. It shows me I'm still connected so I've been unaware, only to find out that there's a bunch of texts people didn't get from me that I thought went through, and there are texts that I'm not receiving. And on occasion I've tried to make a call during this time and it won't call out. When I restart my phone it's fine. But it happens frequently and I need this fixed! I have five other people on my phone line but none of them have 5G except me. None of them have problems. So are we pretty convinced that it's a T Mobile 5G problem? I've been with T-Mobile since 2006 but I run my business from my phone and I can't function like this. Even when I leave my phone on LTE all the time it still happens. Have to constantly restart my phone or turn airplane mode on and off. I'm never really sure what's working to fix it. Does T-Mobile text see this thread?

Having the same problem. I just switched from Verizon to T-Mobile last month because I was eligible for an upgrade at work, but Verizon did not have the Galaxy S21 in stock. I never had this problem with my S10 on Verizon. If I leave the house and I assume am jumping from tower to tower or 4G to 5G, I pretty much always have to go into and out of airplane mode at least once to get a connection back. This is when I am showing 4 or 5 bars. I’ve even seen it act weird showing 5G and no bars (gray x), but have a connection. Pretty annoying to be sure. I just turned off 5G in the settings to see what happens, but a fix would be a lot nicer.

Just a follow up, and hopefully I don't jinx it, but I haven't had a disconnect since turning off 5G. Sucks that I can't use 5G, but it's better than all the disconnecting.

Had the exact same issue on a iPhone pro max 13. It turns out somehow the data package was turned off for the line. I still got a data connection for a few mins here and there when I restarted the phone or toggled airplane mode but it quickly disconnected. It took t mobile a while too figure it out and then turn data back on. Phone works perfectly normal now.

i have been having the same experience ever since they merged with sprint. i call or chat with customer support and NOTHING ever gets done. they said my s9plus was to blame and its cause i didnt have a 5g capable phone. so i bought a note 10plus 5g and STILL have these dang problems.. yet they want me to pay this bill on time every month. I am with the others that say i have had enough and if its not fixed i’m just jumping to Verizon or ATT. this is ridiculous   

Have had the same issues for quite a while. Now it happens multiple times a day. It always alerts me that I have new voicemail when the network comes back on. I can not use the phone, data, apps, or internet while it does this.  Sometimes it will pop up and say visual voicemail has detected a new sim card. 

I have reset the network setting, taken the sim out and inspected the surroundings, reset my phone numerous times, talked to a t mobile “specialist.” They are gonna send me a new sim to see if that works, but I have researched online very similar stories saying that didn’t change anything. So skeptical. We will see. 

I have an s20. 

Badge

S21 ultra here too,  in Austin Texas and the service was working fine a few days ago.  The last 2 days,  all 5G had gone to sh*t and it's si hard to do anything if I'm not on wifi.  

The Support team are all trash,  give no real answers or help.  Help

Userlevel 7
Badge +13

since 5G is tanked have you tried switching the phone to 4G/3G instead to see if you regain usable signal for now at least until the 5G side is figured out? or is it affecting that side as well?

I have the same problem with s20 5g.  I just keep holding on thinking evetually an update or something would fix itself but no. I tried everything with settings and what not, I restart it works for 5-10 minutes and back out with full bars. I’ve been with tmobile for 15 years and I’m just done with it same time every day no internet not working anymore.  time to switch

Userlevel 7
Badge +13

is it happening to you while connected to 5G, 4G or both? have you tried switching to 4G only to see if things improve or not? could be how far you are away from whatever 5G connection youre getting..

Userlevel 5
Badge +7

I’ve seen many apps show the ‘no internet connection’ banner while apps are up, and service appears fine.  Similarly, ‘if’ (when) my phone ends up as base band 12/71 or 41 on LTE, the indicator will show LTE vs. 5G.  I’ve often ended up on B41 LTE (2CA 20MHz), which actually works quite well outdoors.

4g don’t work with full signal, 5g don’t work with full signal and often switches to 4g automatically and don’t work.  The coverage map shows I’m in well within 5g high capacity coverage. Also want to mention before we had 5g my 4g lte worked flawlessly.

Ugghh, same problem here. Four bars. 5G. Can’t stream music. This was the same problem I had about 5 months ago only at my job. Since that’s where I am 10 hours a day I needed a solution. My solution was to cancel just my line (my family stayed with T-Mobile, 5 ppl) and try Visible which used Verizon network. It worked great!  Better service then T-Mobile. So I decided to give T-Mobile another chance. Here I am 3 days into new service with T-Mobile and same issues. Gonna return this new phone and go back to Visible/Verizon.  I really wanted this to work as I’ve loved T-Mobile and their promos/perks. 

Same problem with Samsung Galaxy S20+ 5G. Switching to LTE does not always help. Use phone for business, and losing data service is costing me money! Have contacted T-Mobile support multiple times since December of 2021, and they do nothing. They seem to be reading from a book when they give you their response, and I don't think they really have anyone out there in the field who checks on whether the service actually works. Very close to changing carriers, as I cannot continue to lose money.

S21 Ultra same issue. Terribly frustrating, and it appears to only happen around my workplace so it appears to be location specific. Some days it works, most the time it does not. Unfortunately nothing to add to help, but this needs to be addressed.

Yeah I'm done. Took my 6 lines to Verizon. Oh well, I tried T-Mobile. You broke my heart lol.

Userlevel 4
Badge +4

It looks like most of the folks having this issue (phone and/or home internet) are describing when the cell towers are overloaded with more connections then it can manage. The symptoms are:

  • Strong signal but low or no data
  • Strong signal but dropped calls
  • Restarting your device gives you a brief moment when data works again only to lose it. This is caused by your restart putting your device back to top of the data queue momentarily.

I experience this a lot in both dense cities and remote areas. A good example is a vacation spot. Go during the week and no problems. Go during the weekends and your same phone from the same spot gets little to no data even though the signal strengths is the same as the week.

Unfortunately, the “fix” is for TMO to upgrade such towers and they are. However, they can only upgrade so many on a given day and nobody can tell you when your area will be upgraded. TMO want’s to add more capacity so they can bring in more customers. I’m sure the TMO exec is accurately aware that continued overloading will drive customers to other carriers.

I am having the same issue in SD.  All members of my family have an iPhone 12 and all of us show 4 bars on the 5G network but we constantly are loosing connections with Apple Music, Maps, Podcasts, texting, to name just a few.  I have been sent new SIM cards from T-Mobile that were suppose to fix the issue and it did nothing.  I have tried switching to LTE but we have the same issue with LTE.  I am not even getting 1.0 Mbps upload speeds.  I wanted to love T-Mobile because the monthly charges were so much lower but I am going to be forced to switch back to Verizon because our phones are not even usable with T-Mobile.  Unfortunately,  all phones are locked until we pay out our obligation, which makes no sense since two of the phones were suppose to be free.   If T-Mobile cannot fulfil their obligation to provide service why am I obligated to payout my contract?  Frustrate in SD where the map shows 5G Ultra in the urban area I live in, but extremely slow speeds.

It looks like most of the folks having this issue (phone and/or home internet) are describing when the cell towers are overloaded with more connections then it can manage. The symptoms are:

  • Strong signal but low or no data
  • Strong signal but dropped calls
  • Restarting your device gives you a brief moment when data works again only to lose it. This is caused by your restart putting your device back to top of the data queue momentarily.

I experience this a lot in both dense cities and remote areas. A good example is a vacation spot. Go during the week and no problems. Go during the weekends and your same phone from the same spot gets little to no data even though the signal strengths is the same as the week.

Unfortunately, the “fix” is for TMO to upgrade such towers and they are. However, they can only upgrade so many on a given day and nobody can tell you when your area will be upgraded. TMO want’s to add more capacity so they can bring in more customers. I’m sure the TMO exec is accurately aware that continued overloading will drive customers to other carriers.

First explanation I have received that makes some sense to me.  They grew too fast. 

 

Reply