Solved

How to buy a T-Mobile cellspot

  • 15 September 2014
  • 87 replies
  • 1161 views

Is the cellspot available, how would I be able to acquire one, can I just buy it online, or do I have to go to a T-Mobile store or make a phone call to T-mobile to inquire about one.

icon

Best answer by czarembo 16 September 2014, 23:52

I checked with a local T-Mobile store - they don't expect to have any in stock at their location at  least for a couple of weeks.  I suspect they'll be taking orders tomorrow.

View original

87 replies

they probably realize that $99 for a purchase is a steal, so they decide to only offer them to postpaid subscribers. 😀

it is also interesting to note that postpaid plans are taxed while prepaid are not.

Well I'm getting an S5 on Monday so that's not the issue... I don't see why we can't purchase the router outright, makes no sense.

well apparently you can't buy it for $99 if you're in pre-paid plan...

i've gone to several t-mo store and all of them said that i have to be in post-paid plan (simple choice plan)

some of them are also confused though, they thought they were able to give me one for $99 but seems like t-mo has changed the policy 😕

and also you need to have a wifi calling capable phone!

it's annoying when you have an iPhone 5 which is theoretically the exact same as 5c but it is not wifi calling capable.

I am still not able to purchase one, can someone post a link? The links in this thread (page 2) no longer work and I don't see the router anywhere.

I went to a store, they said I had to call telesales. I called telesales and after over 30 mins on hold, they could not find it. ..I am a pre-paid customer but I thought I could purchase outright for $99.

Please help!

Well, the funny thing is that the AC1900 does not allow DDNS to work behind a NAT but the DD-WRT router had no problem with it. My old 2-Wire U-Verse home gateway had some settings that might allow pass-thru mode but looking at the new Pace RG doesn't seem to have that feature. If there's any one thing that I don't like about U-Verse it's the lobotomized modems they employ.

Userlevel 6

Well, with UVerse, you can set it to run in Bridge mode so it's not

NAT-behind-NAT (actually, I think it's "DMZ"?) -- I had that setup in the

beginning. Then, when I brought a new router into the picture, nothing

worked right, so I went to the NAT-behind-NAT and manually opened up the

handful of ports I use (Subsonic is awesome, I tell ya). The problem with

doing it that way, though, is having to remember to open any new ports on

both the router AND the UVerse gateway (I can't tell you how many hairs I

almost pulled out the last time I had to add a port)

Yes. It's a VPN server (PPTP or OpenVPN). However, there's a Catcha-22. For the VPN server to work, the DDNS has to be working. For the DDNS to be working, it can't run through a NAT. You have to hook your modem up as just a modem passing the IP address through to the WAN side of the router. That may be OK unless you have a complex network or use Uverse, in which case the TM-AC1900 is a "router behind a router". If you put the TM-AC1900 into Access Point mode it removes all the menus about DDNS and VPN. I'm gonna havta study on this some. 

Userlevel 6

Wait - rewind - it has VPN in?

It seems to not want to allow me to activate the VPN server until I've activated the DDNS client.

Got mine ready to set it up😀

Userlevel 6

I've been using ChangeIP.com, so that doesn't help.

You can always go out and buy a Raspberry Pi and have it set to be the only thing that manages your DDNS stuff 😊   (Or, if you're using a DDNS service, find their software and install it on whatever box you're utilizing with the DDNS.  That's the method I do)

It showed up while I was out to lunch. Only snag so far is that the list of DDNS servers does not include afraid.com, which I've been using since Dyn shut down their free DDNS service. Anyone have any recommendations from among TZO, ZoneEdit, DNSoMatic, TunnelBroker and No-IP.com? Also does ASUS.com provide DDNS service? I setup an account on their site but couldn't find anything about DDNS. I also could not complete the registration of the router because ASUS says the s/n is not right.

Well i tracked the router and it's out for delivery😀

I don't think it needs activation

Same with me, last night got a confirmation that it was shipped, today a text from UPS that it's on a truck and will be delivered by 7 pm.. 😀 Does anybody know if we need to call T-Mobile to have them activate the device or set it up, or is it just plug 'n play?

Yep got a message from tmobile and another from ups saying it will be delivered today

UPS is now actually predicting delivery this afternoon.

Mine still says being processed 😥

just got a update from t-mobile website,

"Order status: Shipped"

"Shipped via UPS1D"

with a tracking number that is not active yet.  Yay?

1 day shipping?

I just checked my status on My T-Mobile and found that I'm backordered.

Same here just got it, the original tracking number still on my ups still

just says label generated

just received my router from UPS. 😊

now i found 2 processing orders on UPS on the 22nd and 23rd

Oh ok I had it a long time ago then it got canceled for not using it,  i just signed in again but it shows nothing,  may it needs to be updated,  or there's nothing? Last night i stopped by the store and talked to the guy who ordered it for me he checked the system and said it's not backordered as my account said,  he told me they will receive 3 pieces on Wednesday, if my account keeps saying backordered I can go to the store pick up one if I am in a hurry but I will have to pay the 25 $

I also have two tracking listed with UPS, but neither gives a deliver date. In each case, it says "preparing for shipment."

Reply