Question

iPhone apps not connecting to data


Badge

I have a month-old iPhone 12, and am not able to get apps on the phone to use cellular data. In the last week my phone has also stopped connected to public WiFi, even when I turn off my VPN. Since the phone picks up my home internet just fine, and all of the basic phone functions (camera, calls, calculator, Siri shortcuts) work well, I’m guessing it’s not a phone issue, but rather a network issue.

I have data enabled for all of the apps that I want it to be used for but I’m not able to use any of them once I leave my house. Google apps, Spotify, Twitch, games, banking apps, etc. all fail to connect to data, and recently have failed to connect to public wifi (like at work, where I prefer to use data). 

I’ve tried at home troubleshooting: turning data off an on for individual apps; changing my 5G settings (always on, auto, LTE) and doing a hard restart afterwards; checking for updates; offloading and reinstalling apps...Nothing.

I’ve contacted T-Mobile support three times now (about once a week), and have done basic troubleshooting, advanced troubleshooting, had the towers around my area checked for problems - and nothing has solved the issue. So far my area in the U.S. has good coverage and service, but I’m not able to pick it up.

Any guesses?


2 replies

Having same issue have to go to the McAfee for T-Mobie and turn off get apps to work via cellular data. This is a work-around and possibly started after a iOS update

Userlevel 2
Badge +2

iOS has a bug since version 14.5 that causes iPhone 12 and 13 to have issues with data connections. Also, it seems the modems in those devices aren't all they could be. 

Reply