Solved

MMS messages come in as number/TYPE=PLMN@tmomail.net

  • 6 September 2018
  • 52 replies
  • 886 views


Show first post

52 replies

Userlevel 6
Badge +14

Sorry for any confusion @dpward but I haven't seen this on my phone from other senders (T-Mobile or Non-T-Mobile) as well as when I use the MMS service you posted above.They're coming in without the additional characters. I didn't actually get the MMS from Twilio and I tested this a few times. Have you tested the phone in Safe mode to see if messages still show up like this?

@emholmen here is the link to the APN settings​. Please check that out and see if they match.

I checked - my APN setting seem to be OK - I have only "default, supl, mms". I'm still getting the long contact number/string on MMS messages.

I have sent the following support email to Google.  This discovery explains the intermittent nature of the problem.

Sent to: apps-help@google.com

Subject: Android Messages displays from: +1xxxxxxxxxx/TYPE=PLMN@tmomail.net

I have discovered that the Android Messages app version 3.5.053 has a problem displaying the “from” number.

Working:

  1. Clear all messages from a particular number.  Send test message from that number.
  2. Send an SMS message, the number / name displays as expected.
  3. Send an MMS message, the message arrives in the same thread with a proper name.

Problem:

  1. Clear all messages from a particular number.  Send test message from that number.
  2. Send an MMS message, the number displays +1xxxxxxxxxx/TYPE=PLMN@tmomail.net
  3. Send an SMS message, the message arrives in the same thread with the improper name.

I installed Textra SMS and made this the default messaging app.  Running the same test, Textra displays the name properly and Android Messages displays the name properly.

I am running Android Version 8.1.0, a custom ROM on a ZTE Axon 7.

I noticed the same thing happening around the beginning of September. I have a T-Mobile purchased Samsung Galaxy S8 running Android 8.0 and I'm using Android messages. It happens with pictures and group chats, regardless of whether the contact is in my phone, as you and others noted. I don't think this has been mentioned, but I received a photo from a new number with the @tmomail.net at the end. I saved the number in my phone under a new contact. The conversation did not update to the person's name. Only once I added an email address to the contact with number/type=plmn@tmomail.net, did the message update with their name. Annoying.

I just did a search for "@tmomail" in my messages app, and I have dozens of texts with the suffix that say "new message to download" but when I try to download them, it says the message is expired or unavailable. So who even knows how many photos/group chats I'm missing because of this 😥

@tmo_mike_c Every time I've generated a MMS message from Twilio, it has arrived within seconds on my phone (I've done this at least four times on different days). I hate to ask, but do you know for certain that MMS is working on your phone, and that you're getting MMS messages from numbers that are not stored in your contacts? In other words, is it possible that all of the messages you are receiving are either SMS messages, or the sender is in your contacts already? I'm happy to send you a test MMS from my T-Mobile phone if you PM me.

I tried this in Safe Mode as well and it does exactly the same thing.

I had some problem with mms too. Unknown user sent two mms with weird pictures for me. It was user from Cuba, because in his number was code +53. I checked it on https://areaphonecodes.com/cuba/ I wrote him to response but could not sent it.

Userlevel 6
Badge +14

I figured I'd get a message pretty quick but that didn't happen @dpward .  And I don't mind you asking at all. My MMS is working for both numbers I have stored in my phone as well as numbers I don't have. Just to be on the safe side, I tested on both Wi-Fi as well as the mobile network and I'm still getting images as well as group messages. Super strange I can't get messages from Twilio.

Very few issues stump me but this one's got my scratching my head. The only other thing I can think of is to test out the MMS using a T-Mobile branded device to see if the same issue continues. If by chance it does continue, I'm confident our engineers will be able to look into our network more after filing a Trouble Ticket.

I have a Note 9 from TMobile and this is happening to me as well. None of the fixes above worked. Using Android Messages. Message is coming from a known user already in my contacts with the same number listed before the /TYPE**. Funny how I'm in a group chat with a friend of mine, he's on the same phone plan as his wife, but the wife's number comes up like this and his is normal.

I've been following this thread for a while hoping for a solution. I have a TMobile branded Galaxy S7 edge and I'm still having the same issue. Happened a bunch of times today on a business trip.  It doesn't matter if the number is in my contacts or not. It's always group messages though and it doesn't matter if the message is text only or contains an image.

Just wanted to add my two cents here. I have been having this issue for a while on my old phone (Galaxy S8+). Just upgraded to the Note 9 and the problem persists. Anytime that I get a new group message, the sender's number has the /Type= added to the end. All other numbers are displayed properly. Does not matter if they are in my contacts or not. SMS is sending fine. It is only happening with MMS messages. Any suggestions for fixing this? Its becoming quite a hassle.

Where are we with this issue?  Been over a month since the original post and based on the replies (Tmo devices, non-Tmo devices, contact stored vs. not stored, etc.) there is an issue here with MMS.  Has this been escalated on your side?  What more is needed from me / group to provide so this can gain some traction with your team(s)?

I also have this issue on Pixel XL2 and Android messages.

Some observations:

- this will not occur if the initiator of the group MMS is on tmobile

- This is not occuring on a Nexus 6P running 8.1 with the same SIM.  I wonder if this is a bug in the MMS handling in Android Pie.

I disagree with your first point as I have been able to replicate this issue with an initiator who has T-Mobile.  Your second point is plausible, however without T-Mobile support able to confirm, further information is required.

This happens no matter where the message originates from for me.  My wife and parents are on Tmobile and it happens when they respond to a group text as well as my friends on AT&T & Verizon.

Also, I'm not running Android Pie.  I am running Oreo on a tmobile branded Galaxy S7 Edge.

People are still complaining and do not appear to have verified my observation on Sep 27, 2018 4:29 PM.

Can anyone else verify my observation that this is a Google Messaging app problem?

I've been using the Google messages app. I just switched to Samsung

messages and the problem happens there too. On the conversations with "type=

plmn@tmomail.net", there isn't even a text box for me to type a reply in to

send. Also, even though I saved the contact's info in my phone under both

their 10-digit number AND their 10-digit number/type=plmn@tmomail.net, the

contact's name doesn't show up on the conversation. Just the "type=

plmn@tmomail.net".

Is anyone from T-Mobile reading any of this thread??

On Thu, Oct 11, 2018 at 2:58 PM magenta3364992 <no-reply@t-mobile.com>

Userlevel 5

Hello, All!

I'm sure it's frustrating to continue receiving MMS' that don't properly display the contact name/number especially after you've tried everything under the sun to get it fixed. Some helpful suggestions that have been made is to use the stock messaging app instead of Google messages. This may work from some users but not for all. At this point, we do not have any other workarounds for you try. The next step would be to Community-2153 via 611 or work with T-Force over Facebook/Twitter to get a ticket filed with our Engineers for this. They'll need a few examples that include the date, time, time zone, and the "from" sender's info along with the type of device you're using.

My pixel 3 arrives tomorrow. We'll see if this is miraculously fixed on

Android Pie. Otherwise, I might have to begrudgingly head back to Verizon.

Amanda,

I need to kindly mention that this thread was opened because someone already contacted support and were not able to get a resolution. In fact, this is what several people encountered in the Reddit thread I mentioned.

Please be more specific about how people who are experiencing this issue should contact support. What can you do on your end? Can you review existing support case numbers where this has not been resolved and get those escalated?

Also, regarding the messaging app used: Google's Messages app is the stock messaging app on many (if not all) of these phones.

Thank you in advance for your effort to move this forward on T-Mobile's end.

My pixel 3xl did not solve the problem.  Yours?  Using messages.

Newest update of messages seems to have solved the problem.  Cautiously optimistic.

This is working on my Nokia 6.1 with the Android Messages app version 3.7.052.

@tmo_mike_c Could you please do a favor and fix this thread to mark @tomthebom  's reply as the correct answer? It should be the one that appears at the top of this page for people who come across this thread — not the message from @tmo_amanda .

Agreed, newest Messages update does appear to resolve the issue.  (v3.7.052) specifically on my Pixel 2 XL.  This answer should be at the top and thread can be closed.

Oddly, issue has resolved itself on my Pixel 3 - other than from 1

contact. Deleted message, deleted contact, it still keeps coming in with

the PLMN.

Reply