Solved

MMS messages come in as number/TYPE=PLMN@tmomail.net

  • 6 September 2018
  • 52 replies
  • 886 views

I have been having an ongoing issue with messages (mms) being sent to my Pixel XL 2 device.  MMS Messages received from people, both one person or in a group chat have phone numbers in the format of number/TYPE=PLMN@tmomail.net.  I have narrowed this to the original sender of the message in a group chat by several tests.  This problem happens regardless of the contact being stored in my phone or not.  I have hard reset my phone, contacted Tmo support by phone, etc. and no resolution.  Any assistance would be greatly appreciated.

icon

Best answer by tomthebom 27 October 2018, 05:17

Newest update of messages seems to have solved the problem.  Cautiously optimistic.

View original

52 replies

Same problem here. Started couple weeks ago. Anyone have a solution?

Userlevel 6
Badge +14

Does this only happen with MMS or with SMS too? Are you using the pre-installed messaging app or a downloaded/3rd party messaging app? I'm also curious if this happened after an update with the phone's software or with an app.

This is also happening on my Nokia 6.1 (an Android One phone, running Android 8.1). It happens with the built-in Android Messages app.

There are lots of message threads online about this recently such as this one. It seems to be affecting phones running recent Android versions. A lot of people are asking whether this is caused by T-Mobile's recent rollout of RCS?

Only with MMS or a group message utilizing MMS. I am using the stock Android Messages application.  First started to happen with the release of Android 9 Pie from what I can recall.  I have not tested with other 3rd party applications.

Userlevel 6
Badge +14

I don't see we've been getting internal reports of this being an issue. Do you happen to have T-Mobile branded devices you can test the MMS on to see if this is still happening?

I have reported this several times to CS via phone. As the other user stated there are several theads on this issue if you search Google. I do not have another device to test with at this time.

Mike,

My phone (Nokia 6.1) and @snwahs 's phone (Google Pixel XL 2) both use a stock version of Android OS from Google. The phone manufacturer does not customize the OS to include any additional apps or services.

We are using the native Android Messages app for sending/receiving SMS and MMS messages.

I believe the other pertinent question here should be whether the phone is configured to use T-Mobile's Access Point Name (APN) settings. I've checked that my phone in particular is configured to match these settings.

Otherwise, whether the phone is T-Mobile branded or not should not be relevant. The common denominator here is that the T-Mobile network behavior changed at about the same time for users of many different devices which are running the most recent versions of the Android OS. Could I kindly ask you to view the thread that I linked to in my earlier message (which in turn links to two additional threads)? You can see specific examples of devices that people are reporting to be affected, and under what conditions (both with and without Wi-Fi calling enabled, etc.)

I appreciate your help with this.

Userlevel 6
Badge +14

Hmm, okay. @snwahs after you contacted CS, did they have you do some troubleshooting? What was the end result?

@dpward I did check out the reddit thread you posted. I do appreciate you making sure you have the correct settings.  It's still a bit unclear if the folks there are using T-Mobile branded phones or not. As for RCS, that's the standard in which T-Mobile's Advanced Messaging feature was built on. Also, I may have missed this, but I didn't see anyone mention if this was happening only while connected to T-Mobile's network or also while on Wi-Fi with Wi-Fi calling enabled. I'm also curious if these messages are showing up from folks that are not using devices that support Advanced Messaging.

I have this same issue as well.  I have a Galaxy S7 Edge purchased from T-mobile and I'm using Android Messages.  This happens on group MMS messages. 

Tmobile LG V30 here with same problem.  It is not an unlocked device issue.  I assumed this would be fixed quickly. Will have to leave Tmobile if it's not.  Really annoying.

@tmo_mike_c This is happening with Wi-Fi calling. This past week I have been in an area with almost no T-Mobile cellular coverage — I have found some spots at least half a mile away with T-Mobile cellular service, but there is none at all where I am staying. However I have very good Wi-Fi service indoors and have had no trouble remaining connected to Wi-Fi calling. To reiterate, it only affects MMS messages and not SMS messages.

Userlevel 6
Badge +14

Thanks for that info. Are these messages coming from T-Mobile numbers only or have you seen this come from other carriers? Also, do you see a difference as to where the contacts are stored? For example, if they're tied to a Gmail account vs. stored to the phones memory?

Mike,

I am seeing this issue from Tmo numbers as well as numbers from different carriers.  Also seeing it on numbers tied to a Gmail account as well as stored in memory.  The constant is that it affects MMS and Group MMS messages received to my / our devices.  As of today the issue is still persisting.

Mike-

I have seen it happen from both T-Mobile and VZW numbers. All my contacts

are stored on gmail (phone). Has happend on both SMS and group MMS

messages.

Griffin

Userlevel 6
Badge +14

Thanks for that info. I'm wondering if it's possible that it could be stemming from the contacts synced from the email. Are you able to temporarily unsync or remove the contacts synced from your email and only use the contacts from the device's internal memory to see if the messages still show up that way?

I removed the contact from gmail. The text still showed the number with

the stuff at the end. I added it back as a phone contact and that didn't

change anything.

I also have one text with this "Type=" stuff at the end that is from a

number that is not stored in gmail contacts or phone contacts.

Griffin

I'd like to add my account to the reports here - I have a Google-purchased Pixel 2, updated to Android 9 'Pie' with the latest security update (September, 2018). I am using the default sms/mms application (Android Messenger) with the correct APN settings.

I don't know what the issue is, but I'm convinced that this is a server-side issue rather than a device issue. I'm happy to offer any details if it would be helpful.

@tmo_mike_c​ If I receive an MMS message from someone completely new (who is not in my Google contact list or the SIM card contact list), then this issue will happen. The issue isn't that the number is somehow stored incorrectly in a contact list.

It's actually really easy to demonstrate on affected phones. Simply go to www.twilio.com/mms and scroll all the way down to "Demo". Enter your ten-digit mobile number and click the "Send MMS" button. Here's what I see in the Android Messages app:

Before this issue started happening recently, it would have shown (415)xxxxxxx as the sender. Now, the sender appears as +141xxxxxxxx/TYPE=PLMN@tmomail.net. Aside from receiving regular app updates from Google, the only thing that has changed is the T-Mobile network behavior. (I also just did a factory reset on my phone and confirmed it still has the problem.)

Userlevel 6
Badge +14

Thanks for that info @magenta6177582 .

I'm using the same phone you have and I've never seen this before. What software version are you running? Did you get this phone directly from T-Mobile?

Android 8.0.0

Software Version H93220k

No, it's a T-mobile phone but I bought it on secondary market

Userlevel 6
Badge +14

Okay. Thanks for that info. Have you also tested this on 2G instead of 4G or Wi-Fi? I'd like to know if this is happening while only on a faster network or if the GSM network is being effected as well.

Hey Mike,  I had an apn type of default,supl,mms,IA  - I have never seen IA before on an apn type.  i removed it and it fixed the issue,  maybe have everyone check to see their apn type and if it has the IA then remove.

Userlevel 6
Badge +14

@kredno99 I really appreciate you posting that. Out of curiosity, what kind of phone and software version you're running?

Can everyone else try the step above to see if that helps? Please let me know. Thanks.

@tmo_mike_c I wasn't entirely clear from your reply if you meant you just haven't seen this on your phone before, or if you have actually confirmed that this issue does not affect your phone:

Did you try generating an MMS to your T-Mobile LG V30, using Twilio (as I described in my earlier message) — and did the MMS show up in Android Messages app from a simple 10-digit US phone number? Could you please try this if you have not already? That would be very helpful.

I temporarily configured my phone to use 2G connectivity only (in the Android settings), with VoLTE / Wi-Fi calling disabled. (The internet browsing speed became significantly slower, as expected.) However, receiving another test MMS from Twilio showed that this problem affects 2G connectivity on my device as well.

The APN type is already configured exactly as "default,mms,supl" on my phone (as described in T-Mobile's support page) but I still see this issue.

I'm not sure how to do what kredno99 suggested. Where would I do that?

Reply