OnePlus 8-5G Wifi Calling has no sound

  • 12 October 2020
  • 31 replies


My new OnePlus 8-5G phone (TMobile in US) cannot consistently send/receive wifi calls. Once answered, there is no sound on the OnePlus 8-5G phone while the other end can hear OK. I’ve tried updating the phone’s software (it is up to date) and I have updated the firmware on my router (which works with wifi calling with other phones: iPhone 11, iphone8, Droid Turbo 2, Motorlla Razr MAXX). I also tried disabling any battery saving features on the device and even did a factory rest of it (with no apps installed). I have also tried rebooting the phone once I have connected to the wifi router. Phone has same issues on any wifi router I have connected to. browsing is fine, only wifi calling is a problem.

31 replies

Userlevel 5
Badge +8

Going back through these posts… I had an LG G7 (Android 9?), LG Velvet (Android 10), Samsung A32 (Android 10), LG One Plus 8 (Android 10 → 11), and Samsung S21 (note: A32 was ‘freebie’ for spare line), Velvet and OnePlus 8 were exchanged due to various issues through T-Mobile. 

I haven’t had issues with WiFi calling on these, although I can’t say that I’ve used it much on Velvet/OP8 or Samsung.  I used it quite a bit on G7.  I’ll have a good chance to use it soon, as T-Mobile’s coverage is not quite usable in Cambria, CA, and may have to resort to it if I don’t want to have to walk a mile to make a call.

This has to be a T-Mobile issue.  I have a Motorola Razr 2020 and this just began happening to me a few days ago.  When I place or receive a call, I cannot hear the other party but they can hear me.  I can disconnect from WiFI while in the call and I can immediately hear the other party.


Very frustrating

Same, wifi calling not working on Oneplus8t+. Anyone with any update on resolving wifi-calling issue?

I just started having the same problem about 3 days ago. Has there been any progress on this issue?

This is just ridiculous at this point. I work below ground and need wifi calling as my place of work has no TMobile coverage downstairs. One plus 8 5G, EVERYBODY is muted on ALL wifi calls until I turn off wifi calling.


This is my first and last phone with t mobile.

My family has been experiencing this as well, across OnePlus and Samsung devices. I just found this link on a Reddit thread and many users have reported it correcting this issue for them. It involves opening firewall ports up at your router. The article is filed under “WiFi calling on a corporate network” so how would we find it, right? Wi-Fi Calling on a corporate network | T-Mobile Support

Summary of the article:


IPv4 Address Block:
Port: 500 / UDP    / IPsec - IKE : Authentication [WFC 2.0]
Port: 4500 / UDP / IPsec - NAT traversal : Encrypted voice traffic [WFC  2.0]
Port: 5061 / TCP + UDP / SIP/TLS : Encrypted SIP [WFC 1.0]

IPv4 Address Block:
Port: 443 / TCP    / HTTPS : Used for handset authentication [WFC 1.0]
Port: 993 / TCP    / IMAP/SSL : Visual Voicemail [WFC 1.0]

Also whitelist the CRL server for DIGITS OTT and WFC 1.0: