Outgoing Spectrum mail on t'mobile

I don't know if this is T-Mobile's problem or Spectrum, but I cannot get outgoing mail to work on my Android when connected to T-Mobile cellular data.  Works OK if my Android is on WiFi.


Security protocol: TLS

Port: 587

Mail client says server did not respond when using above.

Server rejects connection to port 25 with "service unavailable"

I had used, same problem.

Inbound mail with imap not a problem


Best answer by tmo_lauren 12 April 2019, 23:27

View original

16 replies

Userlevel 4 <-- Spectrum's help on this subject.

As can be inferred by what I said I tried, I've been there. They even have a mistake: you must use TLS, not SSL for SMTP.

If you have a URL to actual human support rather than guides, I'd appreciate that.

What really would be useful is a support email address for Spectrum and T-Mobile and let them battle it out among themselves, since either side could be the culprit.

Sent from my HTC

Userlevel 4

The short of what I said is that it's a Spectrum-side issue, or your configuration.

T-Mobile doesn't stop folks from using email from other services.  Spectrum doesn't require as much security when you're on their network (e.g. you're on wifi), but requires full security when you're coming from somewhere else (to prevent spam from originating in their systems).  The only thing T-Mobile can do is point you to Spectrum.

I'll try another network (most Wi-Fi connections I've used get internet through Spectrum) but so far the issue only seems to occur on T-Mobile. Carriers and internet providers have been known to restrict SMTP.

Sent from my HTC

Userlevel 6
Badge +15

Were you able to test another Wi-Fi connection to see if that still happens? I can't think of anything that would block it on our end. I'm also curious if you're able to use other web services while connected to T-Mobile's network. Like going to websites or using web-based applications.

I haven't yet found a Wi-Fi that didn't have Spectrum behind it.

T-Mobile data otherwise seems fine, though most of the time I'm on a Wi-Fi.

The default APN was using IPv6 exclusively, thought that might have been a factor. Created a new one based on the default, switching to IPv4 only. Same issue.

Inbound secure IMAP works fine, just not secure SMTP.

Sent from my HTC

Userlevel 6
Badge +15

Okay, thanks for testing out the settings. Are you able to use the mail service through the browser on your phone to see if that works? I'm thinking it could be a setting issue, so I'm curious if that works.

When I can, I'll try it over T-Mobile data, but since I only have problems with secure SMTP, secure IMAP not being an issue, and I don't have issues accessing web pages, I doubt web mail would fail. Web mail should not have anything to do with secure SMTP. I don't think they are even the same servers.

Again, this is ONLY with TLS SMTP (port 587) to Spectrum server, and so far, only from T-Mobile network.

Sent from my HTC

Just tested. No issues logging into

Spectrum specifies mail client configuration for SMTP to be (also been told port 587.

Their only mistake is stating to use SSL for IMAP and SMTP, but really they use TLS for SMTP.

Sent from my HTC

Userlevel 4

All the Spectrum docs say to use SSL, not TLS.

Your security protocol may be the problem?

Another site suggests your username is your full email address.

Based on your posts, you haven't tried on anything besides T-Mobile and Spectrum.  If you have a friend that can let you tether their phone on a non-T-Mobile provider for a minute, you'll probably confirm it's anywhere but Spectrum.  I'm wagering it's something set up with your email settings.

Have you tried Spectrum's support boards?

It used to work, then recently in the past month or so stopped sending. I didn't notice because most of the time I'm on Wi-Fi, which around here is mostly Spectrum.

Issue isn't login because IMAP works, and as I said above, outgoing used to work.

Spectrum gives you the runaround in even finding live support. What I was hoping for is email support from Spectrum and T-Mobile so both of you could battle it out.

Sent from my HTC

By the way, when I first wrote this a couple hours ago, it failed to send because I had no Wi-Fi and had to use T-Mobile data.

Now that I'm home, I could send it over my Wi-Fi.

Sent from my HTC

Userlevel 3

Going through the troubleshooting steps, it unfortunately takes us back to having you reach out to Spectrum. 😥

While I definitely understand in theory the idea of us going to them and having a battle royale sounds good, buuut, we ultimately don't pay them any money and therefore those sort of things fizzle out. When I was rep back in the day we used to see this a lot with certain landline carriers and Caller ID, we would try and call on behalf of the customer and they would more or less just remind us we don't pay them and the customer needs to handle it. 😥


Understood. What I was hoping for was a three-way email conversation between myself and support for both parties.

Alas, Spectrum hides their help.

Sent from my HTC

Did this get resolved?  I have the exact same problem but with Cox. 

For our office we have 3 different phones different email address' but we cannot sent out using secure SMTP server via Tmobile data.  We can send emails on all wifi connections so we know the settings are correct.  I've been calling Tmo for 6 months without resolution. 

Userlevel 4

magenta3066961 wrote:

We can send emails on all wifi connections so we know the settings are correct.

Are the WiFi connections you're testing on provided by a service other than Cox?  If you're on Cox, it doesn't mean your settings are correct.  ISPs bypass authentication when SMTP is used from their own network.