Solved

Slow speeds with Global Plus ONE

  • 19 November 2018
  • 37 replies
  • 326 views

Userlevel 3

Creating a new thread to see if we can get this answered.

Several users are experiencing slow speeds when on the Global Plus ONE plan - with this plan, there should be no throttling of international speeds.

@opkellyks​ and @brandonjhb

icon

Best answer by internationalsam 23 November 2018, 14:16

Are you still abroad? Nothing needs to be sent to the phone; the reps that are not aware of this specific system issue will try to send various reset signals etc but those will not do anything. The problem is/was deeply rooted in how the new plan itself was provisioned; whatever system that is responsible for throttling international traffic erroneously grouped this plan in as well.

I am not sure how they disseminate known issues amongst the folks in T-Force but if your rep does not immediately acknowledge it as a known, system issue and attempts various (fruitless) troubleshooting measures, you may have luck referencing ticket 21612073.

View original

37 replies

Thank you Jarvis for creating the new thread.

For TMO - it has also been frustrating in dealing with your “Experts” as I needed to educate all of them on what the Global Plus One package is. I was told by numerous “experts” that I should expect 2G speeds under my plan.

Userlevel 3

Some specific details:

  • Before migrating to Global Plus ONE, speeds were not throttled.  After applying the add-on, speeds ~100kbps.
  • International Day pass works fine for same Phone Location
  • Seen on iPhone XS in Hong Kong (210+ country, so should be no throttling)

This issue has been wildly frustrating. Glad this was recently indexed by Google and I hope other users who have Global Plus notice it too, since T-Mobile doesn’t seem to know what’s going on.

It appears anyone who who has added either the grandfathered Global Plus or the new Global Plus 15GB will be subjected to 128kbps throttled data at all times on the device. Adding a day pay does seem to alleviate the issue temporarily. Why it’s even possible to add a day pass feature on a Global Plus line is unclear.

Even stranger, hot spot data is not throttled. To any other customers experiencing this, T-Mobile will tell you they don’t see any throttling on your account, that there must be congestion or that it’s ultimately  to the carrier you’re roaming on. This is incorrect. It’s quite easy to tell when you’re being throttled to 128kbps with full LTE and it’s disappointing this misinformation is going around. Even a lot of folks in T-Force seem to not be aware of it. If they tell you this, explain that adding a day pass instantly fixes the problem so it’s not congestion.

Hopefully this gets sorted out soon. 

I am having this same issue with the consumer global plus one plan. I am in Rome currently and also brought my Project Fi phone as a back up. While I am not an expert, I believe they use the same roaming agreements. Below is a screenshot of the side by side speed tests. I contacted support yesterday and have not heard back, but am hoping the below will help out.

Userlevel 3

Thanks @internationalsam​ - good info.

@daskbrolock​ - thanks for the comparison.

I am not able to add a day pass on my account and have Global Plus

Keep adding to the thread, we need TMO team to get this sorted out!

Userlevel 3

My understanding is that international roaming does vpn back to the US, which may slow things down.  But if a day pass eliminates the problem and @internationalsam said, then surely it is network throttling.

Yes, exactly. At a technical level, TM tunnels all the international traffic through their own VPN back in the states. This is how the throttling is facilitated, the international carriers are not tasked with the speed of each individual TM customers.

If you cannot add a day pass online, use your Twitter account (or open a new one for this purpose) and DM T-Force, they are the only ones who even slightly know what’s going on. Specifically ask for Joel B or DJ Constable and say you would like a day pass for this reason. Note that every time you exhaust 512mb or 24 hours (whichever is first), youll have to request the old be manually removed and a new one added. They’ll waive these charges for you,  but it’s the only way right now.

This is not an an issue with the roaming partners, and has nothing to do with congestion. It’s just related to TM and something being configured improperly.

Having the same trouble as well. I am in Italy and had added the Consumer Global plus one data add on and it was working perfectly for about a week. On November 16, 2018 is when I started getting 3G speeds which seemed like it was happening to everyone as well on the same day. The odd thing is that when I turn on my hotspot, my laptop is getting 90+mbps but my cellphone is only getting 3G speeds. This is also happening to my co workers who have T-mobile and the global data add on. I submitted a ticket the next day and received a reply today. This is what the tech rep has said:

"I have verified that the customer is properly provisioned for roaming data services and do not show them to have reached any data caps. In the usage logs I show roaming data uage that occurs after the ticket was filed. Please verify resolution with the customer. If the issues persist for specific roaming areaas advise the customer that we cannot guarantee service for a specific address in a roaming partners network. If the issues only occur with specific data services (such as internet access or email) but other data services are functional the issue is going to be with the device. Thank you."

My only problem with the reply is that the hotspot works but not my cell service data and that it is happening to 4 other people out here with me.

Userlevel 3

Here is the official plan info for Global Plus 15GB

I came up with a bit of a temporary workaround. if you use the "pcweb.tmobile.com" APN you'll get full speeds. however that chows into your hotspot limit

Thanks - where can I change this?  i googled for an iPhone and it should be under “cellular data options” but don’t see it there.

i also have the Global One plan and have been receiving throttled speeds in Singapore, Malaysia, and Thailand. 

Userlevel 3

Thanks @brandonjhb​ - this means the normal APN (fast.t-mobile.com) must be the source of the throttling.

@chitown12​ - check out this article on how to set the APN - BYOD T-Mobile data & APN settings

I wonder if the IPV4 roaming protocol has something to do with it...

It looks like the throttle is off in Rome.[Image]

I just did a speed test and I am at least getting 3-4mb/s right now.  It’s an improvement from the 0.1mb/s I’ve been getting for the last few week. I’m currently in Thailand. 

Perhaps others who who have had issues should also try a speed test again. 

To be clear, this is not something that T-Mobile permits iOS users to modify. Apple allows carriers to choose whether or not this setting even appears, and T-Mobile chooses to hide it and block the customer from editing it. Android is a different story, but out of the the box iOS users with a US T-Mobile SIM cannot change this setting.

View and edit your Access Point Name (APN) on your iPhone and iPad - Apple Support

https://support.t-mobile.com/docs/DOC-2383

I meant to include an image in the message. Overall it looks like my line is not being throttled this morning.

Same plan (Global Plus Unlimited)

Two different countries

Two different txts

I can confirm.  Recently returned from a week long trip in Japan, and the speeds were abysmal. My account wont let me add a day pass.  Something is definite messed up here.  Tried to do a speed test, it routed me through Dallas from Tokyo as the closest server.  I was getting 0.01mbs! How can I fix this issue?

Regarding routing through Dallas, this isn't necessarily abnormal. As I had mentioned above, at technical level, TM tunnels all the international traffic through their own VPN back in the states. This is how the throttling is facilitated, the international carriers are not tasked with the speed of each individual TM customers.

In any case, I believe the actual issue of improperly throttling on-device data through the on-device APN has been fixed as of today. I have a followup scheduled with T-Force later today and will report back.

Anyone who purchased a day pass after day pass to alleviate the improper throttling should request these be waived off their bill (mine will).

Thanks for the info, I am talking to T-Force over Twitter now.  Will this problem fix itself, or does T-Mobile have to send something to our phones to get the daya throttling issues resolved?   Thanks!

Are you still abroad? Nothing needs to be sent to the phone; the reps that are not aware of this specific system issue will try to send various reset signals etc but those will not do anything. The problem is/was deeply rooted in how the new plan itself was provisioned; whatever system that is responsible for throttling international traffic erroneously grouped this plan in as well.

I am not sure how they disseminate known issues amongst the folks in T-Force but if your rep does not immediately acknowledge it as a known, system issue and attempts various (fruitless) troubleshooting measures, you may have luck referencing ticket 21612073.

Userlevel 3

I had a hunch that this was something provisioning related.  Introducing a new plan that wasn't fully baked yet - should have been executed better.  Anyway, glad that things seem to be resolved now.  I'll hold off on marking this question answered until we get a little more feedback.  Post back if you are still having issues.

Userlevel 3

@magenta6875365​ - looks like things are now working.  Post back if you have any more issues...

I’m heading to Korea in two days, will let you know if everything has been resolved.  The reps I have spoken with claim there is no ongoing issue, and that service is dependent on the local carrier. They don’t even seem to know what this plan is!

As of today, this has finally been resolved for me (in Thailand). Kind of disappointing that it took this degree of effort and campaigning, begging them to look into it further instead of just blaming it on a partner network. Countless hours put into this issue.

Reply