T-Mobile Digits app keeps giving me "Service Unavailable" error page whenever I try to log in on Surface Pro laptop.

  • 1 September 2019
  • 26 replies
  • 222 views

I've been getting an error page for the past week whenever I try to use the Digits app on my computer. It doesn't happen when I use the internet webdigits, only when I use the app that's installed on my device.


26 replies

I'm experiencing the exact same error.  Just noticed today!  Thanks for reporting this.  I'm on an Asus Windows 10 Laptop with latest Operating System updates installed.

The help text conversation I just had with support regarding this issue follows.  No real time-frame given for "enhancements" to be complete, just "ASAP," it's a known problem, and phones aren't affected.  I only use the Windows DIGITS app every couple of weeks or so - we'll see if it's fixed the next time I need it!  The support text string follows:

Hi, Robert! Thank you for letting us know about the Digits app. May i know the error that you were getting regards on the app?

Me at 12:03, Sep 2:

Yes. After entering email address & password in the T-Mobile DIGITS App on Windows PC the following error message is received "Service Unavailable. Uh-oh, it looks like we have our wires crossed. Please try again later."

It never gets to the security questions.

Usually its password --> security questions --> choose digits --> app starts. So this is happening between the first two log on steps.

Me at 12:05, Sep 2:

T-Mobile DIGITS Version: 1.5.0/1.5.15

Me at 12:06, Sep 2:

Windows 10 Version 1903

Joyeliza at 12:07, Sep 2:

Thank you for confirming, Robert. I understand the confusion and I will be happy to clarify this, currently we are having a system upgrade on going that is why some of the customers are having an error when it comes to Digits app. But nothing to worry since the engineering team is already working on this, i will assure you that this will be done ASAP. We will going to notify you once the upgrade is done. Thank you for your understanding and for your patience on this, I really appreciae it.

Me at 12:08, Sep 2:

Okay, it's a known problem. Thank you for the information.

Joyeliza at 12:09, Sep 2:

YEs, Robert thank you as well for being so kind on this. I will assure you that this will be done. They are updating it.

Me at 12:10, Sep 2:

So no effect on phones, just PC?

Joyeliza at 12:11, Sep 2:

Yes, Robert you got it right! That is just for the browser, they are upgrading/Enhancing it. 😊

I understand from the conversation that Digits is not working because it is being enhanced.  Is there a timeframe for completion?  I use Digits regularly as part of my workflow and it is a serious inconvenience not having it available.  It's one of the reasons I chose T-Mobile.  It has been unavailable for several days and I'd like some sort of expectation of when it will be back up and running.

Yup I just got a Digits account and getting the same on the app with multiple computers. Web version seems kinda broken as well, but I'll wait until the app clears up before troubleshooting that further. Shame they didn't give any notification that their app has been completely broken for several days.

I have the same problem. Being a Windows Specialist, my sense is that Microsoft's latest Virus database-update is preventing the T-Digits App on Windows from accessing the Internet. The T-Digits App must now confirm to Microsoft's requirements and be posted on Microsoft's Store, as a Trusted App.

In chatting with T-Mobile support I learned that there is a web version that can be used instead of the app.  Its link is https://wrc.t-mobile.com/wrcpro/home.html   That's been working just fine for me.  I tried uninstalling the app and downloading and installing the latest version, but the app still didn't work.

Although it's possible there may be a separate Windows-related cause of this issue, it's not just a Windows problem.  I'm having the problem on an iMac using chrome.

Also seeing this on both a mac and windows for about a week now.

This link https://wrc.t-mobile.com/wrcpro/home.html   shows as insecure 😥

An error occurred during a connection to webrtc.t-mobile.com. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

What I learned about this from googling:

"If this is happening with one particular website only, its a server side issue. Only, the server admin can resolve the issue. This mostly happens when a website is still using RC4-Only Cipher Suite, and the settings in the server ‘security.tls.unrestricted_rc4_fallback’ preference is toggled to false.

We have noticed this error reported at times, for various websites including Cloudfare, Sonicwall, Tomcat, IMGUR, Amazon and so on."

I'm having the same problem on my mac with both the digits app and web interface. This should be fixed by T-Mobile ASAP since it is a critical error with no work around

Now it doesn't even give the Service unavailable error. It's just spins:

I appreciated that T-Mobile is working on this issue, but given it's been over 1 week "we are working on it" is not a sufficient response. I shouldn't have to keep calling customer support every few days to get an update. T-Mobile needs to be proactive and tell their digits customer what to expect in terms of status updates and resolution.  Also, the web app doesn't work on Firefox due to misconfigured encryption.

Please provide more details on the nature of the problem. What is being done to correct it, and when we can expect a resolution.

Shows as secure for me once logged in:

Thanks for this link!  It's quite useful and will get me by for now while awaiting app repairs.  One other cool thing is that it works on my Samsung Galaxy Note Pro 12.2" device!  This device was no longer compatible with the DIGITS! Android app because it's OS was too old.  Now I can log in to digits using Chrome on this Android 5.0.1 device and it will work if I select the Desktop site!  I'm very pleased with this unexpected result, so thanks again!!

I have the same here. It doesn't even login now. Just a spinning magenta circle. Come on T-Mobile, what is going on, and when will it be fixed?

Another week goes by with no response from T-Mobile and no resolution to the issue.

For a company that seems to pride itself on great customer service, you are really dropping the ball on this one.

Userlevel 5

Hey folks! I just took a look at the known issues list and was not seeing anything that matched this issue specifically. For this, we will want to collect examples from each of you and get support requests opened up so that we can properly investigate this. Please give us a call when you have a moment so we can get this started.

Hey Chris, have you tried the windows app? I think we're all trying to convey that it doesn't work for anyone. so you should just try it.

I already reported that the Windows desktop app is not working (and has not been working for approx. 2 weeks). I was told it was a known problem and was being worked on. Do you need us to call in and report it again?

Userlevel 5

I just installed the Windows desktop DIGITS app (version 1.5.9b/1.5.15) on my Windows 10 Pro (version 1903) and was able to successfully log in as well as receive a call. It was weird, as soon as I got it installed a call came through... turns out it was just a robo call about "My current credit card account" lol.

I just tried logging into the app after @tmo_chris's latest post, and the app is working for me now as well. I hope it stays this way. Good luck everybody!

I was just able to logon to the Windows Desktop App. Glad they got it working.

Glad to hear the new version is working for some! Is anyone else having an issue where the app won't update to the version @tmo_chris cites?

At least for me, it wasn't the app version that made a difference. Tmob seems to have fixed the situation on their end.

Same here. I didn't have to download a new version. It's just working.

So, good news!  I've confirmed as the others who have already commented that the DIGITS! App for Windows is working again.  The app version does not matter.  I would still like to know what's different about @tmo_chris​​'s version!  Any new features (hint: customized ringtones by conversation, short code support)?

I have tried the app again and now it is working.  (version 1.5.9-b)  Thanks!

Reply