T-mobile internet/cell service will not allow google play store apps to download or update


Userlevel 2
Badge

A good amount of people have been running into the issue of not being able to download google play store apps or updates using the T-mobile services. I have their internet service and cell service and every time I attempt to install an update using google play it will just stick on pending and will not initiate the download. Tested the downloads on a different internet provider and it works just fine. Clearing the cache nor resetting the phone to factory can fix this issue. 

I will link a few reference sites where others are talking about this exact issue:

https://www.reddit.com/r/googleplay/comments/t74j3f/google_play_was_working_perfectly_fine_yesterday/

Link 2
https://downdetector.com/status/google-play/

 

If anyone can help or can forward this to the proper channels would be great.


92 replies

Userlevel 1

I am having the exact same problem. When I contacted CS they said this was NOT a known issue on their end... I do not believe that for a second. This cannot possibly be something affecting a handful of individuals only. In my household alone, we have 2 phone lines and 1 tablet line, all on T Mobile's network. 3 different devices: OnePlus phone, Motorola phone, and Samsung tablet. We are unable to download any app from the Play Store on any device. Plus, many videos won't load in the YouTube app. This problem is affecting just the Google apps. I find it odd that not many folks are reporting this. I guess a lot of people either don't care or just use WiFi... As you said, using a different internet provider, one can download anything and all YouTube videos play/load. 

Userlevel 1

I’m having the exact same issue. So far no help from support. But this means it isn’t my phone.

Badge

Man I had a question on here for 7 months that still has yet to be answered. You post and within 1min already have 3 reply’s.! Wtf

Userlevel 1

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

Userlevel 2
Badge

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

This is great to hear, it’s not uncommon for Samsung updates to break features of our phones. I hope they can roll something out asap so people can use their devices as intended.

Userlevel 2

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

This is great to hear, it’s not uncommon for Samsung updates to break features of our phones. I hope they can roll something out asap so people can use their devices as intended.

Sorry but I gotta call BS on the Samsung issue.... Have 2 one plus 9 pros and a Nord n200 and a Samsung A32. ALL OF THEM ARE DOING IT!!!

talked to 4 different T-Mobile "experts",one supposed "tech" from OnePlus,then the last tech sent me to talk to Google after doing speed tests on my devices they said their mobile data was up to speed so it has to be google. Talked to a Google tech that had me do about 15 different things....in the end Google is blaming my carrier and my carrier is blaming Google. Meanwhile I have a mobile device that I can't download apps if I'm "mobile".  So YouTube takes forever,apps don't download on mobile data and I have to be at home on WiFi to make the most out of a mobile device.🙄🙄 Maybe someday we'll know what end the issue is on.

Userlevel 1

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

This is great to hear, it’s not uncommon for Samsung updates to break features of our phones. I hope they can roll something out asap so people can use their devices as intended.

Sorry but I gotta call BS on the Samsung issue.... Have 2 one plus 9 pros and a Nord n200 and a Samsung A32. ALL OF THEM ARE DOING IT!!!

And I have a Moto phone doing it too .. I am so mad. Experts? They are no experts. All they can do is run basic tests. They cannot think. But what annoys me even more is that not enough people are talking about this issue...as if we are some crazy outliers. 

Userlevel 5
Badge +12

This is from Google. I am unsure if you guys tried this.  
This one is from AndroidAuthority.  There’s more than basic reasons why it may be delaying updates.  For example not turning on download on any network for example.

 

Since This is a Google product doesn’t expect Carrier customer services being able to troubleshoot things like this.

 

Userlevel 2

This is from Google. I am unsure if you guys tried this.  
This one is from AndroidAuthority.  There’s more than basic reasons why it may be delaying updates.  For example not turning on download on any network for example.

 

Since This is a Google product doesn’t expect Carrier customer services being able to troubleshoot things like this.

 

Did all of those more than a few times and then when I was on the phone with the "experts" that's what they had me do every time. Did a factory reset and still does the same thing. Looking at the down detector website this is a pretty widespread issue.

Userlevel 1

This is from Google. I am unsure if you guys tried this.  
This one is from AndroidAuthority.  There’s more than basic reasons why it may be delaying updates.  For example not turning on download on any network for example.

 

Since This is a Google product doesn’t expect Carrier customer services being able to troubleshoot things like this.

 

Did all of those more than a few times and then when I was on the phone with the "experts" that's what they had me do every time. Did a factory reset and still does the same thing. Looking at the down detector website this is a pretty widespread issue.

That's why I won't bother calling the "experts". More of my time wasted. I love it when someone asks me Do you have enough storage space? 

Userlevel 2
Badge

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

This is great to hear, it’s not uncommon for Samsung updates to break features of our phones. I hope they can roll something out asap so people can use their devices as intended.

Sorry but I gotta call BS on the Samsung issue.... Have 2 one plus 9 pros and a Nord n200 and a Samsung A32. ALL OF THEM ARE DOING IT!!!

talked to 4 different T-Mobile "experts",one supposed "tech" from OnePlus,then the last tech sent me to talk to Google after doing speed tests on my devices they said their mobile data was up to speed so it has to be google. Talked to a Google tech that had me do about 15 different things....in the end Google is blaming my carrier and my carrier is blaming Google. Meanwhile I have a mobile device that I can't download apps if I'm "mobile".  So YouTube takes forever,apps don't download on mobile data and I have to be at home on WiFi to make the most out of a mobile device.🙄🙄 Maybe someday we'll know what end the issue is on.

This is also true, I’ve used a mate’s phone on my network and it is not working using their non-Samsung phone as well on the Tmobile gateway. So my assumption is there has to be an issue on the towers right now as my friend who has the same phone as me in a different state can download apps through the google play store just fine. I’m going to look more into this myself as much as possible and see if I can get some real answers. 

Userlevel 6
Badge +13

and here i am updating all my streaming apps right now so i can watch them undisturbed on my lunch break...updating with zero issues...LG V60

We are having the same issue (about a week). We have T-Mobile home internet as well, so unfortunately we cannot download apps/updates on WiFi either. Also, this seems to affect other google based applications such as YouTube. 

This does seem isolated to the 5G network. I am able to force my devices to use LTE and everything works perfectly. 

The same holds true for all my devices: Pixel 6, OnePlus, Tablets, etc.

Userlevel 2

The same thing is happening to us. A Pixel 6 and any Android devices we connect to T-Mobile Home Internet.

Userlevel 1

Just heard back. They worked with Samsung and Samsung says it is a problem with some of Samsung’s services not T-Mobile. They are working on a security patch (supposedly)

This is great to hear, it’s not uncommon for Samsung updates to break features of our phones. I hope they can roll something out asap so people can use their devices as intended.

Sorry but I gotta call BS on the Samsung issue.... Have 2 one plus 9 pros and a Nord n200 and a Samsung A32. ALL OF THEM ARE DOING IT!!!

talked to 4 different T-Mobile "experts",one supposed "tech" from OnePlus,then the last tech sent me to talk to Google after doing speed tests on my devices they said their mobile data was up to speed so it has to be google. Talked to a Google tech that had me do about 15 different things....in the end Google is blaming my carrier and my carrier is blaming Google. Meanwhile I have a mobile device that I can't download apps if I'm "mobile".  So YouTube takes forever,apps don't download on mobile data and I have to be at home on WiFi to make the most out of a mobile device.🙄🙄 Maybe someday we'll know what end the issue is on.

After I thought about it, I agree it can’t be that. I can’t download via cell service either but it works fine on my friend’s (non T-Mobile) service. Whatever it is, I hope they figure it out soon.

I have called customer service and tech support multiple times. They have no idea what's going on. It's infuriating. It is only on T-Mobile internet and their cell service. I have non-samsung devices that don't work also all devices work fine on all networks that are not T-Mobile so it's not a Samsung problem. There are two fixes for this that are only temporary. Use another Wi-Fi service at a friends or work that's not T-Mobile. Or download 1.1.1.1 app through a APK mirror and that masks your DNS. This is clearly a DNS issue between T-Mobile and Google

Userlevel 1

Mine just started working!

Userlevel 2
Badge

Mine just started working!

Are you able to download multiple updates and apps at once; have you tried using different devices on your network/hotspot? Is there any hanging on the installation process of the downloads? Right now in my area it is doing the same thing right now, not downloading.

Userlevel 1

Mine just started working!

Are you able to download multiple updates and apps at once; have you tried using different devices on your network/hotspot? Is there any hanging on the installation process of the downloads? Right now in my area it is doing the same thing right now, not downloading.

It took care of about 25 updates that were waiting.  Didn’t see any issues. I also downloaded something from the Play Store. Haven’t had the chance to try anything else yet.

Mine just started working!

Are you sure your not on a non T-Mobile network?

 

I have the same issue on my brand new Galaxy S22 Ultra.  I’m getting over 500Mbps on the speedtest app, so I know its not a speed issue.  

As someone mentioned above, it stays at ‘Pending’ the whole time.  

If I switch over to Wi-Fi (comcast), it works right away.  

It definitely is a T-Mobile issue and they need to fix it.  

 

Userlevel 1

Same issue on my Pixel 6 Pro. Has been happening for almost a week. Using a vpn alleviates issue. setting a custom DNS makes the issue come and go. using a vpn to completely obscure my tmobile connection restores proper functionality. this is 100 percent a tmobile issue.

Userlevel 2

According to DownDetector, most of the complaints about Play being unreachable are in the Chicagoland area of the US.

 

I’m in that region. Anyone else?

 

Nobody from T-Mobile will admit what is going on here.

I'm having the same issue in NW Indiana. T mobile needs to fix this fast.

So agree, it is a TMO issue. If I use my TMHI gateway, problems; if I go straight cellular, or onto say Starbucks wifi, works fine. And I have Samsung, Lenovo, and Pixel devices, all doing the same thing.

Frustrating part is every once in a while, ONE app will update, then back to no-go without doing anything other than selecting another app to update…. 

Question - as this is a TMO forum, does anyone from TMO look at it? I don’t see any official responses, just users trying to help users but we don’t have visibility to the network….

C’mon TMO!

 

Reply