Text messages are not sending...

  • 29 March 2019
  • 26 replies

I am able to receive text messages but none are going through.  It just says message failed to send.  I have tried being connected to the wifi and without but I still have a strong signal. Full bars.  I have tried restarting my phone and that did not help.



Best answer by tmo_amanda 8 April 2019, 18:09

View original

26 replies

Userlevel 2
Badge +1

This one is easy. has done it to some of my android (mostly lg’s) phones.


pay attention! but it’s straight forward.


turn off wifi.


if you do NOT use it, that’s fine, you can get rid of it after.


download google messages from the play store. keep wifi off after you download it and install it.


install it, accept and permit all necessaries access to your phone.


simply go to and enable chat features, it will either ask you or go under settings, in the messages app. accept whatever! let it set up until it says ready to use or chat features are active.


should start working almost instantly or within the minute, and texts etc will start going thru.


once that happens, TURN ON wifi, so it syncs in the system.


that’s it. use the phone like you always have.


keep using messages or get rid of it and go back to your phone’s messaging app if you like.


I had mine on, but I believe it is irrelevant if you have wifi calling on or off.


this little process always and magically corrects this problem. this is a wifi/data configuration thing that needs to be tweaked, corrected, once you got a new phone with the same num or simcard that has been transferred over. even if the phone is defaulted to stock or simply the phone has not been “refreshed” in a while.


if you already do use messages, follow the same steps. if it was already on, turn it off and restart the phone, then do the steps from above. :]

Thanks tmbileuser.  Installed google messages & use it instead of the messaging app that pre-installed on my LG phone fixes the problem. 

I have had this issue with my Note 8 since December 2019. Since February 2020, I have called support more than 15 times. First it was clear everything and reset to factory setting. Still had the same issue. Then I was sent a new Note 8, still had the same issue. Then I was sent a new SIM card. Still it is happening, I have been paying over $100 a month for service that does not work and no one knows why? I live in Miami-Dade county, FL. At this point, after 8 years with T-Mobile, I will not continue paying for a service that does not work and no one knows why? I doesn’t just happen at my house, it happen everywhere, it happens when on WiFi or cell service. Why can’t T-Mobile fix issues and follow up with its customers?

Userlevel 4
Badge +9

Try going into settings>apps>messaging>storage

and deleting the cache of the messaging app. If that doesn't work try deleting the phone's cache.

Hi, I’m in the family plan(magenta) with 8 lines. I’m facing issues on sent text failed. when we switch off wifi and cellular data text message didn't go through, but it supposed to be sent out because the text message is not related to any wifi or cellular data. what is the problem why we are facing this issue?

one of my friends has the same plan but he is not facing this issue.


looking for a quick resolution.

Ok so this is going to be a very technical answer. The Carrier Hub is a nightmare to deal with and was causing all kinds of problems on my phone including not being able to send texts. You can’t remove it using the normal methods so here is how you do it using the only if you know what your doing methods.

First you need to unlock developer mode on your phone this is done by going to setting and tapping on the build number of your software until it unlocks it.

You will then need to have access to a computer and down load the android SDK Platform Tools

You will then need to open a command prompt (as admin or root) to where these tools are installed. Connect your phone to your computer when developer mode enabled and then run the command

adb devices


This should prompt for your phone to trust your computer.

Once that is done and your computer can see your phone you can run this command

adb uninstall --user 0

That will remove the Carrier Hub app from your phone. I would then reset your network connections (found under reset options) and reboot your phone. This fixed all the network and texting problems I had.  


Thanks tmbileuser.  Installed google messages & use it instead of the messaging app that pre-installed on my LG phone fixes the problem. 


This worked for me as well, even though it doesn’t really sound right having to download another messaging app. Many thanks to tmbileuser

Very frustrating situation when text messages don’t get sent and just get stuck “sending.” Also more frustrating with 2FA and OTP (one time passwords) I wasn’t receiving texts either, which basically keeps you from accessing your accounts waiting for a OTP that never comes. I’ll share what worked for me and maybe it’ll work for you too. No guarantees, of course. I have an LGQ7+. I tried this yesterday 12/09/2020. 

I’ve been using the textra app for text messaging. After being on the phone with T-mobile tech support 3 or 4 times they tried having me clear some caches and restart my phone a couple times. It didn’t work and left tech support with no solution. But when I combined their tips with tmbileuser’s trick it worked. 

I turned off WiFi and bluetooth for all this. Under apps and notifications, app info, find the “carrier services” app, click storage, clear cache, wait a couple seconds and then clear data. Wait a couple seconds and then restart phone. You can also try a “force stop“ in there too before resetting phone. I did that at least once, just can’t remember when I did it. Test and check text messaging after phone comes back on and finishes booting up.

If that still doesn’t work. Do the same thing under your factory text messaging app. Just make sure you convert your text messaging app to the factory default app first, so it’s “supported by T-mobile.” For me and my phone “messaging” is the factory LG app. After making it my default text app I click storage, clear cache, clear data, restart phone as before. Then test text messages again. If it works for you, great, done deal. 

Didn’t work for me. After doing those two things a couple hours later I stumbled upon this forum desperately trying to find a solution. I downloaded the “google messages” from the play store as prescribed. As soon as the app was downloaded, I went to open it from the play store screen and within 30secs text messages started coming in. I just opened the app mind you. I didn’t even set it up and accept permissions yet. Things started working. At this point, I’m assuming you could delete the app if you wanted to and move on with your life. I decided to keep it and replace my textra app. Google Messages seems to have more features. 

This all begs the question… what did the Google Messages app do in the background to fix this problem? Maybe it did something to reconfigure or fix carrier services app?

One shouldn’t have to (be forced to) download Google Messages just to get their text messaging to work on their phone. I hope it’s not another Google take-over plot going on. 

Hope this helps someone. And I hope to not have this problem again. 

Userlevel 4

what particular phone do you have and when did this begin... has it always been a problem or just recently?perhaps you got a new phone or there is a sim card problem or there is message blocking on the account. have you contacted TMobile?

Userlevel 7
Badge +15

Restarting your device is one step but have you powered it off for 5 minutes to allow it to refresh on the network? 

No I have not tried that. I will.

Userlevel 4

Happy Monday, @vyckie72​!

I just wanted to swing by to see if you're able to send texts now. If you're still having issues, please share what type of phone you're using and the zip code this usually occurs in.

Userlevel 3

Just wanted to check in on the questions from Amanda above!


It seems like it only happens at my office for some reason, I connected to the wifi and they are sending now.


i just did a system upgrade on my Android S8 -- i am receiving group messages however i am not able to send out group messages.

i have the group messaging enabled... i did shut my phone down for 5 mins then restarted it... but i am still not able to send group messages (prior to the upgrade it was working fine)

Userlevel 4

Vyckie, it sounds like this is a network issue since you have it narrowed down to one location and the messages send when connected to WiFi. You mentioned you have a strong signal at work so something else may be going on. In this case, I recommend working with either your local TEX team via 611 or T-Force over Facebook/Twitter to have us take a look at the network in the area which may possibly lead to filing a ticket with our engineers.

@aguirago​, welcome to our Support Community! How many people are included in the group text? Have you tried deleting that specific message thread and starting a new one with the same people? Lastly, are you using the stock messaging app?

thank you.

i have 2 groups ... one has 4 people (including myself) and the other has 8 people (including myself) .. and i have tried to start a new thread - same issue 😥 not sure what stock massaging app is... but i am using "messages"

I am currently messaging through Facebook to get some answers.

Userlevel 7
Badge +15

The stock messaging app refers to the messaging app that came pre-installed on your device. 

thank you for calcification, and in that case yes i am using stock messaging.

Userlevel 3

Can you let us know what happens when you try and message the group?

Have you tried starting a new thread with different people to see if there is any combo you can get to work?


when i tried using a new group send a group text on the stock messaging app.. it did not work...

however i installed the android messaging app..the only thing is when i send group text it displays my message twice

Userlevel 6
Badge +15

Hmm, so do you get a message failure error when you use the pre-installed messaging app? i'm also curious if you're able to send individual messages or do they not work either?

I'm having issues with group messaging as well,  and I deleted the messaging cache and it still fails. I'm tired of replying individually.

Userlevel 4
Badge +9

Try deleting the phone's cache as well. By the way, did you restart the phone after you deleted the app's cache?