Solved

Text messages frequently fail to send, even when I have a solid connection.


Far too often, I am having a texting conversation with someone, when a message will simply fail to send. This often occurs in my home, where I have both a solid wifi connection and four bars of 4g connection. However, this problem seems to occur no matter what location I am in.

Aren't text messages supposed to be able to be sent when there is a wifi connection? Although this sometimes happens when I have wifi and 4g, it happens a lot more when I have wifi but not 4g.

Please help me to fix this problem. It is very annoying. I never had this happen when I had sprint.

This also happens with calling; sometimes I just can't call someone even though I have a data connection.

My phone is a samsung galaxy s10, and I just got it in June. My family members have the same phone and they often experience this problem too.

icon

Best answer by tmo_amanda 15 August 2019, 00:57

One other thing that I thought of that you can try on your S10 is to change the network preference to "WiFi preferred" follow these steps. You can also try resetting the network settings:

  1. From the Home screen, swipe up on an empty spot to open the Apps tray.
  2. Tap Settings > Connections > Mobile networks > Access Point Names.
  3. If available, tap the T-Mobile US LTE (the bullet point fills with green). If not available, tap ADD.
  4. To reset your APN settings, tap Menu > Reset to default.
View original

12 replies

I used to experience this when my phone was connected to LTE. Switching to 2G/3G mode would usually get the text to send. It has not been much of a problem since I got a new phone.

Same issue here. I do not receive call or texts and I can not send text message on a daily bases. I went to my local T-Mobile store and they gave me a new SIM card.  Still the same issue. I have to restart my phone, Galaxy S10, on a daily bases. This seems to be the only thing that will allow me to send text messages.  I never once had this issue on Verizon with my previous phone, Galaxy S7.

I'll have to try this. Do you normally switch it right back to LTE after? This would be pretty annoying if you're trying to do something which requires LTE at the same time as you are texting someone.

Yes, I would switch to 2G/3G mode, send the text, then switch back to LTE mode.

Userlevel 6
Badge +13

Check the number and settings in the messages app to make sure everything is correct.  I have seen the texting issue pop up a few times on the XDA boards where more commonly, the settings in the Samaung Messages app seem to be incorrect.

Userlevel 5

Hey, @magenta9463218​! I don't have an official fix for the issue but I've seen this happen time and time again. What others have reported as a fix is turning on airplane mode then turning it off. It's similar to what others have mentioned here about switching to 2G/3G mode. Can you give that a shot and see if your messages will go through that way?

+1 @drnewcomb2​ suggestion.  Particularly if that is the only problem and it just started out of the blue.

FWIW I experienced this when traveling once (San Diego), was on 4G LTE, using an unlocked, unbranded device at the time.  It was actually a call to T-Mobile Customer service that I learned this.  For me it was a very rare occurrence, maybe twice, maybe three times.

I've tried switching from 4g to 2g and it doesn't help.

Furthermore, I think the more pressing issue is that if I have only a Wi-Fi

connection, I can't send or receive any messages. Shouldn't you be able to

text on Wi-Fi alone?

I missed the point that you are speaking of WiFi    The tip about switching mode on wireless doesn’t apply. 

I dont know android at all, so I will just offer some rough ideas that may help.  If not, perhaps someone will offer more detailed info.....

If you have been able send SMS and MMS before on WiFi only with WiFi calling, then my assumption to start with is the problem is not a setting per se.   I would try things that I believe have some have already been suggested.  Restart the device.  Toggle airplane mode off and on.  Delete the wifi profile, restart the device, and add the profile again.  Try each from easiest to more troublesome, and test each time.

For or what it’s worth, on devices I had before, I could switch Routing Preference between circuit switched and packet switched.  For SMS on WiFi calling the setting needed to be packet switched.  I don’t know if you have that or not.  I looked on my iPhone and—maybe because of iMessage—there is no setting such as this.  Just throwing out FWIW if you have that option and SMS has not worked on WiFi calling at all for you.

Userlevel 6
Badge +14

Have you tested your text on Wi-Fi as well as the mobile network recently to see if it's working?

Userlevel 5

Just checking in here to see how things are going. Please let us know if you still need help.

Userlevel 5

One other thing that I thought of that you can try on your S10 is to change the network preference to "WiFi preferred" follow these steps. You can also try resetting the network settings:

  1. From the Home screen, swipe up on an empty spot to open the Apps tray.
  2. Tap Settings > Connections > Mobile networks > Access Point Names.
  3. If available, tap the T-Mobile US LTE (the bullet point fills with green). If not available, tap ADD.
  4. To reset your APN settings, tap Menu > Reset to default.

Reply