Solved

Texting issues when connected to WiFi

  • 28 August 2018
  • 60 replies
  • 9695 views


Show first post

60 replies

Same issue here.  I have an unlocked AT&T phone on T-Mobile. I don't use or have WiFi calling enabled.  I don't seem to have problems sending texts (SMS), but get delayed texts.  If I shut off WiFi, bam! , I get the text.  Does T-Mobile send text over WiFi even if WiFi calling is off?  Could it be I disabled IPv6 on my home internet?  I will try to do more tests.

I am also experiencing this issue intermittently, but recently much worse.

If I turn off wifi, SMS sends just fine. Turn it back on, no SMS will send. Same problem any any wifi network. Home, office, airport, etc.

Immensely frustrating and makes me really consider dropping T-Mobile.

Long time t mobile consumer here. Never experienced this problem before recently getting a new phone. Texts/pictures would not send (msg. Failed), unless I turned off WiFi.

What seemed to work for me was PERMISSIONS.

Device settings---} App.settings/mngmt.---} find the app you use for texting---} Permissions---} give it all the permissions. Save settings. Restart device. Hope that helps someone

I've been having a lot of trouble with this at work.  In my office I don't get a good cellular reception but my phone is connected to WiFi.  However, I consistently have the problem where SMS won't send (thru Messages).  Sometimes they are just really slow and they eventually go thru, though on occasion they get dropped completely (especially pictures).  Sometimes turning WiFi on and off helps push them thru, sometimes it doesn't.  However, I might have finally found the fix.  I switched the WiFi calling preference from mobile network to WiFi.  After doing this, when I send an SMS it consistently sends within 1-2 seconds.  Prior to the change, they would be in the "sending" state for 5-10 seconds minimum or 30+ minutes in the worst case when they just weren't getting thru.   And for reference I have a Pixel 3.

To clarify, I've always had WiFi calling enabled.  The change today was to select which network it attempts to use first, WiFi vs. mobile.

I tried just about all of the suggestions with not luck. Weird combinations of issues. Could send text over wifi to some iphones not others; could never send text or pictures over wifi to ANY android phone; etc. Finally just reset my network settings and so far so good. I wonder of network setting accumulate changes over months or years and gets confused. Anyway... will let you know if it sticks.

I was able to solve a similar issue. While connected to WiFi, and good 4G LTE  signal, and receiving the error message "cellular network not available. Connect to WiFi for messaging?" while attempting to send texted and all other internet functionality seemed to be working. And yes. There was a question mark at the end, even though that's not a question. Pet peeve of mine.

Ih

I'vead the same phone for years, and I've been a T-Mobile customer for almost a decade. Never had this problem, and not sure why someone would leave a great network for such a minor issue. That's like leaving Ford because your car didn't start one day. Anyway, I had called T-Mobile support for an unrelated and during that process they had me reset my network settings. That's when it started happening. I came across this thread and hopefully this helps some folks...

Check Settings>More under Wireless Networks and see if WiFi Calling is disabled. If so, turn it on and change Connection preferences to "Cellular Network Preferred". Texts began to send normally, and I was even able to keep texting after changing Connection preferences back to "WiFi Preferred" and even disabling WiFi Calling entirely.

I have been having issues for a while. I just assumed it was my phone. (not a normal one) interesting to see its not just me. Phone calls and texts both only seem to really come in when I am not on wifi. In order to sign in, I had to take wifi off to get my two-factor authentication to get the text. I can call out no problem, texting out sometimes does not seem to be an issue. It's also not EVERY text. it's strange.

So I’m having the same issue but it definitely only started once my phone, (not iCloud), storage became nearly full.  Memory is just about used up and now my texts won’t send on WiFi as well as browsers are slow and not loading/ all apps crashing… Ive has to delete and offload all apps…I def need an upgrade With more storage than 64.

Userlevel 4
Badge +8

If anyone has enabled power/battery saver, the app/setting often saves battery by disconnecting from wifi while it’s not in use. This can cause a problem if you send a text message before it can reconnect. I always set the battery saver and then choose to NOT disconnect from wifi (i.e. Custom setting), thereby, solving the problem I once had. :wink:

Reply