Solved

Unable to receive SMS after updating SIM

  • 12 August 2020
  • 7 replies
  • 328 views

Badge

I recently replaced my 15 year old SIM with a newer SIM (at the tmobile store) and since then I’ve been unable to receive any SMS. Sending SMS works fine, calling works fine, Data & LTE works fine.

 

Any idea on how to resolve the issue of not receiving SMS will be greatly appreciated. I rely on SMS a lot and it kinda sucks that it’s broken.

Please help

icon

Best answer by long_time_user 12 August 2020, 20:52

Ok, so the issue has been resolved.

 

For my case, the way to resolve it was to insert the SIM into a T-mobile authorized device (the expert from the store had one). Once the SIM was inserted and initialized using a T-mobile device, all the messaging started pouring in.

After this, moving the SIM back to my unlocked device got the SMS working as expected.

I’m able to send and receive messages.

 

Hopefully someone finds this useful.

 

Thanks

View original

7 replies

Badge

Ok, so the issue has been resolved.

 

For my case, the way to resolve it was to insert the SIM into a T-mobile authorized device (the expert from the store had one). Once the SIM was inserted and initialized using a T-mobile device, all the messaging started pouring in.

After this, moving the SIM back to my unlocked device got the SMS working as expected.

I’m able to send and receive messages.

 

Hopefully someone finds this useful.

 

Thanks

Userlevel 7
Badge +13

Have you tried sending a text to yourself?

Badge

thanks !

I’ll be off to the store once they open today. Will update this post on how things go.

Userlevel 6
Badge +13

Going back tot he store might be helpful.  They could try the SIM in another device to see if the problem still persists.  If it does, then they should replace the SIM card and test it before you leave the store.  

Badge

and btw, it’s been more than 3 days since the new SIM was activated.

Badge

Thank you for your reply,

I tried pretty much everything, called customer support to reset network connectivity, reset phone, tried on multiple devices etc.

Customer support claims that there’s nothing wrong on their end but I still don’t receive any SMS. I’m able to send them though.

Does it mean the new SIM might be damaged or something ?

I’m out of clues… Will be taking it to the store to have them check it out.

Userlevel 6
Badge +13

This might be from a bit of SIM update lag.  Try powering your device off for about 5 minutes to allow it to refresh its connection to the network. 

Reply