Why is my tethering speed so slow?


My issue is similar to other threads I have seen here. I am a on a grandfathered Simple Choice NA plan with 10 GB of high speed data. I am not close to using all of my data. My data speeds are always around 10 Mbps (or higher) download and 8 Mbps upload directly on my phone. (On the SpeedTest I just ran I got 25.5 download and 8.11 upload.) However, when I USB tether to my laptop (or desktop), data speeds drop to about 0.3 Mbps download and 0.1 Mbps upload.

I have multiple lines with T-Mobile and multiple phones. It happens on all phones and all lines. The issue is not related to my location because data speeds on the phone are adequate. As soon as I USB tether, speeds drop drastically. The issue is not related to tethering to one particular laptop either. I have been having this issue for the last 1.5 years and in that time I have used several different laptops. Prior to 1.5 years ago, tethering speeds were fantastic. My T-Mobile plan has not changed during this time.

My phones include a Galaxy S8 and a Galaxy S8+ (but the problem has happened with prior phones, as I mentioned). My phones are all T-Mobile branded devices. My current laptop is a Lenovo ThinkPad. I do not have to use a 3rd party app on my phone (USB tethering is built in to Android on the S8, S8+) and I do not need a 3rd party app on my laptop. When I turn on USB tethering, I get a proper connection. The issue is that it is very SLOW.

I also tested the mobile HotSpot feature. For about the first 5-10 minutes, I had good speeds while connected with my laptop, but then the speeds dropped to the 0.2 or 0.3 Mbps range and stayed there the rest of the day. That looks like throttling to me...

Over the last 1.5 years I have called T-Mobile support many times regarding this issue. Tickets have been opened. Unfortunately, no solution. Usually the support person is very nice and promises to follow up with me. So far not a single person who has made me that promise has actually followed up.

Multiple T-Mobile support reps have told me that my plan has no throttling of my 10 GB data allotment. I used to be a huge T-Mobile fan. I have had my current account for over 6 years with multiple lines. Before that I was with Verizon for 2 years, but prior to Verizon I was also with T-Mobile a long time. (I was a loyal T-Mobile customer even when their network was not as competitive as it is now.)

Can anyone from T-Mobile solve this for me?


54 replies

Userlevel 6

Yikes, @d.t.​. Any issue that persists over the course of a year and a half is one that's lasted about one year, five months, and three weeks too long. 😥

Assisting with SMHS or tethering issues over our forum is a little tough, because we don't have a secure platform for account access to review the particulars. It sounds like you've reached out for assistance a ton of times (which again, shouldn't be necessary!). In this situation, my best recommendation would be to reach out to our T-Force team via DM on Twitter or Message on Facebook. You've taken such effort to articulate the issue (very well!) -- you can copy and paste what you've posted here! What we need to do now is take a look at the previous tickets filed and re-open and/or escalate them since the issue still isn't resolved.
Regarding the follow-up, I sincerely apologize. Since we don't know exactly how long engineering will take to review each individual ticket, when we file one we should be scheduling a set time and date to follow back up with you. If at the time of that appointment the ticket still hasn't been returned, we should set another follow-up appointment. At no time should you be left wondering when you'll hear from us -- that is not our customer service standard! Another good benefit of interacting with T-Force is that you can return to the same message thread to check in on your ticket status with any T-Force rep at any point -- so that will hopefully ease some of the issue there.

Because T-Mobile support reps keep asking me the same questions over and over, here are the answers:

Question 1. Do you have these issues anytime you tether or only at specific times?

Answer:  I have been having this issue for about the last one and a half years. Prior to 1.5 years ago, tethering speeds were fantastic on T-Mobile. During the last one and a half years, every time I have tried USB tethering, I have had very slow download speeds (such as a fraction of 1 Mbps).

Question 2. have you ever tethered to another device other than your laptop and run into the same issue?

Answer: See my original post. I have had consistently terrible download speeds on USB tethering with all my T-Mobile lines, on many different laptops, and several different phones.

Question 3. how may bars you have on your phone when you try and connect?

Answer: I have 4 or 5 bars at this location -- usually 5. However, I also ruled out a bad mobile network data connection by the following observation: my data speeds are always around 10 Mbps (or higher) download and 8 Mbps upload directly on my phone. (On the SpeedTest I just ran on the phone I got 25.5 download and 8.11 upload.) However, when I USB tether to my laptop (or desktop), data speeds drop to about 0.3 Mbps download and 0.1 Mbps upload. This happens with no change in the position or location of the phone and no change in bars.

Question 4. Have you put your sim in another phone to see if the issue still happens?

Answer: During the time I have been having this problem I have used multiple T-Mobile branded phones including an LG G5, Galaxy S8 and Galaxy S8+. I received new SIM cards with the Galaxy phones and these new phones with new SIM cards did not improve or change the slow USB tethering speeds.

Question 5. Have you tried connecting through your WIFI or do you always do it with a USB cord?

Answer: Here are some speed test results I just completed. I ran these tests over the last hour using two different laptops. I tested both USB tethering and WiFi tethering.

USB tethered:

http://www.speedtest.net/result/7432946993.png

http://www.speedtest.net/result/7433056239.png

http://www.speedtest.net/result/7433054166.png

http://www.speedtest.net/result/7433013563.png

http://www.speedtest.net/result/7432994735.png

http://www.speedtest.net/result/7432991387.png

http://www.speedtest.net/result/7432985625.png

http://www.speedtest.net/result/7432983858.png

Mobile Hotspot (WiFi tethered):

http://www.speedtest.net/result/7433101215.png

http://www.speedtest.net/result/7433103846.png

http://www.speedtest.net/result/7433105939.png

http://www.speedtest.net/result/7433112405.png

http://www.speedtest.net/result/7433119951.png

As you can see 100% of the USB tethering tests have unacceptably slow download speeds. The WiFi tethered speeds are also typically just as slow, but in these tests I occasionally see results that show acceptable speeds. A week ago I was getting good speeds with WiFi tethering for about 10 minutes straight, and then they suddenly dropped to a fraction of 1 Mbps and stay at this crawl the rest of the day.

To be clear, all these speed tests were done with my T-Mobile branded Galaxy S8. I used two different laptops and I tested by USB tethering and WiFi tethering. I used different servers during the tests to eliminate the possibility that any one server was slow. The above results are essentially the same as the results I have been seeing for the last year. USB tethering speeds are always slow. WiFi tethering can sometimes be better, but they are mostly very slow too.

I just ran another speed test using WiFi tethering. 0.34 Mbps download and the upload test timed out (so that's a 0 upload speed). Sad.

I  have a similar issue my Hotspot speeds doesn't match up with what I have on the phone normally it only happens when I have speeds lower than 5mbps or 3mbps if I have higher than that then it works unfortunately I live in a heavy congested area so speeds if am lucky go up to 2 mbps or higher if like for example I have 1.5mbps on my phone trough the Hotspot I only get 0.01mbps and that's literally 2G speeds this started around when they announced t mobile one before that speeds I got on the phone where the same on my Hotspot I did some digging and I find on their terms and conditions that data trough the Hotspot isn't treated the same way as on the phone I am like I don't have unlimited 4G LTE Hotspot I have a certain high speed data allowment so I am not getting what I am paying for that is the 7GB of high speed data I haven't complained yet since I want them to first fix the congestion on my area so I looked for alternatives and started using an app called foxfi/Pda net this actually gives me unlimited high speed Hotspot trough sometimes I run into issues but overall it works

I decided to do some testing with an alternative site: https://testmy.net/

This site provides some good data.

Download Connection Speed:: 228 kbps or 0.2 Mbps

Download Speed Test Size:: 1.3 MB or 1280 kB or 1310720 bytes

Download Binary File Transfer Speed:: 29 kB/s

TiP Measurement Summary:: Min 0.16 Mbps | Middle Avg 0.23 Mbps | Max 0.34 Mbps | 61% Variance

Test Time:: 2018-06-29 16:53:08 Local Time

Client Location:: US https://testmy.net/country/us

Target:: New York, NY https://ny2.testmy.net

Client Host:: T-Mobile USA

99% slower than country avg

This test of exactly 1280 kB took 46.506 seconds to complete

Userlevel 5

You are incredibly thorough!

Soooo, we definitely need to have another ticket filed. And I am sure that's absolutely not want you want to hear since you have not found resolution in them in the past, buuuut. The resolution for this lies 100% in a trouble ticket of some sort.

What I would suggest is reaching out to T-Force and linking to this thread so they access to both your account, and the information you have posted here. We aren't able to access accounts through here which is why we are limited to what we can offer, but they have online access to your account unlike us, and they will also have access to all the information you have here!

There will also be written record of all the interactions you have so there is a solid paper trail of what has been promised. You can find T-Force through FB or Twitter, there are links in my signature!

-Lauren

I reached out to T-Force on June 20th.  A ticket was opened. I provided them with even more information than I provided here. Unfortunately, it has been a waste of time. Nobody even asked me any good questions. All I did was continually repeat what I already said here in the first post.

T-Mobile has a really bad policy that nobody can speak directly to a support engineer. I cannot speak directly to a support engineer and apparently neither can T-Force. They can open tickets, but nobody can have a conversation with a support engineer.  In my T-Force conversation, people come and go and I am continually asked the same questions over and over with nobody going beyond the basics to actually investigate the details. Nobody ever asked me to run a traceroute or a ping or anything else.

On June 24th one person told me a new ticket had been opened on one of my other lines. Then on June 29th another person told me that ticket had never been opened. It's like a broken record that repeats the same thing that has been going on for the last 18 months I have been trying to get this solved. I'm really ready to give up on T-Mobile.

Userlevel 5

Hmm.


That's definitely not the experience we would expect to see you having, I'll be happy to do some follow up and see what we can find. You are indeed correct there is not a direct line in on engineering, for T-Force or any front line team. That said, the ticketing process when completed properly should negate that need and is a more efficient use of their time when working as it should

I'm going to send you a private message and get some info from you and we'll go from there! You can check your inbox here - https://support.t-mobile.com/inbox

-Lauren

Thank you Lauren. I received your private message. I prefer to reply here. Unfortunately, my experience with T-Force was just as unsatisfactory as my prior experiences with telephone support over the last 18 months. It started off well, with a T-Force support rep telling me, "It looks like we have not met our commitment on this for you in the past, but I am determined to get this resolved for you. Not only that, I am very curious myself as to what is causing this! We are getting into my weekend, but I would like to go ahead and set a follow up for Sunday evening when I am back in the office it that is okay." Unfortunately, that rep simply dropped out of sight after a few days without seeing it through to any kind of resolution. I then had to start the conversation over with new people which meant answering the same basic questions I have answered dozens of times over the last 18 months. After doing this for several new people in that same conversation, I realized I was, once again, wasting my time.

Around that time forum member @landonloco posted his solution of using a 3rd party tethering app. I tried that and it does indeed work for me too. After running hundreds of tests on my own over the last 18 months, this recent experiment with a 3rd party tethering app makes it clear that T-Mobile's data management policies are the problem. Therefore, I'm dropping out of the official support channel and I'll address this on my own the way the other person did. Clearly T-Mobile does not intend to fix this because tethering is severely deprioritized by intentional policy.

There is a level of dishonestly here. I have been consistently told by T-Force support reps (and phone support reps) that I should expect better tethering speeds. However, somebody should have told me 18 months ago that T-Mobile's network management policies lead directly to unusable tethering in situations as described by landonloco in this thread.

I want to add that not only have I been a T-Mobile customer for more than 6 years straight, I have been a vocal promoter of T-Mobile to all my friends and followers. But I am extremely disappointed in T-Mobile's position on tethering. I realize economic factors are driving this, but the policy-makers are being short-sighted in a way that is decidedly not "Un-carrier"-like. T-Mobile is as bad or worse than every other carrier when it comes to tethering and mobile data. (Example: your MiFi device is consistently reviewed as much worse than AT&T's or Verizon's.) Those two features are the two most important for me and, I would guess, for most thought leaders in the mobile space. T-Mobile needs to wake up to this problem and fix it in a hurry.

Userlevel 5

I responded to you in PM as well, but I definitely understand your hesitancy to want to reach back out to them. I still went ahead and made sure I passed this thread along to them for feedback, your experience is certainly not what we have come to expect from T-Force or any of our representatives.

I'm unfortunately at a bit of a disadvantage since I'm unable to collect secure account info through a public forum and thus unable to review what's transpired and any notes.

I can't entirely speak to your whole situation without all the pieces, but it certainly does sound like there is something going on. If I wind up with more information or able to find anything, I will certainly return to this post and publish any findings.

-Lauren

I just switched to TMo on Tuesday (two days ago) after 10 years with ATT.  I was ok with the tethering speed being only 3g, but I am getting exactly the same numbers that you are getting.  With my TMo branded S8, I am getting anywhere between 7 and 25 Mbps download, but while tethering my Surface Pro 3 through this phone, I am getting between .22 and .52 Mbps!  Good grief, that is really bad.  Not sure I can do this.  I know I don't want to go back to ATT and I won't go to Verizon, so I am really over a barrel. 

Interesting that your speeds show the same pattern as mine. I think @landonloco has the right idea in his post of Jun 29, 2018 1:42 PM in this thread.

I was thinking I would need to add the extra "high-speed" tethering for my line (One Plus plan?), but apparently that doesn't make a bit of difference, if I am reading your issue correctly.

@timmyb​ from what I have read, adding the extra "high-speed" tethering has worked for some people but others still have these super slow tethering speeds even with that paid feature. Even on plans that support "high-speed" tethering, that traffic is severely deprioritized.

In my case, the slow speeds are definitely not due to my plan's limitations. My plan includes support for high speed tethering up to my data limit of 10 GB per month. The problem is that I do not receive high speed tethering at any time, regardless of my data usage or lack thereof. (Over the last 6 years, it is a rare month where I have used all my data.)''

I think my slow tethering speeds result from an overall network management policy that is independent of one's plan. But if your plan doesn't support high speed tethering, then that's a different issue.

If I were you, I would probably try adding the extra "high-speed" tethering feature first and see what happens. Personally, I would not have minded paying T-Mobile an extra amount of money if they could provide good tethering service at a fair price.

Sounds like a good plan to try adding it first.  I'm going to wait until after this holiday weekend as I'm sure the lines are a bit taxed by the tourists in this town.  Not enough to create this much of a slowdown but I want to remove that variable.

⁣Sent from BlueMail ​

DT can you add an APN in your connection settings?

phamos1 wrote:

DT can you add an APN in your connection settings?

Yes, why?

Because after weeks of internet searches I found a solution for my galaxy s8+. does this form have pm?

phamos1 wrote:

Because after weeks of internet searches I found a solution for my galaxy s8+. does this form have pm?

Yes, add me to your connections, then you can send me a message through this forum. Looking forward to hearing about your solution.

It says you have to be following me and excep my following invite to send messages.

_

Thank you. I"m going to try the same. I hope my "after" results are as good as yours.

After my initial frustration, I decided to bump up the plan to the paid option.  It worked instantly.  Kind of disappointing that I need to pay for it, but at least I'm not banging my head against the wall trying to figure it out.  I am usually only in my "summer home" (which has very poor WiFi availability) for about three months, so at least I don't have to pay for this year round.

timmyb wrote:

After my initial frustration, I decided to bump up the plan to the paid option. It worked instantly. Kind of disappointing that I need to pay for it ...

I have to disagree. What's really frustrating, and what this thread is about, is those of us who are paying for the best tethering T-Mobile offers and are not getting it.

I've been paying T-Mobile hundreds of dollars a month (multiple lines) for more than six years. For the last 18 months or so, tethering has not worked for me even though I am paying for it. I'm going to try @phamos1​ suggestion tonight and see if that helps me as much as it helped him. (Speaking of frustration, another one is that T-Mobile's best support people did not resolve this for me after multiple support tickets over 18 months.)

Anyway, I am happy that tethering is working well for some people, but I am just taking exception with that we should call frustrating. As I said, the real frustration is when you pay for it and you still don't get it.

Reply