Solved

Why No TM-AC1900 Firmware Updates

  • 5 February 2015
  • 54 replies
  • 7556 views


Show first post

54 replies

‌Got fed up waiting for TMobile firmware and flashed mine to stock Asus. Not as scary as I thought.  Biggest thing is you'll need to change the bootloader to allow you to update the firmware. It involves using a hex editor but it's simple cut and paste. If you follow the directions it's fine. Also mine wouldnt let me flash with the latest Asus firmware until I flashed with an earlier version. Again, instructions link to earlier firmware so you can do this. Just follow instructions here:

T-Mobile Personal CellSpot AC Router by Asus - Free for postpaid ($25 deposit) 09-10-2014 - Slickdeals.net

Well you pulled the trigger a week too soon.  My router reset for some unknown reason today (6/3/2016), so I decided to log in and check it.  And what a surprise!  It had just updated to 3.0.0.4.376_3169.  I would have preferred that it auto-update overnight rather than 1:30 PM while I was using it.  Still too early to notice any difference...

Mine also. About 8:00 PM last night.

Stock firmware is 3.0.0.4.380_3264.

Do you have all the new features including use of the Android/iOS app to access the router, Adaptive QoS and ability to view bandwidth per device?

This is what my General column looks like:

It has a Traffic Manager tab that seems to include the Adaptive QoS and Traffic Analyzer. No AiProtection or AiCloud tabs. I have not poked around the new UI very much.

Mine hasn't gotten the update after multiple checks. Is there a way to do this manually?

Here's a way to force whatever firmware you want. NOTE - this will void your warranty on the device.

Don't rely on T-Mobile for firmware updates because you will not get timely through them. Not sure why but their firmware is very far behind the actual device this router is based on which is the Asus RT-AC68U. The current firmware (at time of writing 12/2016) is version 3.0.0.4.380.4164.

You cannot flash this firmware directly from the router's admin page but you can force flash it by using some common SSH commands. Here's a quick guide on that process. Don't do this if you are uncomfortable with typing at a command prompt.

1. Download the current firmware version that you want. (Look into Asus Merlin firmware as well. Really cool stuff)

2. Download Putty (ssh client) and WinSCP (SCP & SFTP client)

3. Log into your router and go to Administration > System and enable SSH. Click Apply

4. Open WinSCP and change the protocol to SCP, type in your router's IP address (192.168.0.1)

5. Log in with your router's admin account (or whatever acount you setup)

6. Verify that the right-hand pane of WinSCP is in the /tmp/home/root directory

7. In the left pane find the firmware that you downloaded and drag it over to the right pane (/tmp/home/root)

8. Once that completes open Putty and use the same router IP address that you used above

9. Log in with you router's admin account. Congrats, you have root access to YOUR router

10. Type the following commands (In Italics) below in Putty, pressing Enter after each one:

cd /tmp/home/root/

ls


(You should see your firmware listed after this command)

/sbin/mtd-write2 /tmp/home/root/your-firmware.trx linux && reboot

Congrats, you have flashed an official or aftermarket firmware on the router!

Once it reboots, sign back in through your router's admin page and verify that your previous settings are still applied. Being a T-Mobile device I found that after the flash I could not get to T-Mobile.com but that was an easy fix...

Log into the router and go to LAN > DHCP Server. In the field labeled TM-AC1900's Domain Name, delete T-Mobile.com and click Apply. You should now be able to get to their website.

Report back with your results 😊

This worked perfectly.  Thank you very much for these easy instructions.

@timmytimaz - Excellent instructions! I cannot thank you enough for simplifying the firmware replacement process.  I am comfortable with scripting, etc., but I was leery of the instructions found on the slickdeals site.

I did have an issue:

The reboot cmdlet didn't work in the PUTTY session.

I waited about 5 minutes and then power-cycled the router.  After that, everything is working as advertised.

Woot!.

That's awesome, you guys! I'm glad it worked for you too 😊

This is a really nice device and it's a shame T-Mo doesn't keep it updated. The new firmware fixes a ton of bugs I was having with this thing. Oh well.... All good now!

Great guide! I got the router for free and have to return it at some point, so if I flash it with newer Asus firmware, will I be able to put stock firmware back in the future or how could I do this?

I would like to try this soon but was curious, can I follow this procedure on an ASUS RT-AC66U or any router for that matter? I have an RT-AC66U and TM-AC1900 and want to put Advanced Tomato on both. I was considering Asus Merlin as well but I didn't like that they pointed out on the dev page that they specifically don't target new features very often. May not be an issue but I always like Tomato on my old Linksys router a long time ago.

Does this new firmware keep T-mobile's patented wifi-calling prioritization feature?

@timmytimaz

Thanks for the instructions!  I can't wait to try it.  I have a question though . . . all of the other instructions I saw mentioned going to an intermediate firmware first in order to change the /jffs partition from 32MB to 64MB . . . have you confirmed that your method does that?  I.e, does 'df -h' show the bigger partition size?

Thanks again for your good work and for sharing! 😊

I'll pose the question to @foamcowadv‌ and @danny.villarreal‌ too . . . did you guy notice if the rootfs partition increased to 64MB?  Or did you have to use an intermediate firmware first, then go to the latest?

Thanks!

You don't need a lower firmware version to jump to first. Flashing the newest firmware from Asus took it to 64mb

Thanks for the response!!! 😊

Anytime 😊

Let me know if you have any other questions and I'll try my best to help!

I did not have to downgrade to get the 64MB partition. Woot.

From my device:

df -h

/dev/mtdblock4           62.8M      1.8M     61.0M   3% /jffs

Thanks!

@ timmytimaz Greetings thanks for the tutorial. My question to you is: Do you know if flashing the RT68U firmware removes the Tmobile wifi call prioritization feature? thx

Userlevel 6
Badge +13

If you remove the stock firmware, you remove the T-Mobile optimization.

Noticed an update this morning to my TM-AC1900. It shows: 3.0.0.4.376_3181  Not sure when this happened.

Userlevel 6
Badge +13

The update was available several months ago, but you might have just updated recently either automatically somehow or by searching for an update in the router interface.

I'm trying to follow timmytimaz's guide but am not getting very far. I don't have the option to enable SSH on my Admin > System page. Anyone have any suggestions to enable SSH? I'm on f/w 3.0.0.4.376_3181  using Google chrome. I've tried to look through the html of the page to see if it's there but blocked and haven't found anything.

Thx

mike

Reply