Solved

Why No TM-AC1900 Firmware Updates

  • 5 February 2015
  • 54 replies
  • 7556 views

Hello,

 

There haven't been any Asus firmware updates to this router, if you go to the Asus website there are still none listed.  But if you look up the RT-AC68U which this router is based off of there are a lot of recent updates.

 

Concerning?

 

Thanks

icon

Best answer by bst82551 31 March 2015, 04:46

There's a new update out. I don't see any new features, but maybe they fixed some of the wifi calling issues and addressed some of the security concerns.

The update must be done manually. I left instructions on how to do that about 10 posts into this thread:

Thread-87613

Mod edit: You can get the firmware patch notes here: Cellspot router firmware update information 😊

View original

54 replies

Firmware updated yesterday to: 3.0.0.4.376_3199.  Happened automatically from what I can tell.....

Hey jabv,

I have the TM-AC1900 router and am having issues with the 5G dropping down to 2.4G and it is really slow. I am only a few feet away and the signal drops already which makes me frustrated lol. I am currently on f/w 3.0.0.4.376_3181

It does not have SSH. How do I downgrade to the right firmware with SSH? Should I follow all the steps listed on decepticlone? I'm scared it might brick my router which i am renting from T-mobile.

Thanks!

Okay I found how to change the firmware from t-mobile's default firmware.  In order to enable SSH you have to downgrade your router to an older firmware version.  Full tutorial and older firmware available at these sites:

https://decepticlone.com/?p=1653

Slickdeals.net - View Single Post - T-Mobile Personal CellSpot AC Router by Asus - Free for postpaid ($25 deposit)

Same problem here as cosmichippo.  I don't have the option to enable SSH in the Administration -> System page.

Is there another way to enable SSH on this router firmware?  3.0.0.4.376_3181

Really want to install a different firmware from the t-mobile stock firmware.

I'm trying to follow timmytimaz's guide but am not getting very far. I don't have the option to enable SSH on my Admin > System page. Anyone have any suggestions to enable SSH? I'm on f/w 3.0.0.4.376_3181  using Google chrome. I've tried to look through the html of the page to see if it's there but blocked and haven't found anything.

Thx

mike

Userlevel 6
Badge +13

The update was available several months ago, but you might have just updated recently either automatically somehow or by searching for an update in the router interface.

Noticed an update this morning to my TM-AC1900. It shows: 3.0.0.4.376_3181  Not sure when this happened.

Userlevel 6
Badge +13

If you remove the stock firmware, you remove the T-Mobile optimization.

@ timmytimaz Greetings thanks for the tutorial. My question to you is: Do you know if flashing the RT68U firmware removes the Tmobile wifi call prioritization feature? thx

Thanks!

I did not have to downgrade to get the 64MB partition. Woot.

From my device:

df -h

/dev/mtdblock4           62.8M      1.8M     61.0M   3% /jffs

Anytime 😊

Let me know if you have any other questions and I'll try my best to help!

Thanks for the response!!! 😊

You don't need a lower firmware version to jump to first. Flashing the newest firmware from Asus took it to 64mb

I'll pose the question to @foamcowadv‌ and @danny.villarreal‌ too . . . did you guy notice if the rootfs partition increased to 64MB?  Or did you have to use an intermediate firmware first, then go to the latest?

Thanks!

@timmytimaz

Thanks for the instructions!  I can't wait to try it.  I have a question though . . . all of the other instructions I saw mentioned going to an intermediate firmware first in order to change the /jffs partition from 32MB to 64MB . . . have you confirmed that your method does that?  I.e, does 'df -h' show the bigger partition size?

Thanks again for your good work and for sharing! 😊

Does this new firmware keep T-mobile's patented wifi-calling prioritization feature?

I would like to try this soon but was curious, can I follow this procedure on an ASUS RT-AC66U or any router for that matter? I have an RT-AC66U and TM-AC1900 and want to put Advanced Tomato on both. I was considering Asus Merlin as well but I didn't like that they pointed out on the dev page that they specifically don't target new features very often. May not be an issue but I always like Tomato on my old Linksys router a long time ago.

Great guide! I got the router for free and have to return it at some point, so if I flash it with newer Asus firmware, will I be able to put stock firmware back in the future or how could I do this?

That's awesome, you guys! I'm glad it worked for you too 😊

This is a really nice device and it's a shame T-Mo doesn't keep it updated. The new firmware fixes a ton of bugs I was having with this thing. Oh well.... All good now!

@timmytimaz - Excellent instructions! I cannot thank you enough for simplifying the firmware replacement process.  I am comfortable with scripting, etc., but I was leery of the instructions found on the slickdeals site.

I did have an issue:

The reboot cmdlet didn't work in the PUTTY session.

I waited about 5 minutes and then power-cycled the router.  After that, everything is working as advertised.

Woot!.

This worked perfectly.  Thank you very much for these easy instructions.

Here's a way to force whatever firmware you want. NOTE - this will void your warranty on the device.

Don't rely on T-Mobile for firmware updates because you will not get timely through them. Not sure why but their firmware is very far behind the actual device this router is based on which is the Asus RT-AC68U. The current firmware (at time of writing 12/2016) is version 3.0.0.4.380.4164.

You cannot flash this firmware directly from the router's admin page but you can force flash it by using some common SSH commands. Here's a quick guide on that process. Don't do this if you are uncomfortable with typing at a command prompt.

1. Download the current firmware version that you want. (Look into Asus Merlin firmware as well. Really cool stuff)

2. Download Putty (ssh client) and WinSCP (SCP & SFTP client)

3. Log into your router and go to Administration > System and enable SSH. Click Apply

4. Open WinSCP and change the protocol to SCP, type in your router's IP address (192.168.0.1)

5. Log in with your router's admin account (or whatever acount you setup)

6. Verify that the right-hand pane of WinSCP is in the /tmp/home/root directory

7. In the left pane find the firmware that you downloaded and drag it over to the right pane (/tmp/home/root)

8. Once that completes open Putty and use the same router IP address that you used above

9. Log in with you router's admin account. Congrats, you have root access to YOUR router

10. Type the following commands (In Italics) below in Putty, pressing Enter after each one:

cd /tmp/home/root/

ls


(You should see your firmware listed after this command)

/sbin/mtd-write2 /tmp/home/root/your-firmware.trx linux && reboot

Congrats, you have flashed an official or aftermarket firmware on the router!

Once it reboots, sign back in through your router's admin page and verify that your previous settings are still applied. Being a T-Mobile device I found that after the flash I could not get to T-Mobile.com but that was an easy fix...

Log into the router and go to LAN > DHCP Server. In the field labeled TM-AC1900's Domain Name, delete T-Mobile.com and click Apply. You should now be able to get to their website.

Report back with your results 😊

Mine hasn't gotten the update after multiple checks. Is there a way to do this manually?

It has a Traffic Manager tab that seems to include the Adaptive QoS and Traffic Analyzer. No AiProtection or AiCloud tabs. I have not poked around the new UI very much.

Reply