Solved

WIFI Calling doesn't work LTE turned on

  • 12 February 2019
  • 15 replies
  • 3661 views

I have a iPhone 6S.   WHen I am at home, or anywhere for that matter, I can't get wifi calling to work.  My coverage at home isn't too good so I often miss cell calls.  I was playing around yesterday and

1) Went into settings

2) Selected Cellular

3) Selected Cellular Date Options

4) Went to Enable LTE and turned it off.

 

Now WIFI calling works.  However, at the most I get is 4G on my phone, no more LTE.

 

Problem with the phone or is this the way it is supposed to work?

 

Dennis

icon

Best answer by skymorena 12 February 2019, 18:55

You won't have LTE since you turned off your Enable LTE option.

Then follow this instructions to turn on your Wi-Fi calling to your device.

  1. Register your E911 address at My T-Mobile.
  2. Turn on Wi-Fi and connect to a Wi-Fi network.
  3. From the Home screen, tap Settings > Phone > Wi-Fi Calling.
  4. If you have an iPhone with an eSIM, tap the line you're making changes to.
  5. Tap the slider next to Wi-Fi Calling on this phone to turn Wi-Fi Calling on.
  6. Tap Update Emergency Address.
  7. Enter your E911 address and tap Save.
View original

15 replies

if you can't turn on or use Wi-Fi Calling, make sure that your carrier offers Wi-Fi Calling and that your devices have the latest software. Then, follow these steps - 

Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on.
Restart your iPhone.
Connect to a different Wi-Fi network. Not all Wi-Fi networks work with Wi-Fi Calling.
Turn Wi-Fi Calling off and then on again.https://prepaidcardstatus.link/
Go to Settings > General > Reset and tap Reset Network Settings.

if you can't turn on or use Wi-Fi Calling, make sure that your carrier offers Wi-Fi Calling and that your devices have the latest software. Then, follow these steps if you can't turn on Wi-Fi Calling or make a Wi-Fi call. Wait two minutes before you go from one step to the next.

Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on.
Restart your iPhone.
Connect to a different Wi-Fi network. Not all Wi-Fi networks work with Wi-Fi Calling.
Turn Wi-Fi Calling off and then on again.https://postalexperiencecompos.tech
Go to Settings > General > Reset and tap Reset Network Settings.

So after 5 months of issues it is finally fixed.  T-mobile tech support suggested a cell signal booster so that I wouldn't need to use wifi calling.  I've been using it for 3 days now and it is flawless.  Only cost $25 one time fee no monthly fee.  I get full bars cell signal in my home.  It has to hard wire via lan which wasn't a problem for me.  

Same issue here on an iPhone 11 Pro (iOS 14). Had always worked fine before when recently I noticed it had stopped working suddenly after I upgraded my router. Android devices work fine.

Switching off LTE and the phone connects immediately to WiFi calling.

EDIT:
Found this on T-Mobile’s webpage: https://www.t-mobile.com/support/devices/apple/apple-ios-11/wi-fi-calling-apple-iphone-on-ios-11

Set connection preference

  • You can't set the connection preference on an iPhone.
  • The connection preference is 4G LTE > Wi-Fi Calling > 4G > 3G > 2G.
  • If you're in a 4G LTE area and want to force a connection to Wi-Fi Calling, you must turn off LTE.

 

Pixel  2 here. Same issue as described June 2020. Wifi i calling is intermittent. Nobody has a straight answer or cure for the problem. Just came from Verizon and Verizon wifi calling worked flawlessly. TMobile works great everywhere I go... Except my home

 

You won't have LTE since you turned off your Enable LTE option.

Then follow this instructions to turn on your Wi-Fi calling to your device.

  1. Register your E911 address at My T-Mobile.
  2. Turn on Wi-Fi and connect to a Wi-Fi network.
  3. From the Home screen, tap Settings > Phone > Wi-Fi Calling.
  4. If you have an iPhone with an eSIM, tap the line you're making changes to.
  5. Tap the slider next to Wi-Fi Calling on Prepaid Card Status this phone to turn Wi-Fi Calling on.
  6. Tap Update Emergency Address.
  7. Enter your E911 address and tap Save.

Wow, huge article but very useful. Thanks.

skymorena wrote:

You won't have LTE since you turned off your Enable LTE option.

Then follow this instructions to turn on your Wi-Fi calling to your device.

  1. Register your E911 address at My T-Mobile.
  2. Turn on Wi-Fi and connect to a Wi-Fi network.
  3. From the Home screen, tap Settings > Phone > Wi-Fi Calling.
  4. If you have an iPhone with an eSIM, tap the line you're making changes to.
  5. Tap the slider next to Wi-Fi Calling on this phone to turn Wi-Fi Calling on.
  6. Tap Update Emergency Address.
  7. Enter your E911 address and tap Save.

I am really happy to say it’s an interesting post to read.

I learn new information from your article , you are doing a great job.

Keep it up.

I just switched to T mobile from Verizon and I brought my iPhone 11 Pro Max over. Previously on Verizon I could make WiFi calls but now I can’t since switching. Tech support keeps giving me the run around but it won’t make calls if there is no cell signal. I work in hospitals where coverage isn’t available in certain spots and it’s annoying not being able to send and receive calls. Clearly this seems to be an issue based on the other posts. It doesn’t change anything for me if I turn off LTE. Does anyone else have the same issue or have found a solution? T mobile is checking with their engineers but based on this working previously with Verizon I think it’s a T mobile thing.

This exact same thing is happening to me on my iPhone 8 (13.3.1).

Thank you for posting.  This is the only workaround I've found to get wi-fi calling to work again.

As described, if I disable LTE my phone immediately starts using T-Mobile Wi-Fi for service and everything works fine.  If i turn LTE back on, my phone immediately drops the Wi-Fi calling network and loses all service (as I'm in a dead zone).

I just wanted to chime in and confirm that on my iPhone 11 it's sporatic. Sometimes it'll say TMobile Wifi and sometimes it'll try the cellular network. It doesn't seem to matter the signal strength. It could be 1 bar and highly unlikely to actually be able to make a call, and it won't even attempt Wifi. I've tried rebooting, setting the 911 address and switching off LTE. It's very random and very irritating. It's like someone didn't even bother to test the feature in locations with a less than perfect signal or something.

I Have the same Problem with my Iphone 11 Pro Max

Wifi Calling is enabled on my Iphone, when it connects to a Wifi Network, sometimes Wifi Calling works ... 

My 911 information was correct, but I went through the process again.  Works sporadically.    Like right now, WiFi calling was not enabled.  I turned off the LTE option, and immediately T-Mobile WiFI appeared on my phone.   I just turned LTE back on, and the WiFi calling display disappeared.

Userlevel 5

Hey, Dennis!

Any luck with updating your E911 address? If you've updated it and are still having issues, please let us know.

Userlevel 6
Badge +14

Updating the E911 address is a good idea. You should give that a shot and test it out to see if that fixes the issue.

You won't have LTE since you turned off your Enable LTE option.

Then follow this instructions to turn on your Wi-Fi calling to your device.

  1. Register your E911 address at My T-Mobile.
  2. Turn on Wi-Fi and connect to a Wi-Fi network.
  3. From the Home screen, tap Settings > Phone > Wi-Fi Calling.
  4. If you have an iPhone with an eSIM, tap the line you're making changes to.
  5. Tap the slider next to Wi-Fi Calling on this phone to turn Wi-Fi Calling on.
  6. Tap Update Emergency Address.
  7. Enter your E911 address and tap Save.

Reply