Question

Wifi Calling not working - Germany

  • 7 November 2020
  • 5 replies
  • 289 views

Badge

I’m in Germany and WiFi Calling doesn’t work.  On my network status it says “T-Mobile Wi-Fi Calling” but when I try to call the US (even T-Mobile!!) it says “your wireless carrier does not allow calls to the number you have dialed”.

I tried to call T-Mobile using the international support number and it said I did not have enough money in my prepaid account… even though I do, and it’s on auto pay…


I’ve restarted the phone multiple times.  I’ve toggled WiFi calling off and on multiple times.  Your network is screwed up and I can’t even call you to get help!

 

The internet I’m using is even T-Mobile (German T-Mobile).

 

Phone:

Pixel 3a XL


5 replies

Userlevel 6
Badge +13

Have you tried putting the device into Airplane Mode and then turning on WiFi only?  It sounds like it is still trying to use cellular, which you want to eliminate.  Perhaps the internet where you are isn’t fast enough to use WiFi Calling properly, kicking it back to cellular.  Putting the device in Airplane Mode and turning back on WiFi will force it to try and use WiFi Calling.  Is your e911 address setup on your account?  This needs to be done in order to use WiFi Calling.  

Userlevel 5
Badge +7

Is your phone set to WiFi Preferred or WiFi-only?

Have you tried the Airplane Mode trick that @syaoran suggested?

What is the format of the number you are dialing?

Have you tried calling +1-505-998-3793 while on WiFi Calling?

P.S. It’s always a good idea to have a small Viber-out or Skype-out credit for situations like this.

Badge

I’ve tried Wi-Fi only. I’ve tried turning off mobile data.  Nothing works. 

 

Calling the 505 number tells me I don’t have enough credit in my account.  When I go to my account, all is well.

 

My internet:

17ms ping

50mbps down

9mbps up.

Voice communications requires almost no bandwidth anyway.

This is BS.

Userlevel 6
Badge +13

That is more than enough for WiFi Calling.  Perhaps try contacting T-Mobile's T-Force Team via Facebook or Twitter to see if they can help you out further. 

Badge

I can confirm that a T-Mobile eSIM with T-Mobile Connect (prepaid) works abroad as described by the original poster.

I am in the UK and whereas it connects to wifi calling all call attempts end up with the “your wireless carrier does not allow calls to the number you have dialled”

I have, however, managed to make it work under very strict conditions. First, you can only use airplane mode with this SIM. If at anytime you activate the cellular/mobile network, it will revert to the above behaviour.

So, if, like me, you have a local SIM too in your iPhone, whenever you go out and need to connect to the mobile network, first turn off the t-Mobile line in settings. I cannot stress this enough.

Usually, if you turn off the line, restart the phone, select airplane mode and then turn on the T-Mobile line it will work over wifi calling as if you were in the USA. You’ll be able to make and receive calls and texts.

But if you forget to disable the T-Mobile line before connecting the cellular network, it will be unable to make and receive calls again, although you can send and receive texts.

This is a crappy feature of T-Mobile. I understand that because roaming is not allowed in prepaid, if you try to connect to a foreign mobile carrier they will detect it and block your calling. For some reason this will also affect wifi calling.

If anyone from T-Mobile reads this, please change this awful behaviour. It is okay you block roaming from the cellular network, but please, do not block it with wifi calling. And yes, you do it, do not say you don’t.

 

Reply